summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/tho-puppet-bootstrap')
-rw-r--r--app-admin/tho-puppet-bootstrap/ChangeLog8
-rw-r--r--app-admin/tho-puppet-bootstrap/Manifest4
-rw-r--r--app-admin/tho-puppet-bootstrap/metadata.xml10
-rw-r--r--app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.1.0.ebuild24
4 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/tho-puppet-bootstrap/ChangeLog b/app-admin/tho-puppet-bootstrap/ChangeLog
new file mode 100644
index 0000000..b13a33b
--- /dev/null
+++ b/app-admin/tho-puppet-bootstrap/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-admin/tho-puppet-bootstrap
+# Copyright 2014-2014 Thomas Carrie; Distributed under the GPL v2
+# $Header: $
+
+*tho-puppet-bootstrap-0.1.0 (08 Nov 2014)
+
+ 08 Nov 2014; Thomas Carrie <tocaro@thocar.org> :
+ Initial import.
diff --git a/app-admin/tho-puppet-bootstrap/Manifest b/app-admin/tho-puppet-bootstrap/Manifest
new file mode 100644
index 0000000..fafd28b
--- /dev/null
+++ b/app-admin/tho-puppet-bootstrap/Manifest
@@ -0,0 +1,4 @@
+DIST tho-puppet-bootstrap-0.1.0.tar.gz 3284 SHA256 eac8ce860b8d9b6f15d82e1ee164ba258a18a30cb494365fc297e1fc9334b0bf SHA512 ce49023536b5317ff0f5a53ad2b796ae439d541b9a95bc74dc9cc3f54512173d2ae28bda8264f0b84a28f6ef042808260f9025643fe33fe08f3d6027ac640436 WHIRLPOOL 826c6cd29527a08b3187ce2c823742b7989f8500a5c8ad32ed01078cef6848e0f40d8d1a162f8a6c37928d1d3c985ce6f01e910c449b3e6be22dac7fdc08a218
+EBUILD tho-puppet-bootstrap-0.1.0.ebuild 599 SHA256 64748536958a84f88ac29768fc1083b52fedfaffb538cdaf307ff233f54d415d SHA512 b9030c2222fa8f818b5d0a6e5d88bcee96474902f5cc074fbaaf0bd43057d13f07f10703bf51c85a18d43ddf60c9b342193121a8f2c11034369f2d0637964304 WHIRLPOOL 70090b8baaa1b8db49f35f61dd19a8afde142f65e7a61ec65c814fdbfee4104ae89abb2a42561f0cdfbb80679b3f63ac6b2d2223f8439a266373a3a58e34f3f2
+MISC ChangeLog 239 SHA256 3b6dd1850fcae4a5fc90002b445bc72136f34c92b804200622af5a2a2c5bab4b SHA512 566de4d7726a77b27e03f50442a00a54761c2554c807b9eee907174049f457ad84a40fd0e38b7790dd8f02e796b0ba7e45fa9c6c23761d50c3142c0291f51bd5 WHIRLPOOL 063baf330900073c2296e8ffd1fd0b413b08b1616d57b27670100516057c9fda71814ccff3dc41c8ba56a04781ae083110a7bcfa959f0573def7b537a7236445
+MISC metadata.xml 475 SHA256 385fd9023cf35f214f91c664863a06079c78152af28c5228afb07b3ce5a9a152 SHA512 a757306fe851d8180703206bf9d1352bcdadde25b1819a46c558dc9aa6563b078afa5823e2044bc11c9299eb941eb34fc44bece9508208052be2b458caa1c856 WHIRLPOOL 2aeaf66ae90e315e64bb61d1218a5ecfce51fac2f43f68df1eb81005ee315faed781838304640311338dd5102e09d2f1c905983c587e6cd62fb91d0781a0ae47
diff --git a/app-admin/tho-puppet-bootstrap/metadata.xml b/app-admin/tho-puppet-bootstrap/metadata.xml
new file mode 100644
index 0000000..efed7c0
--- /dev/null
+++ b/app-admin/tho-puppet-bootstrap/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- http://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/ -->
+ <!-- herd>not maintained by a herd</herd-->
+ <maintainer>
+ <email>tocaro@thocar.org</email>
+ </maintainer>
+ <longdescription>If you use rdiff-backup, you probably would like to have a script to put in the crontab to monitor your rdiff backup</longdescription>
+</pkgmetadata>
diff --git a/app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.1.0.ebuild b/app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.1.0.ebuild
new file mode 100644
index 0000000..b04caf8
--- /dev/null
+++ b/app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2013-2014 Thomas Carrie
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="If you want to use puppet without the puppet server, you can use it via git with a recent puppet setup via rubygems"
+HOMEPAGE="http://thocar.org/tarballs/"
+SRC_URI="http://thocar.org/tarballs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=dev-vcs/git-1.7.0
+ virtual/rubygems"
+
+src_install() {
+ # http://devmanual.gentoo.org/function-reference/install-functions/
+ dobin thoPuppetBootstrap
+}