aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/neo4j-community')
-rw-r--r--dev-db/neo4j-community/ChangeLog9
-rw-r--r--dev-db/neo4j-community/Manifest4
-rw-r--r--dev-db/neo4j-community/metadata.xml8
-rw-r--r--dev-db/neo4j-community/neo4j-community-1.7.ebuild45
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-db/neo4j-community/ChangeLog b/dev-db/neo4j-community/ChangeLog
new file mode 100644
index 0000000..ea01ad4
--- /dev/null
+++ b/dev-db/neo4j-community/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-db/neo4j-community
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header:$
+
+*neo4j-community-1.7 (23 Apr 2012)
+
+ 23 Apr 2012; Leonardo Martins <leonardo@venidera.com>
+ +neo4j-community-1.7.ebuild, +metadata.xml:
+ Initial commit.
diff --git a/dev-db/neo4j-community/Manifest b/dev-db/neo4j-community/Manifest
new file mode 100644
index 0000000..7f2e3d6
--- /dev/null
+++ b/dev-db/neo4j-community/Manifest
@@ -0,0 +1,4 @@
+AUX neo4j.init 0 RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 SHA1 da39a3ee5e6b4b0d3255bfef95601890afd80709 SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
+DIST neo4j-community-1.7-unix.tar.gz 36220025 RMD160 0cbd5da70b19e4ca4fb4e0dfa4d82ba72e51eeed SHA1 f18a7539bd5ad1df2b91b4f17ecce36f1902ab59 SHA256 b9f626878624d9a7b9408c6213dec6d82c13c62e86a037b489dc335e31c4d993
+EBUILD neo4j-community-1.7.ebuild 873 RMD160 e75fb020d475d8625504ad9518e172123abea993 SHA1 6effdf8c94bbda29008c65a821f04c346f04a2ee SHA256 de8b3c6b3bb64fb65955ae927fc16a15041b33573b0e2d47200f2cf358f976db
+MISC ChangeLog 0 RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 SHA1 da39a3ee5e6b4b0d3255bfef95601890afd80709 SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
diff --git a/dev-db/neo4j-community/metadata.xml b/dev-db/neo4j-community/metadata.xml
new file mode 100644
index 0000000..8e95404
--- /dev/null
+++ b/dev-db/neo4j-community/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <name>Leonardo Martins</name>
+ <email>leonardo@venidera.com</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-db/neo4j-community/neo4j-community-1.7.ebuild b/dev-db/neo4j-community/neo4j-community-1.7.ebuild
new file mode 100644
index 0000000..bc03c42
--- /dev/null
+++ b/dev-db/neo4j-community/neo4j-community-1.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Neo4j is a high-performance, NOSQL graph database with all the features of a mature and robust database."
+HOMEPAGE="http://neo4j.org/"
+SRC_URI="http://dist.neo4j.org/${PN}-${PV}-unix.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="!dev-db/neo4j-advanced
+ !dev-db/neo4j-enterprise
+ >=virtual/jre-1.6
+ sys-process/lsof"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ insinto /opt/neo4j
+ dodir /opt/bin
+
+ doins -r * || die
+ fperms 0700 /opt/neo4j/bin/neo4j
+ fperms 0700 /opt/neo4j/bin/neo4j-shell
+ fperms 0700 /opt/neo4j/bin/utils
+
+ # create symlinks
+ dosym /opt/neo4j/bin/neo4j /opt/bin/neo4j
+ dosym /opt/neo4j/bin/neo4j-shell /opt/bin/neo4j-shell
+}