summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVance M. Allen <vma_gentoo@vmacs.us>2016-09-11 20:23:10 -0600
committerVance M. Allen <vma_gentoo@vmacs.us>2016-09-11 20:23:10 -0600
commit9cff1d992a7c1cc083e09e95d77b174187a8ba2a (patch)
tree8d3738a1d587f2d85e6bc681d3c83a4377265c32
parentAdd support for phpMyAdmin-4.0.10.17, -4.4.15.8, and -4.6.4 (diff)
downloadvmacs-9cff1d992a7c1cc083e09e95d77b174187a8ba2a.tar.gz
vmacs-9cff1d992a7c1cc083e09e95d77b174187a8ba2a.tar.bz2
vmacs-9cff1d992a7c1cc083e09e95d77b174187a8ba2a.zip
Add support for Joomla 3.6.2
-rw-r--r--www-apps/joomla/Manifest2
-rw-r--r--www-apps/joomla/files/postinstall-en.txt29
-rw-r--r--www-apps/joomla/files/postinstall-sv.txt26
-rw-r--r--www-apps/joomla/joomla-3.6.2.ebuild50
4 files changed, 107 insertions, 0 deletions
diff --git a/www-apps/joomla/Manifest b/www-apps/joomla/Manifest
new file mode 100644
index 0000000..b5ed450
--- /dev/null
+++ b/www-apps/joomla/Manifest
@@ -0,0 +1,2 @@
+DIST Joomla_3.6.2-Stable-Full_Package.tar.bz2 6884960 SHA256 96c537c69ed86852e5af27864ee612fda3df9bd14460d28f8f2c6ba04a1aea1e SHA512 53603a3d1f0b3f899c3d28f2c13773202a2f5e3cfa0206605bee87550f3a644b54e148a5750fe4f66d0fc3e2fe774d953e497e00dda2aa922888a547deea0354 WHIRLPOOL 4b9655d5d3f2e13913b04ce31fbe3972fc96b0dc66bf64acaf6f3da3a2e94767ab0fdef8f9fb3c948bada0c403f0dd6cfa8fe730a1e2ea5ddf89bc088f610eab
+EBUILD joomla-3.6.2.ebuild 1495 SHA256 067b3acb66b27bc45d8e35407cd9970eebc4836e0b9cfd9cf754d401a09e5b4e SHA512 25b5d1210902d8154b9201cbd99a326a5f099ec641af68430441d67412d953eb9b21ed58ea2ac9a458e04a3af088b12dd9c78b8d6cae96d0842c2023b296da51 WHIRLPOOL 054705d2e9165a7a3c0fe194b1e95e0e89c45aaaebe6d737111d794dd3ed3d146d2a3b3e60777a1316076d947c0304f11daabf6f7f27024fc5305611cf3130e6
diff --git a/www-apps/joomla/files/postinstall-en.txt b/www-apps/joomla/files/postinstall-en.txt
new file mode 100644
index 0000000..8f940d6
--- /dev/null
+++ b/www-apps/joomla/files/postinstall-en.txt
@@ -0,0 +1,29 @@
+You are almost done!
+
+ 0. Make sure your database server is initialized and started,
+ and that you have the login details of a user who can create a database.
+
+ 1. Login on http://${VHOST_HOSTNAME}/${VHOST_APPDIR}
+ and finish the installation.
+
+ If the installation hangs, you might want to modify your php.ini:
+
+ max_execution_time = 3000 ;
+ memory_limit=128M ;
+
+ 2. Move into the directory where you installed Joomla and remove
+ the "installation" folder:
+
+ # cd ${MY_INSTALLDIR}
+ # rm -rf installation
+
+ 3. You can now launch your browser and point it to your Joomla site e.g.
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR} -> Main Site
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/administrator -> Admin
+
+ You can log into the administration view using the username 'admin'
+ along with the password that was generated or you chose during the
+ web based installation.
+
+ Enjoy Joomla!
diff --git a/www-apps/joomla/files/postinstall-sv.txt b/www-apps/joomla/files/postinstall-sv.txt
new file mode 100644
index 0000000..4c1f706
--- /dev/null
+++ b/www-apps/joomla/files/postinstall-sv.txt
@@ -0,0 +1,26 @@
+Du är nästan klar!
+
+ 0. Se till att du har installerat och startat en databasserver,
+ och att du har en användare som får skapa databaser.
+
+ 1. Surfa in på http://${VHOST_HOSTNAME}/${VHOST_APPDIR}
+ för att slutföra installationen.
+
+ Om installationen hänger sig, kan det vara en idé att ändra php.ini så här:
+
+ max_execution_time = 3000 ;
+ memory_limit=128M ;
+
+ 2. Ta bort installationsmappen:
+
+ # cd ${MY_INSTALLDIR}
+ # rm -rf installation
+
+ 3. Surfa in på din nya Joomla sida:
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR} -> Main Site
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/administrator -> Admin
+
+ Logga in till adminvyn med användarnamn 'admin' och det lösenord som du valt under installationsprocessen ovan.
+
+
diff --git a/www-apps/joomla/joomla-3.6.2.ebuild b/www-apps/joomla/joomla-3.6.2.ebuild
new file mode 100644
index 0000000..e3ead25
--- /dev/null
+++ b/www-apps/joomla/joomla-3.6.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit webapp versionator
+
+MY_PV=$(replace_version_separator '_' '-')
+
+DESCRIPTION="A powerful Open Source Content Management System"
+HOMEPAGE="http://www.joomla.org/"
+M_PN="Joomla_${MY_PV}-Stable-Full_Package"
+SRC_URI="https://github.com/${PN}/${PN}-cms/releases/download/${MY_PV}/${M_PN}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+S="${WORKDIR}"
+need_httpd_cgi
+
+RDEPEND=">=dev-lang/php-5.3.10[json,zlib,xml]
+ virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[postgres] )"
+
+src_install () {
+ webapp_src_preinst
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files=" administrator/cache administrator/components
+ administrator/language administrator/language/en-GB
+ administrator/manifests/packages
+ administrator/modules administrator/templates cache components images installation
+ images/banners language language/en-GB media modules plugins
+ plugins/authentication plugins/content plugins/editors plugins/editors-xtd
+ plugins/search plugins/system plugins/user plugins tmp templates"
+
+ for file in ${files}; do
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postinst_txt sv "${FILESDIR}"/postinstall-sv.txt
+ webapp_src_install
+}