summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIskren Slavov <iskren.s@gmail.com>2010-06-20 09:24:59 +0300
committerIskren Slavov <iskren.s@gmail.com>2010-06-20 09:24:59 +0300
commit05a929053565facff8d59e477a973cf5a2308022 (patch)
tree3858653ab7d8aa9087a4695af213151f50571fa5 /net-p2p/flush/flush-0.9.6.ebuild
parentGIMP 2.7.0 ebuild added and a mysql-workbench ebuild that does not need exper... (diff)
downloadwish-05a929053565facff8d59e477a973cf5a2308022.tar.gz
wish-05a929053565facff8d59e477a973cf5a2308022.tar.bz2
wish-05a929053565facff8d59e477a973cf5a2308022.zip
Updated flush. Added trickle. Some small fixes
Diffstat (limited to 'net-p2p/flush/flush-0.9.6.ebuild')
-rw-r--r--net-p2p/flush/flush-0.9.6.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-p2p/flush/flush-0.9.6.ebuild b/net-p2p/flush/flush-0.9.6.ebuild
new file mode 100644
index 0000000..168c158
--- /dev/null
+++ b/net-p2p/flush/flush-0.9.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils distutils flag-o-matic
+
+DESCRIPTION="A GTK-based BitTorrent client by Dmitry Konishchev"
+HOMEPAGE="http://sourceforge.net/projects/flush/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.16.6
+ >=dev-cpp/gtkmm-2.16.0
+ >=dev-cpp/glibmm-2.20.1
+ >=x11-libs/libnotify-0.4.5
+
+ >=sys-devel/gettext-0.17
+ >=dev-libs/libconfig-1.3.2
+ >=dev-libs/boost-1.35.0
+ >=sys-apps/dbus-1.2.3
+
+ >=net-libs/rb_libtorrent-0.14.8"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --disable-bundle-package \
+ --enable-system-libconfig \
+ --enable-system-libtorrent
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc COPYING ChangeLog
+
+ # Fix icon if using different icon theme in GNOME
+ insinto /usr/share/pixmaps
+ doins ./icons/hicolor/72x72/apps/flush.png
+
+ ewarn
+ ewarn There seems to be some incompability with older version
+ ewarn configuration files. If Flush seems to be unstable or
+ ewarn too slow you can fix this with 'rm -rf ~/.flush'.
+ ewarn
+ ewarn WARNING: This will remove all your loaded torrent files.
+ ewarn
+}