summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/backintime/backintime-1.0.2.ebuild88
-rw-r--r--app-backup/flyback/Manifest2
-rw-r--r--app-backup/flyback/flyback-0.6.5-r1.ebuild56
3 files changed, 58 insertions, 88 deletions
diff --git a/app-backup/backintime/backintime-1.0.2.ebuild b/app-backup/backintime/backintime-1.0.2.ebuild
deleted file mode 100644
index 3a68168..0000000
--- a/app-backup/backintime/backintime-1.0.2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="A simple backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
-HOMEPAGE="http://backintime.le-web.org/"
-SRC_URI="http://backintime.le-web.org/download/backintime/${P}_src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="kde gnome"
-
-DEPEND="dev-lang/python
- net-misc/rsync[xattr,acl]
- kde? (
- >=kde-base/kdelibs-4
- kde-base/pykde4
- kde-base/kompare
- kde-base/kdesu
- )
- gnome? (
- gnome-base/libglade
- gnome-base/gnome-session
- dev-python/gnome-vfs-python
- dev-python/gnome-python
- )
- dev-python/notify-python
- "
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- #fix doc install location
- sed -i "s:/doc/kde4/HTML/:/doc/HTML/:g" kde4/Makefile.template
- sed -i "s:/doc/backintime:/doc/${PF}:g" common/Makefile.template
-}
-
-src_configure() {
- cd "${S}"/common
- econf
-
- if use kde ; then
- cd "${S}"/kde4
- econf
- fi
-
- if use gnome ; then
- cd "${S}"/gnome
- econf
- fi
-}
-
-src_compile() {
- cd "${S}"/common
- emake
-
- if use kde ; then
- cd "${S}"/kde4
- emake
- fi
-
- if use gnome ; then
- cd "${S}"/gnome
- emake
- fi
-}
-
-src_install() {
- cd "${S}"/common
- emake DESTDIR="${D}" install || die
-
- if use kde ; then
- cd "${S}"/kde4
- emake DESTDIR="${D}" install || die
- #use kdesu instead of kdesudo
- sed -i 's/kdesudo/kdesu/' \
- "${D}"//usr/share/applications/kde4/backintime-kde4-root.desktop
- fi
-
- if use gnome ; then
- cd "${S}"/gnome
- emake DESTDIR="${D}" install || die
- fi
-}
diff --git a/app-backup/flyback/Manifest b/app-backup/flyback/Manifest
new file mode 100644
index 0000000..7cac56d
--- /dev/null
+++ b/app-backup/flyback/Manifest
@@ -0,0 +1,2 @@
+DIST flyback-lucid_0.6.5-1_all.deb 37668 RMD160 5c5e7938363943191c804a22ec25002a4acc02c9 SHA1 452d2e3d5658dce13244bda8346aa54b3cc3a1a6 SHA256 bdc68049afed5837e9fd110ae3d3b6b2e6a773866bec97f97ddae8f0df96bb16
+EBUILD flyback-0.6.5-r1.ebuild 1217 RMD160 5bb93ebc764a9bc99f533979f63e4d49acaf62be SHA1 99126f057dc473b09df0eb4fb74ad2d3458322ed SHA256 44b44323c2d5da6598de90d427ac9d74de141ab14ca4493e6e73159b9cee254a
diff --git a/app-backup/flyback/flyback-0.6.5-r1.ebuild b/app-backup/flyback/flyback-0.6.5-r1.ebuild
new file mode 100644
index 0000000..0db4a27
--- /dev/null
+++ b/app-backup/flyback/flyback-0.6.5-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+DESCRIPTION="Apple's Time Machine alternative for Linux"
+HOMEPAGE="http://code.google.com/p/flyback/"
+SRC_URI="http://flyback.googlecode.com/files/flyback-lucid_0.6.5-1_all.deb"
+
+IUSE=""
+SLOT="0"
+LICENSE="UNKNOWN"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip mirror"
+
+DEPEND=">=dev-lang/python-3.1.2
+ >=dev-util/glade-3.6.7[gnome,python]
+ >=gnome-base/libglade-2.6.4
+ >=dev-vcs/git-1.7.2.2"
+RDEPEND="${DEPEND}"
+
+BASE_DIR="usr/share"
+INSTALL_DIR="/${BASE_DIR}"
+
+src_unpack() {
+ unpack ${A}
+ unpack ./data.tar.gz
+}
+
+src_install() {
+ // Python files
+ insinto "${INSTALL_DIR}/flyback"
+ for file in "${BASE_DIR}/flyback/*";
+ do
+ doins ${file}
+ done
+
+ // Glade files
+ insinto "${INSTALL_DIR}/flyback/glade"
+ for file in "${BASE_DIR}/flyback/glade/*";
+ do
+ doins ${file}
+ done
+
+ // Executable file
+ exeinto "${INSTALL_DIR}/flyback"
+ doexe "${BASE_DIR}/flyback/flyback.py"
+
+ // Changelog
+ dodoc "${BASE_DIR}/doc/flyback/changelog.Debian.gz"
+
+ // Icon
+ exeinto "${INSTALL_DIR}/applications"
+ doexe "${BASE_DIR}/applications/flyback.desktop"
+}
+