summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/playonlinux/Manifest2
-rw-r--r--app-emulation/playonlinux/playonlinux-3.8.3.ebuild90
-rw-r--r--app-text/madedit/Manifest2
-rw-r--r--app-text/madedit/madedit-0.2.9.ebuild16
4 files changed, 110 insertions, 0 deletions
diff --git a/app-emulation/playonlinux/Manifest b/app-emulation/playonlinux/Manifest
new file mode 100644
index 0000000..b7036a4
--- /dev/null
+++ b/app-emulation/playonlinux/Manifest
@@ -0,0 +1,2 @@
+DIST PlayOnLinux_3.8.3.tar.gz 2309646 RMD160 1a23a219a96c81d3d1f12e42c4e583cb151575b7 SHA1 e2e89fdbaa6feafb956e4b5b02ce4ac0c95f739e SHA256 ca84d080e5d6f11c43c754543289125c56162c8c5a9d9b3f128ea71a7f378763
+EBUILD playonlinux-3.8.3.ebuild 2621 RMD160 3f7884d4667659d39ea45abb27f92aae403e69bb SHA1 3a2d96d5568b589920c57d4e0bcafe724baaa2a4 SHA256 210969b2f4d9d7648946e23f928c880b16e3f59bdf2ab709c4959f477ceb97f2
diff --git a/app-emulation/playonlinux/playonlinux-3.8.3.ebuild b/app-emulation/playonlinux/playonlinux-3.8.3.ebuild
new file mode 100644
index 0000000..2531738
--- /dev/null
+++ b/app-emulation/playonlinux/playonlinux-3.8.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils python games
+
+MY_PN="PlayOnLinux"
+
+DESCRIPTION="Set of scripts to easily install and use Windows(tm) games and softwares"
+HOMEPAGE="http://playonlinux.com/"
+SRC_URI="http://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-emulation/wine
+ app-arch/cabextract
+ app-arch/unzip
+ dev-python/wxpython:2.8
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ x11-apps/mesa-progs
+ x11-terms/xterm"
+
+S=${WORKDIR}/${PN}
+
+# TODO:
+# Having a real install script and let playonlinux use standard filesystem
+# architecture to prevent having everything installed into GAMES_DATADIR
+# It will let using LANGUAGES easily
+# How to deal with Microsoft Fonts installation asked every time ?
+# How to deal with wine version installed ? (have a better mgmt of system one)
+# Look at debian pkg: http://packages.debian.org/sid/playonlinux
+
+src_prepare() {
+ einfo "Removing temporary files..."
+ rm -f $(find . -name *.pyc) || die "rm -f doesn't die"
+ rm -f $(find . -name *~) || die "rm -f doesn't die"
+}
+
+src_install() {
+ # all things without exec permissions
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r themes lang lib etc || die "doins failed"
+
+ # bash/ bash/terminals/ bash/expert/ python/ install
+ for dir in 'bash' 'bash/terminals' 'bash/expert' 'python'
+ do
+ exeinto "${GAMES_DATADIR}/${PN}/${dir}"
+ doexe ${dir}/* || die "doexe failed for ${dir}"
+ done
+
+ # lib/ python/lib/ plugins/ install
+ for dir in 'lib' 'python/lib' 'plugins'
+ do
+ insinto "${GAMES_DATADIR}/${PN}/${dir}"
+ doins ${dir}/* || die "doexe failed for ${dir}"
+ done
+
+ # main executable files
+ exeinto "${GAMES_DATADIR}/${PN}"
+ doexe ${PN}{,-pkg,-daemon,-cmd,-shell} || die "doexe failed"
+
+ # making a script to run app from ${GAMES_BINDIR}
+ echo "#!/bin/bash" > ${PN}_launcher
+ echo "cd \"${GAMES_DATADIR}/${PN}\" && ./${PN}" >> ${PN}_launcher
+ newgamesbin playonlinux_launcher playonlinux || die "newgamesbin failed"
+
+ dodoc CHANGELOG || die "dodoc failed"
+
+ doicon etc/${PN}.png || die "doicon failed"
+ domenu etc/${MY_PN}.desktop || die "domenu failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ python_mod_optimize "${GAMES_DATADIR}/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${GAMES_DATADIR}/${PN}"
+
+ ewarn "Installed softwares and games with playonlinux have not been removed."
+ ewarn "To remove them, you can re-install playonlinux and remove them using it"
+ ewarn "or do it manually."
+}
diff --git a/app-text/madedit/Manifest b/app-text/madedit/Manifest
new file mode 100644
index 0000000..5663f44
--- /dev/null
+++ b/app-text/madedit/Manifest
@@ -0,0 +1,2 @@
+DIST madedit-0.2.9.tar.gz 1703993 RMD160 51de25c76eed74a3de0c153da15a62712a477745 SHA1 3a2fa45c305e83ec983adfe910660521769dfdee SHA256 db97d926b11fa339995434098044d85866151c123742c4de74f5ab5dc391955b
+EBUILD madedit-0.2.9.ebuild 427 RMD160 3c8257e65b548b5f85b5f199f9ca95e29e26048c SHA1 f2a9cd6005fdb2fb885b36f6b092a7d3a5f70ccb SHA256 4693647cab3a7b0ad32df686e4975677d81335f1c68c58ef14e48ab2d40e1eaa
diff --git a/app-text/madedit/madedit-0.2.9.ebuild b/app-text/madedit/madedit-0.2.9.ebuild
new file mode 100644
index 0000000..1f06506
--- /dev/null
+++ b/app-text/madedit/madedit-0.2.9.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit base
+
+DESCRIPTION="MadEdit is an Open-Source and Cross-Platform Text/Hex Editor written in C++ and wxWidgets."
+HOMEPAGE="http://madedit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=x11-libs/wxGTK-2.8"
+RDEPEND="${DEPEND}"