summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/cairo-dock/cairo-dock-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/x11-misc/cairo-dock/cairo-dock-9999.ebuild b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
index 1e9896a..2981cd4 100644
--- a/x11-misc/cairo-dock/cairo-dock-9999.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
@@ -73,11 +73,17 @@ pkg_setup()
# Also, the weird reported behavior of cairo-dock installing
# stuff under "/usr/usr/lib6464" for 64-bit system.
- # We are doing this so that files are actually placed into the normal directory
-
+ # We are doing this so that files actually get placed into the normal directory
+
+ mkdir /usr/usr
ln -s /usr/lib /usr/usr/lib
ln -s /usr/lib64 /usr/usr/lib6464/
+ # Note that the first 'ln' will fail if we're on a 64-bit system. That's
+ # okay.
+ # Note that the second 'ln' will fail if we're on a 32-bit system. THat's
+ # okay.
+
}