summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/cairo-dock/ChangeLog9
-rw-r--r--x11-misc/cairo-dock/Manifest3
-rw-r--r--x11-misc/cairo-dock/cairo-dock-9999.ebuild66
-rw-r--r--x11-misc/cairo-dock/metadata.xml8
-rw-r--r--x11-plugins/cairo-dock-plugins/ChangeLog9
-rw-r--r--x11-plugins/cairo-dock-plugins/Manifest3
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild90
-rw-r--r--x11-plugins/cairo-dock-plugins/metadata.xml8
8 files changed, 196 insertions, 0 deletions
diff --git a/x11-misc/cairo-dock/ChangeLog b/x11-misc/cairo-dock/ChangeLog
new file mode 100644
index 0000000..a7e495b
--- /dev/null
+++ b/x11-misc/cairo-dock/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-misc/cairo-dock
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header$
+
+*cairo-dock-9999 (03 Feb 2012)
+
+ 03 Feb 2012; David P <write2david@gmail.com>
+ +cairo-dock-9999.ebuild:
+ Initial commit \ No newline at end of file
diff --git a/x11-misc/cairo-dock/Manifest b/x11-misc/cairo-dock/Manifest
new file mode 100644
index 0000000..3b1c06a
--- /dev/null
+++ b/x11-misc/cairo-dock/Manifest
@@ -0,0 +1,3 @@
+EBUILD cairo-dock-9999.ebuild 1319 RMD160 0b52171d11bdd67bacec52bff3f06e3c3c838385 SHA1 4eb6baf2a1391d3ee0cddc4e7d6202e76ad9dc22 SHA256 2d701a80b3f1c8ea386136a927fcad205e8723336db74ce0a34d700133b31ebc
+MISC ChangeLog 240 RMD160 55af20059609afd5f2f7c6587a398a8771ad3b97 SHA1 954131dc27940452045dd947d865332f92420cbe SHA256 ffd103359939888e5c0463fda3245d4e54b55fdcc16782e5e83f14fbaaa31efd
+MISC metadata.xml 283 RMD160 e0f08c017c57b0424ffa9250b0e8818d3b3253cd SHA1 62374de770ec97144aa653d355d581b93fa68755 SHA256 1c3d6ef6576788b50b9140d7578885034d5ddb210138d78de6a0a77c35b3d2b4
diff --git a/x11-misc/cairo-dock/cairo-dock-9999.ebuild b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
new file mode 100644
index 0000000..05d7373
--- /dev/null
+++ b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit cmake-utils bzr
+
+EBZR_REPO_URI="lp:cairo-dock-core"
+#EBZR_REPO_URI="lp:cairo-dock-core/2.3"
+#EBZR_REVISION="959"
+
+
+DESCRIPTION="Cairo-dock is a fast, responsive, Mac OS X-like dock."
+HOMEPAGE="https://launchpad.net/cairo-dock-core/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="xcomposite"
+
+RDEPEND="
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ dev-libs/libxml2
+ gnome-base/librsvg
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ x11-libs/libXrender
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXinerama
+ x11-libs/libXtst
+ )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ bzr_src_prepare
+# intltoolize --automake --copy --force || die "intltoolize failed"
+# eautoreconf
+}
+
+#src_configure() {
+# econf $(use_enable xcomposite xextend)
+#}
+
+#src_install() {
+# #emake DESTDIR="${D}" install || die "emake install failed"
+#}
+
+MAKE_IN_SOURCE_BUILD=true
+
+pkg_postinst() {
+ ewarn "THIS IS A LIVE EBUILD, SO YOU KNOW THE RISKS !"
+ ewarn "DO NOT report bugs to Gentoo's bugzilla"
+ ewarn "Please report all bugs to #gentoo-desktop-effects"
+ einfo "Thank you on behalf of the Gentoo Desktop-Effects team"
+}
diff --git a/x11-misc/cairo-dock/metadata.xml b/x11-misc/cairo-dock/metadata.xml
new file mode 100644
index 0000000..074b761
--- /dev/null
+++ b/x11-misc/cairo-dock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</use>
+<herd>no-herd</herd>
+<longdescription>Cairo-dock is a kind of dock applet, which doesn't depend on any gnome package.</longdescription>
+</pkgmetadata>
+
diff --git a/x11-plugins/cairo-dock-plugins/ChangeLog b/x11-plugins/cairo-dock-plugins/ChangeLog
new file mode 100644
index 0000000..a7e495b
--- /dev/null
+++ b/x11-plugins/cairo-dock-plugins/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-misc/cairo-dock
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header$
+
+*cairo-dock-9999 (03 Feb 2012)
+
+ 03 Feb 2012; David P <write2david@gmail.com>
+ +cairo-dock-9999.ebuild:
+ Initial commit \ No newline at end of file
diff --git a/x11-plugins/cairo-dock-plugins/Manifest b/x11-plugins/cairo-dock-plugins/Manifest
new file mode 100644
index 0000000..cd012e9
--- /dev/null
+++ b/x11-plugins/cairo-dock-plugins/Manifest
@@ -0,0 +1,3 @@
+EBUILD cairo-dock-plugins-9999.ebuild 2205 RMD160 c73c835c992231c1347984cd877ba434b3b5bdac SHA1 8ff86e3321c954da83f8773edd34cfeff8bdd34b SHA256 ab91b541071137578c49c9d497d425de22e876363f04fb4075ed281451397b8b
+MISC ChangeLog 240 RMD160 55af20059609afd5f2f7c6587a398a8771ad3b97 SHA1 954131dc27940452045dd947d865332f92420cbe SHA256 ffd103359939888e5c0463fda3245d4e54b55fdcc16782e5e83f14fbaaa31efd
+MISC metadata.xml 283 RMD160 e0f08c017c57b0424ffa9250b0e8818d3b3253cd SHA1 62374de770ec97144aa653d355d581b93fa68755 SHA256 1c3d6ef6576788b50b9140d7578885034d5ddb210138d78de6a0a77c35b3d2b4
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild
new file mode 100644
index 0000000..d0f29cd
--- /dev/null
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+EBZR_REPO_URI="lp:cairo-dock-plug-ins"
+#EBZR_REVISION="2242"
+
+
+inherit cmake-utils bzr
+
+DESCRIPTION="Official plugins for cairo-dock"
+HOMEPAGE="https://launchpad.net/cairo-dock-plug-ins/"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="alsa exif gmenu terminal vala webkit xfce xgamma xklavier"
+
+RDEPEND="
+ ~x11-misc/cairo-dock-${PV}
+ alsa? ( media-libs/alsa-lib )
+ exif? ( media-libs/libexif )
+ gmenu? ( gnome-base/gnome-menus )
+ terminal? ( x11-libs/vte )
+ webkit? ( >=net-libs/webkit-gtk-1.0 )
+ xfce? ( xfce-base/thunar )
+ xgamma? ( x11-libs/libXxf86vm )
+ xklavier? ( x11-libs/libxklavier )
+ vala? ( dev-lang/vala:0.12 )
+"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig
+"
+
+
+pkg_setup()
+{
+ ewarn ""
+ ewarn ""
+ ewarn "THIS IS A LIVE EBUILD, SO IT MAY NOT BUILD RIGHT!"
+ ewarn "DO NOT report bugs to Gentoo's bugzilla"
+ ewarn "Please report all bugs to write2david@gmail.com"
+ ewarn ""
+ ewarn ""
+}
+
+
+src_prepare() {
+ bzr_src_prepare
+}
+
+
+# Can't find out what the following line does (no Gentoo documentation on it?) and it seems to find the makefile and compile fine without it, so commenting it out.
+#MAKE_IN_SOURCE_BUILD=true
+
+
+# Actually, it looks like it is supposed to be CMAKE_IN_SOURCE_BUILD
+# http://devmanual.gentoo.org/eclass-reference/cmake-utils.eclass/index.html
+#CMAKE_IN_SOURCE_BUILD=true
+
+
+
+# Next section is inspired from...
+# https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981
+# and
+# http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
+
+
+src_configure() {
+# MYCMAKEARGS="-DROOT_PREFIX=${D}" cmake-utils_src_configure
+ mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
+ cmake-utils_src_configure
+# econf
+}
+
+
+pkg_postinst() {
+ ewarn ""
+ ewarn ""
+ ewarn "THIS IS A LIVE EBUILD, SO IT MAY NOT RUN RIGHT!"
+ ewarn "DO NOT report bugs to Gentoo's bugzilla"
+ ewarn "Please report all bugs to write2david@gmail.com"
+ ewarn ""
+ ewarn ""
+}
diff --git a/x11-plugins/cairo-dock-plugins/metadata.xml b/x11-plugins/cairo-dock-plugins/metadata.xml
new file mode 100644
index 0000000..074b761
--- /dev/null
+++ b/x11-plugins/cairo-dock-plugins/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</use>
+<herd>no-herd</herd>
+<longdescription>Cairo-dock is a kind of dock applet, which doesn't depend on any gnome package.</longdescription>
+</pkgmetadata>
+