summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/bemerge/bemerge-0.4.1-r1.ebuild56
-rw-r--r--app-portage/bemerge/bemerge-0.45.ebuild56
2 files changed, 112 insertions, 0 deletions
diff --git a/app-portage/bemerge/bemerge-0.4.1-r1.ebuild b/app-portage/bemerge/bemerge-0.4.1-r1.ebuild
new file mode 100644
index 0000000..c669b70
--- /dev/null
+++ b/app-portage/bemerge/bemerge-0.4.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+
+# Helpful information for me:
+# http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=1
+# http://devmanual.gentoo.org/ebuild-writing/index.html
+# http://linuxreviews.org/man/ebuild/
+
+
+EAPI="3"
+
+inherit eutils git
+
+DESCRIPTION="a wrapper script for emerge to make it better"
+HOMEPAGE="https://github.com/write2david/bemerge"
+SRC_URI=""
+
+
+EGIT_REPO_URI="git://github.com/write2david/bemerge.git"
+EGIT_BRANCH="master"
+
+# The commit of version 0.41
+EGIT_COMMIT="48c2164dd4063fe6fa8"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="mirror test"
+
+
+RDEPEND="
+ sys-process/time
+ app-admin/localepurge
+ sys-kernel/module-rebuild
+ sys-process/lsof
+ app-admin/checkrestart
+ "
+
+
+src_unpack() {
+ git_src_unpack
+}
+
+
+src_install() {
+
+ # Dictate where the executable will be installed to
+ exeinto /usr/bin
+
+ # Now put the executable in said location
+ doexe bemerge
+
+}
diff --git a/app-portage/bemerge/bemerge-0.45.ebuild b/app-portage/bemerge/bemerge-0.45.ebuild
new file mode 100644
index 0000000..f6aff6b
--- /dev/null
+++ b/app-portage/bemerge/bemerge-0.45.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+
+# Helpful information for me:
+# http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=1
+# http://devmanual.gentoo.org/ebuild-writing/index.html
+# http://linuxreviews.org/man/ebuild/
+
+
+EAPI="3"
+
+inherit eutils git
+
+DESCRIPTION="a wrapper script for emerge to make it better"
+HOMEPAGE="https://github.com/write2david/bemerge"
+SRC_URI=""
+
+
+EGIT_REPO_URI="git://github.com/write2david/bemerge.git"
+EGIT_BRANCH="master"
+
+# The commit of version 0.45
+EGIT_COMMIT="4e71d23f10864"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="mirror test"
+
+
+RDEPEND="
+ sys-process/time
+ app-admin/localepurge
+ sys-kernel/module-rebuild
+ sys-process/lsof
+ app-admin/checkrestart
+ "
+
+
+src_unpack() {
+ git_src_unpack
+}
+
+
+src_install() {
+
+ # Dictate where the executable will be installed to
+ exeinto /usr/bin
+
+ # Now put the executable in said location
+ doexe bemerge
+
+}