summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/cairo-dock/cairo-dock-9999.ebuild')
-rw-r--r--x11-misc/cairo-dock/cairo-dock-9999.ebuild41
1 files changed, 36 insertions, 5 deletions
diff --git a/x11-misc/cairo-dock/cairo-dock-9999.ebuild b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
index 9747679..133f4a1 100644
--- a/x11-misc/cairo-dock/cairo-dock-9999.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
@@ -6,8 +6,12 @@ EAPI="2"
inherit cmake-utils bzr
+# Launchpad repository where "cairo-dock" lives:
EBZR_REPO_URI="lp:cairo-dock-core"
-#EBZR_REPO_URI="lp:cairo-dock-core/2.3"
+
+
+# You can specify a certain revision from the repository here.
+# Or comment it out to choose the latest ("live") revision.
#EBZR_REVISION="959"
@@ -20,6 +24,10 @@ SLOT="0"
KEYWORDS=""
IUSE="xcomposite"
+
+# Dependencies are listed here:
+# http://glx-dock.org/ww_page.php?p=From%20BZR&lang=en
+
RDEPEND="
dev-libs/dbus-glib
dev-libs/glib:2
@@ -30,6 +38,8 @@ RDEPEND="
x11-libs/gtk+:2
x11-libs/gtkglext
x11-libs/libXrender
+ net-misc/curl
+ x11-libs/pango
xcomposite? (
x11-libs/libXcomposite
x11-libs/libXinerama
@@ -44,6 +54,21 @@ DEPEND="${RDEPEND}
sys-devel/gettext
"
+
+pkg_setup()
+{
+ ewarn ""
+ ewarn ""
+ ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn " Thus, it may FAIL to build properly."
+ ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn " Instead, report all bugs to write2david@gmail.com"
+ ewarn ""
+ ewarn ""
+}
+
+
+
src_prepare() {
bzr_src_prepare
}
@@ -51,8 +76,14 @@ src_prepare() {
MAKE_IN_SOURCE_BUILD=true
+
pkg_postinst() {
- ewarn "THIS IS A LIVE EBUILD, SO YOU KNOW THE RISKS !"
- ewarn "DO NOT report bugs to Gentoo's bugzilla"
- ewarn "Please report all bugs to write2David@gmail.com"
-}
+ ewarn ""
+ ewarn ""
+ ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn " Thus, it may FAIL to run properly."
+ ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn " Instead, report all bugs to write2david@gmail.com"
+ ewarn ""
+ ewarn ""
+} \ No newline at end of file