summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/easystroke/Manifest2
-rw-r--r--x11-misc/easystroke/easystroke-0.5.5.1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/easystroke/Manifest b/x11-misc/easystroke/Manifest
index 8a946a7..19a0824 100644
--- a/x11-misc/easystroke/Manifest
+++ b/x11-misc/easystroke/Manifest
@@ -1,3 +1,5 @@
DIST easystroke-0.5.4.tar.gz 103111 RMD160 55aadba296577f599588cdd792a970914b34b0b5 SHA1 25ac617f4b8a2b804738a8749e96e379c95ea691 SHA256 b18cd209248b1a6bcaa8bba42fe85b82e117cdb78d1b57ba3f5e2308cb3a5f64
+DIST easystroke-0.5.5.1.tar.gz 114390 RMD160 fa6eac68740e61ccf282f1cd86a02d346eb4b0dc SHA1 04a15d6d50f883b6d492a70adf53943e61dc6ca9 SHA256 47fd69a7749c45ca3ea4d373b355d457dc224357c192c4b718b7c92d19955c7c
EBUILD easystroke-0.5.4.ebuild 1053 RMD160 87c840d4fe7f9c134cc440ea597da63939a08598 SHA1 4d7840f51cf49d593308f448e24e0eb5a5afd06e SHA256 5101a7eb491d4a4fa3e684ce2bfbd3c3a6463cd15d0232f4c68c11ca1910c727
+EBUILD easystroke-0.5.5.1.ebuild 1048 RMD160 efb0711415157e859aa77301e8d325e8806b4d83 SHA1 851719fb270af6d1903294039ec929a953fc3d99 SHA256 66016ba6b82769f298b57aab7287fcd34ee8780824694c505c3dacb490e694e9
MISC metadata.xml 318 RMD160 1a77829ca0a3de9847cded7f27e1a6949951c1e7 SHA1 c12224d9f577f7dbb2a63f84a1ba4909a14a1f42 SHA256 7993a8933dc735a5fe2ba03d0ed83c1128489f0961da0ebf5e05b6e3725d013f
diff --git a/x11-misc/easystroke/easystroke-0.5.5.1.ebuild b/x11-misc/easystroke/easystroke-0.5.5.1.ebuild
new file mode 100644
index 0000000..d3cbb71
--- /dev/null
+++ b/x11-misc/easystroke/easystroke-0.5.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+DESCRIPTION="A gesture-recognition application for X11"
+HOMEPAGE="http://easystroke.wiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+COMMON_DEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-cpp/cairomm
+ dev-libs/boost
+ dev-libs/dbus-glib
+ dev-libs/libsigc++:2
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXtst"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-apps/help2man
+ x11-libs/libXfixes"
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/xdg-utils"
+
+src_prepare() {
+ sed -i -e 's/install -Ds/install -D/' \
+ -e 's/^LDFLAGS/#LDFLAGS/' \
+ Makefile || die
+ sed -i -e \
+ "s:^Icon=${PN}:Icon=${EPREFIX}/usr/share/icons/hicolor/scalable/apps/${PN}.svg:" \
+ ${PN}.desktop.in || die
+}
+
+src_compile() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr/"
+ emake man
+}
+
+src_install() {
+ doman ${PN}.1
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+} \ No newline at end of file