summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild')
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild35
1 files changed, 28 insertions, 7 deletions
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild
index d0f29cd..003ddb0 100644
--- a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild
@@ -3,7 +3,12 @@
# $Header: $
EAPI="2"
+
+# Launchpad repository where "cairo-dock-plugins" lives:
EBZR_REPO_URI="lp:cairo-dock-plug-ins"
+
+# You can specify a certain revision from the repository here.
+# Or comment it out to choose the latest ("live") revision.
#EBZR_REVISION="2242"
@@ -16,10 +21,22 @@ SRC_URI=""
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
+
+
+# The next line has been stripped down somewhat from a longer version
+# used in the ebuilds of other overlays. For more info, see:
+# https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981/comments/8
IUSE="alsa exif gmenu terminal vala webkit xfce xgamma xklavier"
+
+# Dependencies are listed here:
+# http://glx-dock.org/ww_page.php?p=From%20BZR&lang=en
+
RDEPEND="
~x11-misc/cairo-dock-${PV}
+ x11-libs/cairo
+ gnome-base/librsvg
+ dev-libs/libxml2
alsa? ( media-libs/alsa-lib )
exif? ( media-libs/libexif )
gmenu? ( gnome-base/gnome-menus )
@@ -31,6 +48,7 @@ RDEPEND="
vala? ( dev-lang/vala:0.12 )
"
+
DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext
@@ -42,9 +60,10 @@ pkg_setup()
{
ewarn ""
ewarn ""
- ewarn "THIS IS A LIVE EBUILD, SO IT MAY NOT BUILD RIGHT!"
- ewarn "DO NOT report bugs to Gentoo's bugzilla"
- ewarn "Please report all bugs to write2david@gmail.com"
+ ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn " Thus, it may FAIL to build properly."
+ ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
}
@@ -61,6 +80,7 @@ src_prepare() {
# Actually, it looks like it is supposed to be CMAKE_IN_SOURCE_BUILD
# http://devmanual.gentoo.org/eclass-reference/cmake-utils.eclass/index.html
+# But still not needed, so it is still commented out.
#CMAKE_IN_SOURCE_BUILD=true
@@ -82,9 +102,10 @@ src_configure() {
pkg_postinst() {
ewarn ""
ewarn ""
- ewarn "THIS IS A LIVE EBUILD, SO IT MAY NOT RUN RIGHT!"
- ewarn "DO NOT report bugs to Gentoo's bugzilla"
- ewarn "Please report all bugs to write2david@gmail.com"
+ ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn " Thus, it may FAIL to run properly."
+ ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
-}
+} \ No newline at end of file