summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--pentoo/pentoo-installer/Manifest3
-rw-r--r--pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild32
-rw-r--r--pentoo/pentoo-installer/pentoo-installer-99999999.ebuild15
3 files changed, 38 insertions, 12 deletions
diff --git a/pentoo/pentoo-installer/Manifest b/pentoo/pentoo-installer/Manifest
index 3a5f505..a1b361c 100644
--- a/pentoo/pentoo-installer/Manifest
+++ b/pentoo/pentoo-installer/Manifest
@@ -1,2 +1,3 @@
AUX pentoo-installer.desktop 214 SHA256 bd7796fe3d6c998c033dd63bcfb81a0ecd0980b8d736d85af45c3604f191aef3 SHA512 8d509a55653efba02e6c398c728f2cf49e7ee6d56510fc0dddab5db9026b7f3dbbaebbe10537040a3b6d8cfecdda7aa282bd90ebe5c4c42aedfa1bb8e282cdae WHIRLPOOL 042817cd99601a7137fb0ae1dbbac9f23370a066eff73bd1b3aeaac767644b6c387b089801b994fed6d72b5130228cb40ee99717ee4a2b3c4175c8f7acff9efa
-EBUILD pentoo-installer-99999999.ebuild 881 SHA256 c8470893d3e7edb7197c504a7e3d8357c02e5c61a6a028a8fc7bd186cd0f491a SHA512 1a39a1a5e245976164da1e5ca964d095d1009386b47eaf6b94feb374a8a876065e969d58ac8522ca63e8c5ddef6d42418c72c873fd5b0ab31fb0b28f282ac60b WHIRLPOOL 206c4af15a1b27811fa5d93ca87adbbfd9b97f3b22956cd1d5e0503ad649bf5d3d864d18fa06d445bd6b33f0729a3761c67aa36ca2655c3a3c7b34cef69e363f
+EBUILD pentoo-installer-0.8.1.ebuild 699 SHA256 6470bcf9a5aff203318ed564396ed82cf5330ef2bb8877e79568844e326d76cb SHA512 55ed5babb77296dff41282d54cabd0891f21ad932d4a0d85e8640893714c999747fab0e06d2cb484975b151b78a9589a98934ee13fe2fc072f830b6d7da88103 WHIRLPOOL be301275fc1de58e1fd64d7cb8cf9403fed3764c3526105df9e42e7ab704b4d76f078030e48b3f74329598419d5743a7886f6d111cfaac90850f6c19be0c559f
+EBUILD pentoo-installer-99999999.ebuild 697 SHA256 1406cc3d1080196a553c27e544bf285f89d9470b2262b93f9c94adb17a4f2bfe SHA512 56c4151a528d7a23593b45777ef343a46c9a6b94610d2e2bd4df3ffa7aebae642c8d3f6558fea4f0832c18ac7b2138c4eaaa77ffdfe4e8d26d5140c3f945d1c3 WHIRLPOOL 8631f52dc5aea98e572aa94527588f02673e14387c8b37379ce642cd16e5845c8c6d66844ab7ea6560d7b59e785d43da1e664c3e85a8dc4ca5631c0bb35ef81d
diff --git a/pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild b/pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild
new file mode 100644
index 0000000..dbe64cb
--- /dev/null
+++ b/pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit subversion
+
+DESCRIPTION="Installer for pentoo"
+HOMEPAGE="https://code.google.com/p/pentoo/"
+ESVN_REPO_URI="https://${PN}.googlecode.com/svn/tags/v${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="dev-util/dialog
+ X? ( x11-misc/xdialog )
+ || ( sys-boot/grub:0
+ sys-boot/grub-static:0 )
+ sys-boot/grub:2
+ sys-fs/squashfs-tools
+ net-misc/rsync"
+
+src_install() {
+ dodir /usr/
+ cp -R "${S}"/* "${ED}"/usr/ || die "Copy files failed"
+ exeinto /root/Desktop/
+ doexe share/applications/pentoo-installer.desktop
+}
diff --git a/pentoo/pentoo-installer/pentoo-installer-99999999.ebuild b/pentoo/pentoo-installer/pentoo-installer-99999999.ebuild
index ca57a0f..c39b5c3 100644
--- a/pentoo/pentoo-installer/pentoo-installer-99999999.ebuild
+++ b/pentoo/pentoo-installer/pentoo-installer-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,20 +6,13 @@ EAPI=5
inherit subversion
-DESCRIPTION="Installer for pentoo, based on the ncurses Arch Linux installer"
+DESCRIPTION="Installer for pentoo"
HOMEPAGE="https://code.google.com/p/pentoo/"
-# ESVN_REPO_URI="https://pentoo.googlecode.com/svn/${PN}/trunk"
-ESVN_REPO_URI="https://${PN}.googlecode.com/svn/trunk"
+ESVN_REPO_URI="https://${PN}.googlecode.com/svn/branches/development"
LICENSE="GPL-3"
SLOT="0"
-if [[ "${PV}" == "99999999" ]] ; then
- KEYWORDS=""
-else
- KEYWORDS="amd64 x86"
- ESVN_REVISION="head"
-fi
-
+KEYWORDS=""
IUSE="X"
DEPEND="app-arch/xz-utils"