summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Huber <huber@crans.org>2010-12-29 17:52:35 +0100
committerOlivier Huber <huber@crans.org>2010-12-29 17:52:35 +0100
commita2fd978a3b051df055df12de127331d0d77f5dc1 (patch)
tree83fcf1e4b16ac35793cd696b9a169002ded18fe4
parent[dev-ml/lwt] add text and toplevel USE flags (diff)
downloadxhub-a2fd978a3b051df055df12de127331d0d77f5dc1.tar.gz
xhub-a2fd978a3b051df055df12de127331d0d77f5dc1.tar.bz2
xhub-a2fd978a3b051df055df12de127331d0d77f5dc1.zip
[dev-ml/obus] initial import
-rw-r--r--dev-ml/obus/Manifest2
-rw-r--r--dev-ml/obus/obus-1.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/obus/Manifest b/dev-ml/obus/Manifest
new file mode 100644
index 0000000..3a50415
--- /dev/null
+++ b/dev-ml/obus/Manifest
@@ -0,0 +1,2 @@
+DIST obus-1.1.tar.gz 402352 RMD160 83a85e65da4fd17fbfe8810f0f7037a6d3ba64dc SHA1 b04855d5b060831255d1f0e3a10281b2776db43c SHA256 af7b0b9f0d8d9084a8a092a1bc6bf6113c102474d45865d64bb37a761ab6ecaf
+EBUILD obus-1.1.ebuild 719 RMD160 472fe6fb65a61213eea6a2963ef576b78bb2c285 SHA1 bb068b02c91ff6bc3d52820682053029120a5457 SHA256 ccd74251b08e7e8c52166c9623f63530edde89c0f27a891637927cd5b9afcfd9
diff --git a/dev-ml/obus/obus-1.1.ebuild b/dev-ml/obus/obus-1.1.ebuild
new file mode 100644
index 0000000..92ef392
--- /dev/null
+++ b/dev-ml/obus/obus-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit findlib oasis
+
+DESCRIPTION="OBus is a pure ocaml implementation of DBus"
+HOMEPAGE="https://forge.ocamlcore.org/projects/obus/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/539/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+RESTRICT="test"
+
+DEPEND="${DEPEND}
+>=dev-lang/ocaml-3.12[ocamlopt?]
+dev-ml/type-conv
+dev-ml/xmlm[ocamlopt?]
+>=dev-ml/lwt-2.2[ocamlopt?]"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ oasis_src_configure
+}
+
+# Fix tests
+#src_test() {
+# dbus-launch emake -j1 test || die "make test failed"
+#}
+
+src_install() {
+ findlib_src_install
+}