aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-11 14:02:23 +0200
committerMichał Górny <mgorny@gentoo.org>2013-08-11 22:43:30 +0200
commit0b946cc0414987b87fbe25915fecea762adca99b (patch)
treea63742da87799cabdd33ef9fc47007b666403305
parentMerge pull request #53 from tampakrap/settings (diff)
downloadidentity.gentoo.org-0b946cc0414987b87fbe25915fecea762adca99b.tar.gz
identity.gentoo.org-0b946cc0414987b87fbe25915fecea762adca99b.tar.bz2
identity.gentoo.org-0b946cc0414987b87fbe25915fecea762adca99b.zip
Enable memcached cache backend.
-rw-r--r--okupy/settings/local.py.sample8
-rw-r--r--requirements.txt1
-rwxr-xr-xsetup.py1
3 files changed, 10 insertions, 0 deletions
diff --git a/okupy/settings/local.py.sample b/okupy/settings/local.py.sample
index 454906c..245d48a 100644
--- a/okupy/settings/local.py.sample
+++ b/okupy/settings/local.py.sample
@@ -19,6 +19,14 @@ DEVELOPMENT = True
# Examples: okupy, okupy-dev, identity.gentoo.org
INSTANCE_NAME = 'okupy-dev'
+CACHES = {
+ 'default': {
+ 'BACKEND': 'django.core.cache.backends.memcached.MemcachedCache',
+ # replace with the path to your memcached socket
+ 'LOCATION': 'unix://home/$USER/okupy/memcached.sock',
+ }
+}
+
DATABASES = {
'default': {
'ENGINE': 'django.db.backends.', # Add 'postgresql_psycopg2', 'mysql', 'sqlite3' or 'oracle'.
diff --git a/requirements.txt b/requirements.txt
index a88ae9f..9b3c8a7 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -9,5 +9,6 @@ hg+https://bitbucket.org/psagers/mockldap#egg=mockldap
passlib>=1.6.1
pyopenssl>=0.13
python-ldap>=2.4.10
+python-memcached>=1.53
python-openid>=2.2.5
qrcode>=3.0
diff --git a/setup.py b/setup.py
index 5455de1..44d14d2 100755
--- a/setup.py
+++ b/setup.py
@@ -42,6 +42,7 @@ setup(
'passlib>=1.6.1',
'pyopenssl>=0.13',
'python-ldap>=2.4.10',
+ 'python-memcached>=1.53',
'python-openid>=2.2.5',
'qrcode>=3.0',
],