aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2013-09-08 15:02:43 +0200
committerTheo Chatzimichos <tampakrap@gentoo.org>2013-09-08 15:02:43 +0200
commit4f3f9e4a4ff07affaf662012700e0ca8718998f3 (patch)
tree9afc1acf0301ed2859e451aff789e6def61b2285 /bin/runtests
parentRemove the -s arg, since we always need to define the test settings (diff)
downloadidentity.gentoo.org-4f3f9e4a4ff07affaf662012700e0ca8718998f3.tar.gz
identity.gentoo.org-4f3f9e4a4ff07affaf662012700e0ca8718998f3.tar.bz2
identity.gentoo.org-4f3f9e4a4ff07affaf662012700e0ca8718998f3.zip
Add -v support in runtests
Diffstat (limited to 'bin/runtests')
-rwxr-xr-xbin/runtests5
1 files changed, 3 insertions, 2 deletions
diff --git a/bin/runtests b/bin/runtests
index 0825325..8284ddd 100755
--- a/bin/runtests
+++ b/bin/runtests
@@ -1,15 +1,16 @@
#!/bin/bash
-while getopts dcf2 arg; do
+while getopts dcf2v: arg; do
case ${arg} in
d) TDAEMON="tdaemon -t django" ;;
c) COVERAGE="coverage" ;;
f) FLAKE8="flake8 . --exclude=./okupy/tests/settings.py,./okupy/settings,setup.py,.virtualenv" ;;
2) SUFFIX="2" ;;
+ v) VERBOSE="-v ${OPTARG}" ;;
esac
done
-ARGS="--settings=okupy.tests.settings --traceback"
+ARGS="--settings=okupy.tests.settings --traceback ${VERBOSE}"
if [[ -n ${TDAEMON} ]]; then
[[ -n ${COVERAGE} ]] && COVERAGE="-c"