summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 21:43:53 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 21:43:53 +0000
commitc8f3ca208f2294161cadfb09308c4735b33295e4 (patch)
tree71b424778051b6310342adfc79744dbfca49daa5 /app-text/expander
parentQA: Respect CC (bug 243736) (diff)
downloadgentoo-2-c8f3ca208f2294161cadfb09308c4735b33295e4.tar.gz
gentoo-2-c8f3ca208f2294161cadfb09308c4735b33295e4.tar.bz2
gentoo-2-c8f3ca208f2294161cadfb09308c4735b33295e4.zip
QA: Respect CC (bug 243728), respect CFLAGS
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-text/expander')
-rw-r--r--app-text/expander/ChangeLog5
-rw-r--r--app-text/expander/expander-2.0.5.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/app-text/expander/ChangeLog b/app-text/expander/ChangeLog
index d0db7806476e..b5bf1503e8f0 100644
--- a/app-text/expander/ChangeLog
+++ b/app-text/expander/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/expander
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/expander/ChangeLog,v 1.8 2008/04/21 17:03:33 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/expander/ChangeLog,v 1.9 2008/12/30 21:43:53 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> expander-2.0.5.ebuild:
+ QA: Respect CC (bug 243728), respect CFLAGS
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/app-text/expander/expander-2.0.5.ebuild b/app-text/expander/expander-2.0.5.ebuild
index aadde6627d8c..a0b0966bd7ee 100644
--- a/app-text/expander/expander-2.0.5.ebuild
+++ b/app-text/expander/expander-2.0.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/expander/expander-2.0.5.ebuild,v 1.8 2008/01/25 19:36:19 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/expander/expander-2.0.5.ebuild,v 1.9 2008/12/30 21:43:53 angelos Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Expander is a utility that acts as a filter for text editors."
HOMEPAGE="http://www.nedit.org"
@@ -19,14 +19,14 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}
src_compile() {
cd src
- make || die "make failed"
+ emake compiler="$(tc-getCC) ${CFLAGS}" || die "make failed"
}
src_install() {
@@ -35,22 +35,22 @@ src_install() {
dosym /usr/bin/boxcomment /usr/bin/unboxcomment
insinto /usr/share/${P}
- doins ${S}/service
+ doins "${S}"/service
for x in defs macros misc templates ; do
insinto /usr/share/${P}/${x}
- doins ${S}/${x}/*
+ doins "${S}"/${x}/*
done
- cd ${S}/docs
+ cd "${S}"/docs
doman *.1
- cd ${S}
+ cd "${S}"
dodoc ChangeLog INSTALL README USAGE
}
pkg_postinst() {
elog
- elog "Instructions for using expander with NEdit are in /usr/share/doc/${P}/INSTALL"
+ elog "Instructions for using expander with NEdit are in /usr/share/doc/${PF}/INSTALL"
elog "Macro, definition and template files can be found in /usr/share/${P}"
elog
}