summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-15 10:30:20 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-15 10:30:20 +0000
commit54a0b5033bcfa9fb76c0ce96e7dcb8666604c9fc (patch)
tree92463ead75f8388ae611444f3bf58baf4950d7c3 /app-text/hunspell/files
parentVersion bump. (diff)
downloadgentoo-2-54a0b5033bcfa9fb76c0ce96e7dcb8666604c9fc.tar.gz
gentoo-2-54a0b5033bcfa9fb76c0ce96e7dcb8666604c9fc.tar.bz2
gentoo-2-54a0b5033bcfa9fb76c0ce96e7dcb8666604c9fc.zip
Revision bump in order to fix static lib usage.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'app-text/hunspell/files')
-rw-r--r--app-text/hunspell/files/hunspell-1.3.2-static-lib.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/hunspell/files/hunspell-1.3.2-static-lib.patch b/app-text/hunspell/files/hunspell-1.3.2-static-lib.patch
new file mode 100644
index 000000000000..0b96fc1b2041
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.3.2-static-lib.patch
@@ -0,0 +1,45 @@
+diff -urN hunspell-1.3.2.old/src/parsers/Makefile.am hunspell-1.3.2/src/parsers/Makefile.am
+--- hunspell-1.3.2.old/src/parsers/Makefile.am 2011-09-15 11:50:40.251441126 +0200
++++ hunspell-1.3.2/src/parsers/Makefile.am 2011-09-15 12:14:25.891424029 +0200
+@@ -1,10 +1,12 @@
+-lib_LIBRARIES=libparsers.a
+-libparsers_a_SOURCES=firstparser.cxx htmlparser.cxx \
+- latexparser.cxx manparser.cxx \
+- textparser.cxx
++lib_LTLIBRARIES=libparsers.la
++libparsers_la_SOURCES=firstparser.cxx firstparser.hxx \
++ htmlparser.cxx htmlparser.hxx \
++ latexparser.cxx latexparser.hxx \
++ manparser.cxx manparser.hxx \
++ textparser.cxx textparser.hxx
++libparsers_la_LIBADD=../hunspell/libhunspell-1.3.la
++libparsers_la_LDFLAGS=-no-undefined
+
+-noinst_PROGRAMS=testparser
+-testparser_SOURCES=firstparser.cxx firstparser.hxx htmlparser.cxx htmlparser.hxx latexparser.cxx latexparser.hxx manparser.cxx manparser.hxx testparser.cxx textparser.cxx textparser.hxx
+-
+-# need mystrdup()
+-LDADD = ../hunspell/libhunspell-1.3.la
++check_PROGRAMS=testparser
++testparser_SOURCES=testparser.cxx
++testparser_LDADD=libparsers.la ../hunspell/libhunspell-1.3.la
+diff -urN hunspell-1.3.2.old/src/tools/Makefile.am hunspell-1.3.2/src/tools/Makefile.am
+--- hunspell-1.3.2.old/src/tools/Makefile.am 2011-09-15 11:50:40.251441126 +0200
++++ hunspell-1.3.2/src/tools/Makefile.am 2011-09-15 12:08:46.081428111 +0200
+@@ -13,14 +13,14 @@
+ example_LDADD = ../hunspell/libhunspell-1.3.la
+
+ hunspell_SOURCES=hunspell.cxx
+-hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../parsers/libparsers.a \
++hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../parsers/libparsers.la \
+ ../hunspell/libhunspell-1.3.la @CURSESLIB@ @READLINELIB@
+
+ hunspell_analyze_SOURCES=analyze.cxx
+ hunspell_analyze_LDADD = ../hunspell/libhunspell-1.3.la
+
+ hunspell_chmorph_SOURCES=chmorph.cxx
+-hunspell_chmorph_LDADD = ../parsers/libparsers.a ../hunspell/libhunspell-1.3.la
++hunspell_chmorph_LDADD = ../parsers/libparsers.la ../hunspell/libhunspell-1.3.la
+
+ noinst_PROGRAMS=example
+