summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-05-17 10:23:42 +0000
committerPeter Volkov <pva@gentoo.org>2010-05-17 10:23:42 +0000
commit6024d990148332e7266213b0239c7873fc751955 (patch)
treeb4bf98d83f43a9bd833e43024371f227eb401bfe /app-text/hunspell/files
parentVersion Bump. (diff)
downloadgentoo-2-6024d990148332e7266213b0239c7873fc751955.tar.gz
gentoo-2-6024d990148332e7266213b0239c7873fc751955.tar.bz2
gentoo-2-6024d990148332e7266213b0239c7873fc751955.zip
Version bump, bug #319709, thank Samuli Suominen for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/hunspell/files')
-rw-r--r--app-text/hunspell/files/hunspell-1.2.11-renameexes.patch116
1 files changed, 116 insertions, 0 deletions
diff --git a/app-text/hunspell/files/hunspell-1.2.11-renameexes.patch b/app-text/hunspell/files/hunspell-1.2.11-renameexes.patch
new file mode 100644
index 000000000000..e037448a2590
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.2.11-renameexes.patch
@@ -0,0 +1,116 @@
+=== modified file 'src/tools/Makefile.am'
+--- src/tools/Makefile.am 2010-05-17 09:20:26 +0000
++++ src/tools/Makefile.am 2010-05-17 09:23:40 +0000
+@@ -1,4 +1,5 @@
+ bin_PROGRAMS=analyze chmorph hunspell munch unmunch hzip hunzip
++bin_PROGRAMS=hunspell-analyze hunspell-chmorph hunspell hunspell-munch hunspell-unmunch hzip hunzip
+
+ INCLUDES=-I${top_srcdir}/src/hunspell -I${top_srcdir}/src/parsers
+
+@@ -6,8 +7,8 @@
+ hunzip_SOURCES=hunzip.cxx
+ hunzip_LDADD = ../hunspell/libhunspell-1.2.la
+
+-munch_SOURCES=munch.c munch.h
+-unmunch_SOURCES=unmunch.c unmunch.h
++hunspell_munch_SOURCES=munch.c munch.h
++hunspell_unmunch_SOURCES=unmunch.c unmunch.h
+
+ example_SOURCES=example.cxx
+ example_LDADD = ../hunspell/libhunspell-1.2.la
+@@ -16,11 +17,11 @@
+ hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../parsers/libparsers.a \
+ ../hunspell/libhunspell-1.2.la @CURSESLIB@ @READLINELIB@
+
+-analyze_SOURCES=analyze.cxx
+-analyze_LDADD = ../hunspell/libhunspell-1.2.la
++hunspell_analyze_SOURCES=analyze.cxx
++hunspell_analyze_LDADD = ../hunspell/libhunspell-1.2.la
+
+-chmorph_SOURCES=chmorph.cxx
+-chmorph_LDADD = ../parsers/libparsers.a ../hunspell/libhunspell-1.2.la
++hunspell_chmorph_SOURCES=chmorph.cxx
++hunspell_chmorph_LDADD = ../parsers/libparsers.a ../hunspell/libhunspell-1.2.la
+
+ noinst_PROGRAMS=example
+
+
+=== modified file 'src/tools/example.cxx'
+--- src/tools/example.cxx 2010-05-17 09:20:26 +0000
++++ src/tools/example.cxx 2010-05-17 09:22:51 +0000
+@@ -17,8 +17,8 @@
+ /* first parse the command line options */
+
+ if (argc < 4) {
+- fprintf(stderr,"example (now it works with more dictionary files):\n");
+- fprintf(stderr,"example affix_file dictionary_file(s) file_of_words_to_check\n");
++ fprintf(stderr,"hunspell-example (now it works with more dictionary files):\n");
++ fprintf(stderr,"hunspell-example affix_file dictionary_file(s) file_of_words_to_check\n");
+ exit(1);
+ }
+
+
+=== modified file 'src/tools/munch.c'
+--- src/tools/munch.c 2010-05-17 09:20:26 +0000
++++ src/tools/munch.c 2010-05-17 09:22:51 +0000
+@@ -42,14 +42,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+
+
+=== modified file 'src/tools/unmunch.c'
+--- src/tools/unmunch.c 2010-05-17 09:20:26 +0000
++++ src/tools/unmunch.c 2010-05-17 09:22:51 +0000
+@@ -39,14 +39,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+
+
+=== modified file 'tests/test.sh'
+--- tests/test.sh 2010-05-17 09:20:26 +0000
++++ tests/test.sh 2010-05-17 09:22:51 +0000
+@@ -34,7 +34,7 @@
+ shopt -s expand_aliases
+
+ alias hunspell='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/hunspell'
+-alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/analyze'
++alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/hunspell-analyze'
+
+ if [ "$VALGRIND" != "" ]; then
+ rm -f $TEMPDIR/test.pid*
+@@ -42,7 +42,7 @@
+ mkdir $TEMPDIR/badlogs
+ fi
+ alias hunspell='valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/.libs/lt-hunspell'
+- alias analyze='valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/.libs/lt-analyze'
++ alias analyze='valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/.libs/lt-hunspell-analyze'
+ fi
+
+ # Tests good words
+