summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-04-15 07:25:52 +0000
committerPeter Volkov <pva@gentoo.org>2010-04-15 07:25:52 +0000
commit90f57776c7b96b6361c3dae21ed18e5f5188c003 (patch)
treeef0ac11348bfc508a8963136d1b261cea9ea90df /app-text/hunspell/files
parentAdd comment about hyphenation. (diff)
downloadgentoo-2-90f57776c7b96b6361c3dae21ed18e5f5188c003.tar.gz
gentoo-2-90f57776c7b96b6361c3dae21ed18e5f5188c003.tar.bz2
gentoo-2-90f57776c7b96b6361c3dae21ed18e5f5188c003.zip
Version bump, bug #314565, thank Samuli Suominen for report. Automatically pull in myspell-* dictionaries based on LINGUAS setting, bug #261050, thank Tobias Leupold for report. Hopefully fixes build on IRIX, bug #257781.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/hunspell/files')
-rw-r--r--app-text/hunspell/files/hunspell-1.2.9-renameexes.patch116
1 files changed, 116 insertions, 0 deletions
diff --git a/app-text/hunspell/files/hunspell-1.2.9-renameexes.patch b/app-text/hunspell/files/hunspell-1.2.9-renameexes.patch
new file mode 100644
index 000000000000..58f366c41f13
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.2.9-renameexes.patch
@@ -0,0 +1,116 @@
+=== modified file 'src/tools/Makefile.am'
+--- src/tools/Makefile.am 2010-04-15 06:56:50 +0000
++++ src/tools/Makefile.am 2010-04-15 06:59:21 +0000
+@@ -1,4 +1,5 @@
+ bin_PROGRAMS=analyze chmorph hunspell munch unmunch hzip hunzip
++bin_PROGRAMS=hunspell-analyze hunspell-chmorph hunspell hunspell-munch hunspell-unmunch hzip hunzip
+
+ INCLUDES=-I${top_srcdir}/src/hunspell -I${top_srcdir}/src/parsers
+
+@@ -6,8 +7,8 @@
+ hunzip_SOURCES=hunzip.cxx
+ hunzip_LDADD = ../hunspell/libhunspell-1.2.la
+
+-munch_SOURCES=munch.c munch.h
+-unmunch_SOURCES=unmunch.c unmunch.h
++hunspell_munch_SOURCES=munch.c munch.h
++hunspell_unmunch_SOURCES=unmunch.c unmunch.h
+
+ example_SOURCES=example.cxx
+ example_LDADD = ../hunspell/libhunspell-1.2.la
+@@ -16,11 +17,11 @@
+ hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../hunspell/libhunspell-1.2.la \
+ ../parsers/libparsers.a @CURSESLIB@ @READLINELIB@
+
+-analyze_SOURCES=analyze.cxx
+-analyze_LDADD = ../hunspell/libhunspell-1.2.la
++hunspell_analyze_SOURCES=analyze.cxx
++hunspell_analyze_LDADD = ../hunspell/libhunspell-1.2.la
+
+-chmorph_SOURCES=chmorph.cxx
+-chmorph_LDADD = ../hunspell/libhunspell-1.2.la ../parsers/libparsers.a
++hunspell_chmorph_SOURCES=chmorph.cxx
++hunspell_chmorph_LDADD = ../hunspell/libhunspell-1.2.la ../parsers/libparsers.a
+
+ noinst_PROGRAMS=example
+
+
+=== modified file 'src/tools/example.cxx'
+--- src/tools/example.cxx 2010-04-15 06:56:50 +0000
++++ src/tools/example.cxx 2010-04-15 06:57:34 +0000
+@@ -17,8 +17,8 @@
+ /* first parse the command line options */
+
+ if (argc < 4) {
+- fprintf(stderr,"example (now it works with more dictionary files):\n");
+- fprintf(stderr,"example affix_file dictionary_file(s) file_of_words_to_check\n");
++ fprintf(stderr,"hunspell-example (now it works with more dictionary files):\n");
++ fprintf(stderr,"hunspell-example affix_file dictionary_file(s) file_of_words_to_check\n");
+ exit(1);
+ }
+
+
+=== modified file 'src/tools/munch.c'
+--- src/tools/munch.c 2010-04-15 06:56:50 +0000
++++ src/tools/munch.c 2010-04-15 06:57:34 +0000
+@@ -42,14 +42,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+
+
+=== modified file 'src/tools/unmunch.c'
+--- src/tools/unmunch.c 2010-04-15 06:56:50 +0000
++++ src/tools/unmunch.c 2010-04-15 06:57:34 +0000
+@@ -39,14 +39,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+
+
+=== modified file 'tests/test.sh'
+--- tests/test.sh 2010-04-15 06:56:50 +0000
++++ tests/test.sh 2010-04-15 07:00:31 +0000
+@@ -34,7 +34,7 @@
+ shopt -s expand_aliases
+
+ alias hunspell='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/hunspell'
+-alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/analyze'
++alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/hunspell-analyze'
+
+ if [ "$VALGRIND" != "" ]; then
+ rm -f $TEMPDIR/test.pid*
+@@ -42,7 +42,7 @@
+ mkdir $TEMPDIR/badlogs
+ fi
+ alias hunspell='valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/.libs/lt-hunspell'
+- alias analyze='valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/.libs/lt-analyze'
++ alias analyze='valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/.libs/lt-hunspell-analyze'
+ fi
+
+ # Tests good words
+