summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-05-12 22:40:28 +0000
committerPeter Volkov <pva@gentoo.org>2008-05-12 22:40:28 +0000
commitcaba8041dc81aa9b4557458e159ce3c5b0c32023 (patch)
treee48f0c78dcbae2c9a5f412c0051e42bb6eb15a7e /app-text/hunspell/files
parentStable for HPPA (bug #221063). (diff)
downloadgentoo-2-caba8041dc81aa9b4557458e159ce3c5b0c32023.tar.gz
gentoo-2-caba8041dc81aa9b4557458e159ce3c5b0c32023.tar.bz2
gentoo-2-caba8041dc81aa9b4557458e159ce3c5b0c32023.zip
Version bump, bug #219811, thank András for report. Fixed libtool-2.x breakage, bug #220114, reported by Alessandro Guido. Removed very old ebuild.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-text/hunspell/files')
-rw-r--r--app-text/hunspell/files/hunspell-1.2.2-libtool-2.22.patch16
-rw-r--r--app-text/hunspell/files/hunspell-1.2.2-renameexes.patch115
2 files changed, 131 insertions, 0 deletions
diff --git a/app-text/hunspell/files/hunspell-1.2.2-libtool-2.22.patch b/app-text/hunspell/files/hunspell-1.2.2-libtool-2.22.patch
new file mode 100644
index 000000000000..f5c44b5728ae
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.2.2-libtool-2.22.patch
@@ -0,0 +1,16 @@
+=== modified file 'configure.ac'
+--- configure.ac 2008-05-04 18:40:59 +0000
++++ configure.ac 2008-05-04 18:41:05 +0000
+@@ -15,11 +15,6 @@
+ AC_SUBST(HUNSPELL_VERSION_MAJOR)
+ AC_SUBST(HUNSPELL_VERSION_MINOR)
+
+-# library version
+-LT_CURRENT=1
+-LT_REVISION=0
+-LT_AGE=0
+-
+ AC_CONFIG_SRCDIR([config.h.in])
+ AC_CONFIG_HEADER([config.h])
+
+
diff --git a/app-text/hunspell/files/hunspell-1.2.2-renameexes.patch b/app-text/hunspell/files/hunspell-1.2.2-renameexes.patch
new file mode 100644
index 000000000000..17d65dc14232
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.2.2-renameexes.patch
@@ -0,0 +1,115 @@
+=== modified file 'src/tools/Makefile.am'
+--- src/tools/Makefile.am 2008-05-04 15:53:24 +0000
++++ src/tools/Makefile.am 2008-05-04 15:55:45 +0000
+@@ -1,4 +1,4 @@
+-bin_PROGRAMS=analyze chmorph example hunspell munch unmunch hzip hunzip
++bin_PROGRAMS=hunspell-analyze hunspell-chmorph hunspell-example hunspell hunspell-munch hunspell-unmunch hzip hunzip
+
+ INCLUDES=-I${top_srcdir}/src/hunspell -I${top_srcdir}/src/parsers
+
+@@ -6,23 +6,23 @@
+ hunzip_SOURCES=hunzip.cxx
+ hunzip_LDADD = ../hunspell/libhunspell-1.2.la
+
+-munch_SOURCES=munch.c
+-unmunch_SOURCES=unmunch.c
++hunspell_munch_SOURCES=munch.c
++hunspell_unmunch_SOURCES=unmunch.c
+ include_HEADERS=munch.h unmunch.h
+
+-example_SOURCES=example.cxx
+-example_LDADD = ../hunspell/libhunspell-1.2.la
++hunspell_example_SOURCES=example.cxx
++hunspell_example_LDADD = ../hunspell/libhunspell-1.2.la
+
+ hunspell_SOURCES=hunspell.cxx
+ hunspell_LDADD = @LIBINTL@ ../hunspell/libhunspell-1.2.la \
+ ../parsers/libparsers.a @CURSESLIB@ @READLINELIB@
+
+-analyze_SOURCES=analyze.cxx
+-analyze_LDADD = ../hunspell/libhunspell-1.2.la
+-
+-chmorph_SOURCES=chmorph.cxx
+-chmorph_LDADD = ../hunspell/libhunspell-1.2.la ../parsers/libparsers.a
+-
+-noinst_PROGRAMS=example
++hunspell_analyze_SOURCES=analyze.cxx
++hunspell_analyze_LDADD = ../hunspell/libhunspell-1.2.la
++
++hunspell_chmorph_SOURCES=chmorph.cxx
++hunspell_chmorph_LDADD = ../hunspell/libhunspell-1.2.la ../parsers/libparsers.a
++
++noinst_PROGRAMS=hunspell-example
+
+ EXTRA_DIST=makealias affixcompress
+
+=== modified file 'src/tools/example.cxx'
+--- src/tools/example.cxx 2008-05-04 15:53:24 +0000
++++ src/tools/example.cxx 2008-05-04 15:54:12 +0000
+@@ -17,8 +17,8 @@
+ /* first parse the command line options */
+
+ if (argc < 4) {
+- fprintf(stderr,"example (now it works with more dictionary files):\n");
+- fprintf(stderr,"example affix_file dictionary_file(s) file_of_words_to_check\n");
++ fprintf(stderr,"hunspell-example (now it works with more dictionary files):\n");
++ fprintf(stderr,"hunspell-example affix_file dictionary_file(s) file_of_words_to_check\n");
+ exit(1);
+ }
+
+
+=== modified file 'src/tools/munch.c'
+--- src/tools/munch.c 2008-05-04 15:53:24 +0000
++++ src/tools/munch.c 2008-05-04 15:56:18 +0000
+@@ -42,14 +42,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+
+
+=== modified file 'src/tools/unmunch.c'
+--- src/tools/unmunch.c 2008-05-04 15:53:24 +0000
++++ src/tools/unmunch.c 2008-05-04 15:56:39 +0000
+@@ -39,14 +39,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+
+
+=== modified file 'tests/test.sh'
+--- tests/test.sh 2008-05-04 15:53:24 +0000
++++ tests/test.sh 2008-05-04 15:57:07 +0000
+@@ -34,7 +34,7 @@
+ shopt -s expand_aliases
+
+ alias hunspell='../src/tools/hunspell'
+-alias analyze='../src/tools/analyze'
++alias analyze='../src/tools/hunspell-analyze'
+
+ if [ "$VALGRIND" != "" ]; then
+ rm -f $TEMPDIR/test.pid*
+