summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-12-06 06:04:30 +0000
committerTim Harder <radhermit@gentoo.org>2014-12-06 06:04:30 +0000
commit1c5977aae4fe157e9cb111526955b881c4185520 (patch)
tree9e8b2b3bf7d92076cb6ef09c2598e21765ad8a2d /www-client/dwb
parentRemove unneeded blank line (diff)
downloadgentoo-2-1c5977aae4fe157e9cb111526955b881c4185520.tar.gz
gentoo-2-1c5977aae4fe157e9cb111526955b881c4185520.tar.bz2
gentoo-2-1c5977aae4fe157e9cb111526955b881c4185520.zip
Respect CFLAGS (bug #531750).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-client/dwb')
-rw-r--r--www-client/dwb/ChangeLog8
-rw-r--r--www-client/dwb/dwb-2014.03.07-r1.ebuild50
-rw-r--r--www-client/dwb/files/dwb-2014.03.07-makefile.patch200
3 files changed, 257 insertions, 1 deletions
diff --git a/www-client/dwb/ChangeLog b/www-client/dwb/ChangeLog
index 8ef588c57b2f..9c20affaba18 100644
--- a/www-client/dwb/ChangeLog
+++ b/www-client/dwb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/dwb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/ChangeLog,v 1.23 2014/07/06 13:23:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/ChangeLog,v 1.24 2014/12/06 06:04:30 radhermit Exp $
+
+*dwb-2014.03.07-r1 (06 Dec 2014)
+
+ 06 Dec 2014; Tim Harder <radhermit@gentoo.org> +dwb-2014.03.07-r1.ebuild,
+ +files/dwb-2014.03.07-makefile.patch:
+ Respect CFLAGS (bug #531750).
06 Jul 2014; Michał Górny <mgorny@gentoo.org> dwb-2013.03.30.ebuild,
dwb-2014.03.07.ebuild:
diff --git a/www-client/dwb/dwb-2014.03.07-r1.ebuild b/www-client/dwb/dwb-2014.03.07-r1.ebuild
new file mode 100644
index 000000000000..b9118e54f7d7
--- /dev/null
+++ b/www-client/dwb/dwb-2014.03.07-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-2014.03.07-r1.ebuild,v 1.1 2014/12/06 06:04:30 radhermit Exp $
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
+HOMEPAGE="http://portix.bitbucket.org/dwb/"
+SRC_URI="https://www.bitbucket.org/portix/dwb/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples gtk3"
+
+RDEPEND=">=net-libs/libsoup-2.32:2.4
+ dev-libs/json-c
+ net-libs/gnutls
+ !gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:2
+ x11-libs/gtk+:2
+ )
+ gtk3? (
+ >=net-libs/webkit-gtk-1.8.0:3
+ x11-libs/gtk+:3
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ local myconf
+ use gtk3 && myconf+=" GTK=3"
+
+ emake CC="$(tc-getCC)" ${myconf}
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/www-client/dwb/files/dwb-2014.03.07-makefile.patch b/www-client/dwb/files/dwb-2014.03.07-makefile.patch
new file mode 100644
index 000000000000..2221c31fd335
--- /dev/null
+++ b/www-client/dwb/files/dwb-2014.03.07-makefile.patch
@@ -0,0 +1,200 @@
+--- dwb-2014.03.07/config.mk
++++ dwb-2014.03.07/config.mk
+@@ -146,12 +146,9 @@
+ CFLAGS := $(CFLAGS)
+ CFLAGS += -Wall
+ CFLAGS += -Werror=format-security
+-CFLAGS += -pipe
+ CFLAGS += --ansi
+ CFLAGS += -std=c99
+ CFLAGS += -D_POSIX_C_SOURCE='200112L'
+-CFLAGS += -O2
+-CFLAGS += -g
+ CFLAGS += -D_BSD_SOURCE
+ CFLAGS += -D_NETBSD_SOURCE
+ CFLAGS += -D__BSD_VISIBLE
+--- dwb-2014.03.07/dwbem/Makefile
++++ dwb-2014.03.07/dwbem/Makefile
+@@ -15,7 +15,7 @@
+
+ CFLAGS := $(CFLAGS)
+ CFLAGS += -std=c99
+-CFLAGS += -Wall -O2 -pedantic
++CFLAGS += -Wall -pedantic
+ CFLAGS += -Wextra -Werror=format-security
+ CFLAGS += $(shell pkg-config --cflags $(LIBS))
+ CFLAGS += -DSYSTEM_EXTENSION_DIR=\"$(SYSTEM_EXTENSION_DIR)\"
+@@ -27,12 +27,10 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $@ $(LDFLAGS)
++ $(CC) $(OBJ) -o $@ $(LDFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
++ $(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
+
+ clean:
+ rm -f $(TARGET) $(OBJ)
+--- dwb-2014.03.07/dwbremote/Makefile
++++ dwb-2014.03.07/dwbremote/Makefile
+@@ -7,7 +7,7 @@
+ include $(BASE_DIR)/version.mk
+
+
+-CFLAGS += -Wall -pedantic -Werror -Wextra -std=c99 -Os
++CFLAGS += -Wall -pedantic -Wextra -std=c99
+ CFLAGS += -DVERSION=\"$(VERSION)\"
+ CFLAGS += -DNAME=\"$(NAME)\"
+ CFLAGS += -DCOPYRIGHT=\"$(COPYRIGHT)\"
+@@ -27,12 +27,10 @@
+ all: $(TARGET)
+
+ $(TARGET): $(SHARED_OBJ) main.o
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
++ $(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
+
+ debug:
+ make CFLAGS="$(DCFLAGS)"
+--- dwb-2014.03.07/exar/Makefile
++++ dwb-2014.03.07/exar/Makefile
+@@ -1,6 +1,6 @@
+ ORIG_CFLAGS := $(CFLAGS)
+
+-CFLAGS := -Wall -pedantic -Werror -Wextra -std=c99 -O2
++CFLAGS := -Wall -pedantic -Wextra -std=c99
+ CFLAGS += $(ORIG_CFLAGS)
+
+ DCFLAGS += -g -O0 -Wall -pedantic -Werror -Wextra -std=c99
+@@ -14,12 +14,10 @@
+ all: $(SHARED_OBJ)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS)
++ $(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS)
+
+ %.o: %.c
+- @echo $(CC) $<
+- @$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
+
+ debug:
+ make CFLAGS="$(DCFLAGS)"
+--- dwb-2014.03.07/Makefile
++++ dwb-2014.03.07/Makefile
+@@ -14,18 +14,18 @@
+ $(TARGET): $(SUBDIRS:%=%.subdir-make)
+
+ %.subdir-make: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+- @$(MAKE) $(MFLAGS) -C $*
++ $(MAKE) $(MFLAGS) -C $*
+
+ #$(SRCDIR)/%: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+
+ %.subdir-buildfirst:
+- @$(MAKE) $(MFLAGS) -C $*
++ $(MAKE) $(MFLAGS) -C $*
+
+ clean: $(SUBDIRS:%=%.subdir-clean) $(SUBDIR_BUILD_FIRST:%=%.subdir-cleanfirst) $(SUBDIR_BUILD_LIB:%=%.subdir-cleanlib)
+ -$(RM) -r sandbox
+
+ %.subdir-clean %.subdir-cleanfirst %.subdir-cleanlib:
+- @$(MAKE) $(MFLAGS) clean -C $*
++ $(MAKE) $(MFLAGS) clean -C $*
+
+
+ install: $(TARGET) install-man install-data
+--- dwb-2014.03.07/scripts/lib/Makefile
++++ dwb-2014.03.07/scripts/lib/Makefile
+@@ -1,6 +1,6 @@
+ # See COPYING for copyright and license details
+ TARGETS := $(patsubst %.js.in, %.js, $(wildcard *.js.in))
+-CFLAGS := -std=c99 -Wall -Wextra -pedantic -Werror -O2
++CFLAGS += -std=c99 -Wall -Wextra -pedantic
+
+ all: $(TARGETS)
+
+@@ -9,7 +9,7 @@
+ @./minify $< $@
+
+ minify: minify.c
+- $(CC) $< -o $@ ${CFLAGS} ${CPPFLAGS}
++ $(CC) $< -o $@ ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}
+
+ clean:
+ $(RM) $(TARGETS)
+--- dwb-2014.03.07/src/Makefile
++++ dwb-2014.03.07/src/Makefile
+@@ -26,30 +26,25 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJ)
+- @echo $(CC) -o $@
+- @$(CC) $(OBJ) -o $(TARGET) $(LDFLAGS)
++ $(CC) $(OBJ) -o $(TARGET) $(LDFLAGS)
+
+ -include $(OBJ:.o=.d)
+ -include $(DOBJ:.do=.dd)
+
+ %.o: %.c %.h config.h dwb.h
+- @echo $(CC) $<
+- @$(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS)
++ $(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS)
+
+ debug: $(DTARGET)
+
+ deps.d: %.c %.h
+- @echo "$(CC) -MM $@"
+- @$(CC) $(CFLAGS) -MM $< -o $@
++ $(CC) $(CFLAGS) -MM $< -o $@
+
+
+ %.do: %.c %.h config.h
+- @echo "${CC} $<"
+- @$(CC) -c -o $@ $< $(DCFLAGS)
++ $(CC) -c -o $@ $< $(DCFLAGS)
+
+ $(DTARGET): $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o
+- @echo "$(CC) $@"
+- @$(CC) $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o -o $(DTARGET) $(LDFLAGS)
++ $(CC) $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o -o $(DTARGET) $(LDFLAGS)
+
+ dependencies: $(DEPS)
+
+--- dwb-2014.03.07/src/util/Makefile
++++ dwb-2014.03.07/src/util/Makefile
+@@ -30,20 +30,16 @@
+ all: $(OUTFILES)
+
+ $(TLDS_H): $(TLDS_IN) $(MKTLDS)
+- @echo gen $(notdir $@)
+- @./$(MKTLDS) < $(TLDS_IN) > $@
++ ./$(MKTLDS) < $(TLDS_IN) > $@
+
+ $(MKTLDS): $(MKTLDS_SRC)
+- @echo $(CC) $<
+- @$(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
++ $(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+
+ $(HSTS_PRELOAD): $(HSTS) $(TRANSPORT_SECURITY_CERTS) $(TRANSPORT_SECURITY_JSON)
+- @echo gen $(notdir $@)
+- @./$(HSTS) > $@
++ ./$(HSTS) > $@
+
+ $(HSTS): $(HSTS).c
+- @echo $(CC) $<
+- @$(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
+
+ clean:
+ $(RM) $(OUTFILES) $(GEN_TOOLS)