summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-09-21 07:47:32 +0000
committerMichał Górny <mgorny@gentoo.org>2011-09-21 07:47:32 +0000
commitd35d5e5485ec1b6192962e0e26fd054170f16d18 (patch)
tree87e958cd6abb2014ca82c8352224e0619ee69324 /www-client/luakit
parentMigrate to git-2. (diff)
downloadgentoo-2-d35d5e5485ec1b6192962e0e26fd054170f16d18.tar.gz
gentoo-2-d35d5e5485ec1b6192962e0e26fd054170f16d18.tar.bz2
gentoo-2-d35d5e5485ec1b6192962e0e26fd054170f16d18.zip
Migrate to git-2, fix github hack to PMS-compliant one.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'www-client/luakit')
-rw-r--r--www-client/luakit/ChangeLog5
-rw-r--r--www-client/luakit/luakit-9999.ebuild21
2 files changed, 14 insertions, 12 deletions
diff --git a/www-client/luakit/ChangeLog b/www-client/luakit/ChangeLog
index 3c96636d9e23..17154885b8c9 100644
--- a/www-client/luakit/ChangeLog
+++ b/www-client/luakit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-client/luakit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/ChangeLog,v 1.26 2011/07/27 10:36:29 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/ChangeLog,v 1.27 2011/09/21 07:47:32 mgorny Exp $
+
+ 21 Sep 2011; Michał Górny <mgorny@gentoo.org> luakit-9999.ebuild:
+ Migrate to git-2, fix github hack to PMS-compliant one.
*luakit-2011.07.22_p1 (27 Jul 2011)
diff --git a/www-client/luakit/luakit-9999.ebuild b/www-client/luakit/luakit-9999.ebuild
index 798729939128..1e96e5f61411 100644
--- a/www-client/luakit/luakit-9999.ebuild
+++ b/www-client/luakit/luakit-9999.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/luakit-9999.ebuild,v 1.17 2011/06/30 17:07:49 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/luakit-9999.ebuild,v 1.18 2011/09/21 07:47:32 mgorny Exp $
EAPI=3
IUSE="luajit vim-syntax"
if [[ ${PV} == *9999* ]]; then
- inherit git
- EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/mason-larobina/luakit.git"}
- [[ ${EGIT_BRANCH} == "master" ]] && EGIT_BRANCH="develop"
- [[ ${EGIT_COMMIT} == "master" ]] && EGIT_COMMIT=${EGIT_BRANCH}
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mason-larobina/${PN}.git
+ https://github.com/mason-larobina/${PN}.git"
+ EGIT_BRANCH="develop"
KEYWORDS=""
SRC_URI=""
else
inherit base
MY_PV="${PV/_p/-r}"
KEYWORDS="~amd64 ~x86"
- SRC_URI="http://github.com/mason-larobina/${PN}/tarball/${MY_PV} -> ${P}.tar.gz"
+ SRC_URI="https://github.com/mason-larobina/${PN}/tarball/${MY_PV} -> ${P}.tar.gz"
fi
DESCRIPTION="fast, small, webkit-gtk based micro-browser extensible by lua"
@@ -49,13 +49,12 @@ RDEPEND="
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
"
-src_prepare() {
+src_unpack() {
if [[ ${PV} == *9999* ]]; then
- git_src_prepare
+ git-2_src_unpack
else
- cd "${WORKDIR}"/mason-larobina-luakit-*
- S=$(pwd)
- base_src_prepare
+ base_src_unpack
+ mv mason-larobina-luakit-* "${S}"
fi
}