summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-11-05 23:18:24 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-11-05 23:18:24 +0000
commit6a377690d82f921807d8f6f33400b84873cd94e2 (patch)
tree4b39bd75d513512dcb202b0849f51742033368b2 /www-client/seamonkey
parentMove IUSE=selinux to the eclass (diff)
downloadgentoo-2-6a377690d82f921807d8f6f33400b84873cd94e2.tar.gz
gentoo-2-6a377690d82f921807d8f6f33400b84873cd94e2.tar.bz2
gentoo-2-6a377690d82f921807d8f6f33400b84873cd94e2.zip
fixed bugs 528062, 527010; moved IUSE=selinux to the eclass
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'www-client/seamonkey')
-rw-r--r--www-client/seamonkey/ChangeLog9
-rw-r--r--www-client/seamonkey/files/seamonkey-2.30-webm-disallow-negative-samples.patch29
-rw-r--r--www-client/seamonkey/seamonkey-2.30-r1.ebuild (renamed from www-client/seamonkey/seamonkey-2.30.ebuild)33
3 files changed, 45 insertions, 26 deletions
diff --git a/www-client/seamonkey/ChangeLog b/www-client/seamonkey/ChangeLog
index 75f45cf6616d..d0707f81fbf8 100644
--- a/www-client/seamonkey/ChangeLog
+++ b/www-client/seamonkey/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/seamonkey
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/ChangeLog,v 1.499 2014/11/02 10:28:35 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/ChangeLog,v 1.500 2014/11/05 23:18:24 axs Exp $
+
+*seamonkey-2.30-r1 (05 Nov 2014)
+
+ 05 Nov 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +files/seamonkey-2.30-webm-disallow-negative-samples.patch,
+ +seamonkey-2.30-r1.ebuild, -seamonkey-2.30.ebuild:
+ fixed bugs 528062, 527010; moved IUSE=selinux to the eclass
02 Nov 2014; Sven Vermeulen <swift@gentoo.org> seamonkey-2.26.1.ebuild,
seamonkey-2.29.1.ebuild, seamonkey-2.30.ebuild:
diff --git a/www-client/seamonkey/files/seamonkey-2.30-webm-disallow-negative-samples.patch b/www-client/seamonkey/files/seamonkey-2.30-webm-disallow-negative-samples.patch
new file mode 100644
index 000000000000..1a79affc38b9
--- /dev/null
+++ b/www-client/seamonkey/files/seamonkey-2.30-webm-disallow-negative-samples.patch
@@ -0,0 +1,29 @@
+--- a/mozilla/content/media/webm/WebMReader.cpp 2014-10-20 21:59:39.000000000 -0400
++++ b/mozilla/content/media/webm/WebMReader.cpp 2014-10-28 09:06:51.959665416 -0400
+@@ -668,7 +668,15 @@
+ return true;
+ }
+ int32_t keepFrames = frames - skipFrames;
++ if (keepFrames < 0) {
++ NS_WARNING("Int overflow in keepFrames");
++ return false;
++ }
+ int samples = keepFrames * channels;
++ if (samples < 0) {
++ NS_WARNING("Int overflow in samples");
++ return false;
++ }
+ nsAutoArrayPtr<AudioDataValue> trimBuffer(new AudioDataValue[samples]);
+ for (int i = 0; i < samples; i++)
+ trimBuffer[i] = buffer[skipFrames*channels + i];
+@@ -691,6 +699,10 @@
+ int32_t keepFrames = frames - discardFrames.value();
+ if (keepFrames > 0) {
+ int samples = keepFrames * channels;
++ if (samples < 0) {
++ NS_WARNING("Int overflow in samples");
++ return false;
++ }
+ nsAutoArrayPtr<AudioDataValue> trimBuffer(new AudioDataValue[samples]);
+ for (int i = 0; i < samples; i++)
+ trimBuffer[i] = buffer[i];
diff --git a/www-client/seamonkey/seamonkey-2.30.ebuild b/www-client/seamonkey/seamonkey-2.30-r1.ebuild
index 17db5e27753c..a67a332b8beb 100644
--- a/www-client/seamonkey/seamonkey-2.30.ebuild
+++ b/www-client/seamonkey/seamonkey-2.30-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-2.30.ebuild,v 1.2 2014/11/02 10:28:35 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-2.30-r1.ebuild,v 1.1 2014/11/05 23:18:24 axs Exp $
EAPI=5
WANT_AUTOCONF="2.1"
@@ -49,7 +49,7 @@ fi
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="+chatzilla +crypt +ipc minimal pulseaudio +roaming selinux test"
+IUSE="+chatzilla +crypt +ipc minimal pulseaudio +roaming test"
SRC_URI="${SRC_URI}
${MOZ_FTP_URI}/source/${MY_MOZ_P}.source.tar.bz2 -> ${P}.source.tar.bz2
@@ -59,7 +59,7 @@ SRC_URI="${SRC_URI}
ASM_DEPEND=">=dev-lang/yasm-1.1"
-CDEPEND=">=dev-libs/nss-3.17.1
+RDEPEND=">=dev-libs/nss-3.17.1
>=dev-libs/nspr-4.10.6
crypt? ( || (
( >=app-crypt/gnupg-2.0
@@ -71,7 +71,7 @@ CDEPEND=">=dev-libs/nss-3.17.1
=app-crypt/gnupg-1.4* ) )
system-sqlite? ( >=dev-db/sqlite-3.8.5:3[secure-delete,debug=] )"
-DEPEND="${CDEPEND}
+DEPEND="${RDEPEND}
!elibc_glibc? ( !elibc_uclibc? ( dev-libs/libexecinfo ) )
crypt? ( dev-lang/perl )
amd64? ( ${ASM_DEPEND}
@@ -79,17 +79,13 @@ DEPEND="${CDEPEND}
x86? ( ${ASM_DEPEND}
virtual/opengl )"
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-mozilla )
-"
-
if [[ ${PV} == *beta* ]] ; then
S="${WORKDIR}/comm-beta"
else
S="${WORKDIR}/comm-release"
fi
-BUILD_OBJ_DIR="${WORKDIR}/seamonk"
+BUILD_OBJ_DIR="${S}/seamonk"
pkg_setup() {
if [[ ${PV} == *_pre* ]] ; then
@@ -125,7 +121,8 @@ src_prepare() {
epatch "${WORKDIR}/seamonkey"
epatch "${FILESDIR}"/${PN}-2.30-pulseaudio_configure_switch_fix.patch \
- "${FILESDIR}"/${PN}-2.30-jemalloc-configure.patch
+ "${FILESDIR}"/${PN}-2.30-jemalloc-configure.patch \
+ "${FILESDIR}"/${PN}-2.30-webm-disallow-negative-samples.patch
# browser patches go here
pushd "${S}"/mozilla &>/dev/null || die
@@ -223,9 +220,6 @@ src_configure() {
# Use an objdir to keep things organized.
echo "mk_add_options MOZ_OBJDIR=${BUILD_OBJ_DIR}" \
>> "${S}"/.mozconfig
- # Add a TOPSRCDIR too just in case
- echo "mk_add_options TOPSRCDIR=${S}" \
- >> "${S}"/.mozconfig
# Finalize and report settings
mozconfig_final
@@ -246,23 +240,12 @@ src_configure() {
append-flags -mno-avx
fi
fi
-
- mkdir -p "${BUILD_OBJ_DIR}" && cd "${BUILD_OBJ_DIR}" || die
- # run configure twice to get it to prepare the objdir and then actually set up properly
- # apparently necessary due to build system b0rkage on mozilla-33
- _moz_src_configure() {
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL}" \
- emake V=1 -f "${S}"/client.mk configure
- }
- _moz_src_configure
- _moz_src_configure
}
src_compile() {
CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL}" \
- emake V=1 -f "${S}"/client.mk
+ emake V=1 -f client.mk
# Only build enigmail extension if conditions are met.
if use crypt ; then