aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-30 15:30:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-07-30 15:31:02 +0200
commit4ea5cb935d21c3575995b69d838ca884f2f6d63f (patch)
treef06e7abae9b4f1ae8240003236ee776f19a98ace
parentupdate elog info to tell people to run mtxrun --generate, bug #555564 (diff)
downloadaballier-4ea5cb935d21c3575995b69d838ca884f2f6d63f.tar.gz
aballier-4ea5cb935d21c3575995b69d838ca884f2f6d63f.tar.bz2
aballier-4ea5cb935d21c3575995b69d838ca884f2f6d63f.zip
Make .extraebuild mandatory to take advantage of make dependencies
Remove trailing whitespaces.
-rw-r--r--scripts/texlive/tlpsrc/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/scripts/texlive/tlpsrc/Makefile b/scripts/texlive/tlpsrc/Makefile
index 16bee61..f4b6957 100644
--- a/scripts/texlive/tlpsrc/Makefile
+++ b/scripts/texlive/tlpsrc/Makefile
@@ -15,7 +15,7 @@ lists : $(FULLDESC:%=%.list) $(FULLDESC:%=%.base)
unpacked : $(FULLDESC:%=%.unpacked)
-%.base:
+%.base:
$(CPF) $(@:texlive-%.base=$(TL_TRUNK)/Master/tlpkg/tlpsrc/collection-%.tlpsrc) $@
-sh $(@:%.base=%.baseexec) $@
@@ -104,7 +104,10 @@ clean:
$(MAKE) CONTENTS="$(shell cat $<)" -f Makefile-dist cataloguehtml
touch $@
-%.ebuild: %.desc %.deps %.list %.doclist %.srclist %.gentoolicense
+%.extraebuild:
+ touch $@
+
+%.ebuild: %.desc %.deps %.list %.doclist %.srclist %.gentoolicense %.extraebuild
cat $(PORTDIR)/header.txt > $@
printf "EAPI=\"5\"\n\n" >> $@
echo -n "TEXLIVE_MODULE_CONTENTS=\"" >> $@
@@ -129,9 +132,9 @@ clean:
cat $(@:%.ebuild=%.deps) >> $@
echo "\"" >> $@
echo -n 'RDEPEND="$${DEPEND} ' >> $@
- -cat $(@:%.ebuild=%.extrardepend) >> $@
+ -cat $(@:%.ebuild=%.extrardepend) >> $@
echo '"' >> $@
- -cat $(@:%.ebuild=%.extraebuild) >> $@
+ cat $(@:%.ebuild=%.extraebuild) >> $@
dist: lists $(VERSIONNED_ZIPS) $(EXTRA_DIST:%=%.doclist) $(EXTRA_DIST:%=%.srclist)
$(MAKE) CONTENTS="$(EXTRA_ZIP)" -f Makefile-dist versionnedzips
@@ -143,9 +146,9 @@ ebuildsdir:
ebuilds: dist $(DESC:%=%.desc) $(DESC:%=%.ebuild) $(DESC:%=%.deps)
-tlpobj: $(DESC:%=%.tlpobj)
+tlpobj: $(DESC:%=%.tlpobj)
-tlpobj: $(DESC:%=%.tlplic)
+tlpobj: $(DESC:%=%.tlplic)
licenselist: $(DESC:%=%.licenselist) $(EXTRA_DIST:%=%.licenselist)