aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-31 13:28:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-31 13:28:01 +0000
commit00563436a8625a75fa61fcc982952ec6972b1c85 (patch)
tree2112214ba3b4d063a8f3712904c8fb1ecda136e4 /scripts/texlive/tlpsrc/Makefile
parentgenerate stricter deps (diff)
downloadaballier-00563436a8625a75fa61fcc982952ec6972b1c85.tar.gz
aballier-00563436a8625a75fa61fcc982952ec6972b1c85.tar.bz2
aballier-00563436a8625a75fa61fcc982952ec6972b1c85.zip
fix dep generation and use standard DEPEND/RDEPEND instead of TEXLIVE_MODULES_DEPS
svn path=/; revision=368
Diffstat (limited to 'scripts/texlive/tlpsrc/Makefile')
-rw-r--r--scripts/texlive/tlpsrc/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/scripts/texlive/tlpsrc/Makefile b/scripts/texlive/tlpsrc/Makefile
index 54a7e5f..e11a93d 100644
--- a/scripts/texlive/tlpsrc/Makefile
+++ b/scripts/texlive/tlpsrc/Makefile
@@ -49,7 +49,7 @@ lists : $(FULLDESC:%=%.list) $(FULLDESC:%=%.base)
echo '</pkgmetadata>' >> $@
%.deps: %.base
- grep "depend " $< | awk '{print $$2}' | grep "collection" | sed -e "s/collection/texlive/g" | sed -e "s/^/>=dev-texlive\//" | sed -e "s/$$/-$(TEXLIVE_VERSION)/" | sed -e "s/dev-texlive\/texlive-basicbin//g" | sed -e "s/dev-texlive\/texlive-fontbin//g" > $@
+ grep "depend " $< | awk '{print $$2}' | grep "collection" | grep -v "collection-basicbin" | grep -v "collection-fontbin" | sed -e "s/collection/texlive/g" | sed -e "s/^/>=dev-texlive\//" | sed -e "s/$$/-$(TEXLIVE_VERSION)/" > $@
-cat $(@:.deps=.extradeps) >> $@
clean:
@@ -89,9 +89,6 @@ clean:
%.ebuild: %.desc %.deps %.list %.doclist %.srclist %.gentoolicense
cat $(PORTDIR)/header.txt > $@
- echo -n "TEXLIVE_MODULES_DEPS=\"" >> $@
- cat $(@:%.ebuild=%.deps) >> $@
- echo "\"" >> $@
echo -n "TEXLIVE_MODULE_CONTENTS=\"" >> $@
cat $(@:%.ebuild=%.list) >> $@
echo "\"" >> $@
@@ -110,6 +107,10 @@ clean:
echo "SLOT=\"0\"" >> $@
echo "KEYWORDS=\"~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd\"" >> $@
echo "IUSE=\"\"" >> $@
+ echo -n "DEPEND=\"" >> $@
+ cat $(@:%.ebuild=%.deps) >> $@
+ echo "\"" >> $@
+ echo 'RDEPEND="$${DEPEND}"' >> $@
-cat $(@:%.ebuild=%.extraebuild) >> $@
dist: lists $(VERSIONNED_ZIPS) $(EXTRA_DIST:%=%.doclist) $(EXTRA_DIST:%=%.srclist)