summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/dmd-bin/Manifest12
-rw-r--r--dev-lang/dmd-bin/dmd-bin-1.014-r1.ebuild114
-rw-r--r--dev-lang/dmd-bin/files/25dmd2
-rw-r--r--dev-lang/dmd-bin/files/digest-dmd-bin-1.014-r13
4 files changed, 131 insertions, 0 deletions
diff --git a/dev-lang/dmd-bin/Manifest b/dev-lang/dmd-bin/Manifest
new file mode 100644
index 0000000..f02baf9
--- /dev/null
+++ b/dev-lang/dmd-bin/Manifest
@@ -0,0 +1,12 @@
+AUX 25dmd 40 RMD160 cb1eb838eaf98d9898134384d3aefeec86bdd50a SHA1 1b7b42ad749a3541fb80bb944a49706ff974bd91 SHA256 40a0ac49424a2ce0a372c66fac3c77b6634138beaacffda0c167f3a81d4a286c
+MD5 ce9610602af9ec245759402355292cc6 files/25dmd 40
+RMD160 cb1eb838eaf98d9898134384d3aefeec86bdd50a files/25dmd 40
+SHA256 40a0ac49424a2ce0a372c66fac3c77b6634138beaacffda0c167f3a81d4a286c files/25dmd 40
+DIST dmd.1.014.zip 4809385 RMD160 8c16cc82abee6cdd7208d18149bdb050e2461540 SHA1 823300dfb3e4693948191af05fc9918d72f8353a SHA256 810f60f4b934fa122d69d45b9301817157f4070ade1400ea05218d7e5e32b441
+EBUILD dmd-bin-1.014-r1.ebuild 3477 RMD160 34957c93b0d075706c6ec76ac10e229306f7351b SHA1 bec9aa58680596f67080f762e70c834a4703c89c SHA256 f37b92a566db1682ba68764f1eb619ac80cfd8ff9bebc7a17b6f5b4956cc0bb8
+MD5 9243e69cef51f147783cf46fbf629e0d dmd-bin-1.014-r1.ebuild 3477
+RMD160 34957c93b0d075706c6ec76ac10e229306f7351b dmd-bin-1.014-r1.ebuild 3477
+SHA256 f37b92a566db1682ba68764f1eb619ac80cfd8ff9bebc7a17b6f5b4956cc0bb8 dmd-bin-1.014-r1.ebuild 3477
+MD5 16ef1e95d5ab67afae5c2132981df57b files/digest-dmd-bin-1.014-r1 223
+RMD160 1701e5209b11d40a8422a3f182ce7f66f0af080a files/digest-dmd-bin-1.014-r1 223
+SHA256 71877c525cdc3320bb8cb4660c17bbb3f50379d2fb330ffd2da3729199d090e9 files/digest-dmd-bin-1.014-r1 223
diff --git a/dev-lang/dmd-bin/dmd-bin-1.014-r1.ebuild b/dev-lang/dmd-bin/dmd-bin-1.014-r1.ebuild
new file mode 100644
index 0000000..bc24c84
--- /dev/null
+++ b/dev-lang/dmd-bin/dmd-bin-1.014-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/dmd-bin-1.014.ebuild,v 1.1 2007/05/20 21:23:08 anant Exp $
+
+inherit eutils
+
+MY_P=${P/-bin/}
+MY_P=${MY_P/-/.}
+
+DESCRIPTION="Digital Mars D Compiler"
+HOMEPAGE="http://www.digitalmars.com/d/"
+SRC_URI="http://ftp.digitalmars.com/${MY_P}.zip"
+
+LICENSE="DMD"
+RESTRICT="mirror nostrip"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="phobos tango"
+
+LOC="/opt/dmd"
+S="${WORKDIR}"
+
+DEPEND="sys-apps/findutils"
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-compat )
+ x86? ( >=virtual/libstdc++-3.3 )"
+PDEPEND="phobos? ( dev-libs/phobos )
+ tango? ( dev-libs/tango )"
+
+pkg_setup() {
+ if use phobos && use tango; then
+ eerror " "
+ eerror "You have selected both phobos and tango as USE "
+ eerror "flags! Only a single standard library may be "
+ eerror "chosen. "
+ eerror " "
+ die "Multiple libraries selected"
+ fi
+
+ if ! use phobos && ! use tango; then
+ eerror " "
+ eerror "You have selected neither phobos or tango in "
+ eerror "your USE flags! Exactly one standard library "
+ eerror "must be chosen. "
+ eerror " "
+ die "No library selected"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Remove unneccessary files
+ rm -r ${S}/dmd/src/phobos
+ rm -r ${S}/dmd/lib
+ rm -r ${S}/dm
+ rm ${S}/dmd/bin/*.dll ${S}/dmd/bin/*.exe ${S}/dmd/bin/readme.txt
+ rm ${S}/dmd/bin/sc.ini ${S}/dmd/bin/windbg.hlp
+
+ # Cleanup line endings
+ cd ${S}/dmd
+ edos2unix `find . -name '*.c' -type f`
+ edos2unix `find . -name '*.d' -type f`
+ edos2unix `find . -name '*.ddoc' -type f`
+ edos2unix `find . -name '*.h' -type f`
+ edos2unix `find . -name '*.mak' -type f`
+ edos2unix `find . -name '*.txt' -type f`
+ edos2unix `find samples -name '*.html' -type f`
+
+ # Fix permissions
+ fperms guo=r `find . -type f`
+ fperms guo=rx `find . -type d`
+ fperms guo=rx bin/dmd bin/dumpobj bin/obj2asm bin/rdmd
+}
+
+src_install() {
+ cd ${S}/dmd
+
+ # Broken dmd.conf
+ # http://d.puremagic.com/issues/show_bug.cgi?id=278
+ mv bin/dmd bin/dmd.bin
+
+ # Man pages
+ doman man/man1/dmd.1
+ doman man/man1/dumpobj.1
+ doman man/man1/obj2asm.1
+ rm -r man
+
+ # Install
+ mkdir "${D}/opt"
+ mv "${S}/dmd" "${D}/opt/dmd"
+
+ # Set PATH
+ doenvd "${FILESDIR}/25dmd"
+}
+
+pkg_postinst () {
+ ewarn "The DMD Configuration file has been disabled, "
+ ewarn "and will be re-enabled when: "
+ ewarn " "
+ ewarn "http://d.puremagic.com/issues/show_bug.cgi?id=278"
+ ewarn " "
+ ewarn "has been fixed. Meanwhile, please supply all your"
+ ewarn "configuration options in the /opt/dmd/bin/dmd "
+ ewarn "shell script, *after* a standard library: "
+ ewarn "phobos or tango has been successfully merged. "
+ ewarn " "
+ ewarn "You may need to run: "
+ ewarn " "
+ ewarn "env-update && source /etc/profile "
+ ewarn " "
+ ewarn "to be able to use the compiler immediately. "
+ ewarn " "
+}
diff --git a/dev-lang/dmd-bin/files/25dmd b/dev-lang/dmd-bin/files/25dmd
new file mode 100644
index 0000000..ab7699d
--- /dev/null
+++ b/dev-lang/dmd-bin/files/25dmd
@@ -0,0 +1,2 @@
+PATH=/opt/dmd/bin
+ROOTPATH=/opt/dmd/bin
diff --git a/dev-lang/dmd-bin/files/digest-dmd-bin-1.014-r1 b/dev-lang/dmd-bin/files/digest-dmd-bin-1.014-r1
new file mode 100644
index 0000000..4901997
--- /dev/null
+++ b/dev-lang/dmd-bin/files/digest-dmd-bin-1.014-r1
@@ -0,0 +1,3 @@
+MD5 e4c912d5a25bd5dca2d6e7dd1a8b3ee1 dmd.1.014.zip 4809385
+RMD160 8c16cc82abee6cdd7208d18149bdb050e2461540 dmd.1.014.zip 4809385
+SHA256 810f60f4b934fa122d69d45b9301817157f4070ade1400ea05218d7e5e32b441 dmd.1.014.zip 4809385