summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdev-plan9/digest5
-rw-r--r--eclass/plan9-cmds.eclass24
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-plan9/digest b/dev-plan9/digest
new file mode 100755
index 0000000..e6bef0e
--- /dev/null
+++ b/dev-plan9/digest
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+for i in */*.ebuild; do
+ ebuild ${i} digest
+done
diff --git a/eclass/plan9-cmds.eclass b/eclass/plan9-cmds.eclass
new file mode 100644
index 0000000..01fc209
--- /dev/null
+++ b/eclass/plan9-cmds.eclass
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-meta.eclass,v 1.82 2007/03/18 21:39:30 carlo Exp $
+#
+# Author Anant Narayanan <anant@gentoo.org>
+#
+# This is the plan9-cmds eclass which supports broken-up Plan9 applications.
+
+inherit plan9-libs
+
+function plan9-cmds_src_compile() {
+ plan9-libs_src_compile
+}
+
+function plan9-cmds_src_install() {
+ set_path
+ mk install || die "Install Failed!"
+
+ dobin ${S}/bin/${PN}
+ doman ${S}/man/man1/${PN}.1
+}
+
+EXPORT_FUNCTIONS src_compile src_install
+