summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2016-09-08 22:38:52 -0500
committerJory A. Pratt <anarchy@gentoo.org>2016-09-08 22:42:35 -0500
commit80cc26434779b5463747f4a1e71e634d26c1158d (patch)
treebef8f8bbe80a94bda4f649cf8f7fcf197e954776
parentdev-embedded/u-boot-tools - update to latest release (diff)
downloadanarchy-80cc26434779b5463747f4a1e71e634d26c1158d.tar.gz
anarchy-80cc26434779b5463747f4a1e71e634d26c1158d.tar.bz2
anarchy-80cc26434779b5463747f4a1e71e634d26c1158d.zip
app-text/openlp : initial version bump to 2.4.2
-rw-r--r--app-text/openlp/Manifest3
-rw-r--r--app-text/openlp/files/OpenLP-2.4.2-disable-tests.patch22
-rw-r--r--app-text/openlp/openlp-2.4.2.ebuild43
3 files changed, 68 insertions, 0 deletions
diff --git a/app-text/openlp/Manifest b/app-text/openlp/Manifest
new file mode 100644
index 0000000..b47b4e1
--- /dev/null
+++ b/app-text/openlp/Manifest
@@ -0,0 +1,3 @@
+AUX OpenLP-2.4.2-disable-tests.patch 795 SHA256 a024fca478b34248d74d4c4a071ad637f1d5b1e45db3749608a9464271b64a4e SHA512 ac67c675a4793be0194ccdc522737de0fd2b7b008707c19cfb5dd4fd1c17e88a59c0d38cdfebb02272774da81dbf06ca8b897504abe3d37b5eeaf40b8d0c63f9 WHIRLPOOL 4fdbba70eaec1ca4bf29d3bdf8104f8ac887b99267880d964caf48f2bb1b7aaa4a34d21b067809f516cccb6ca1b1c80d63cc28a447431d04f5fad5facc2ccbe2
+DIST OpenLP-2.4.2.tar.gz 7430438 SHA256 ae56a9661a1847eb3c859fec3ac73e7b2e8b102b821232a26fd273f61a039c9c SHA512 650662231a5ef23460162f794237f8ecf54c20f8514793aef1b1bada2912e82c3e1a8aaec36e56a88ed38b5c282393635f6345926362080f8101ef6285a5d317 WHIRLPOOL 2771a17c76001b2981ceb4b5fad44319fa4218477fcdc00589a7e437ae6d721624ef5955ee041db20bf9bb6b802e90f386c7e87a95c53dcae9b52d7ebd072e7b
+EBUILD openlp-2.4.2.ebuild 1132 SHA256 773a157bcf0959424aa5e5383f8292ae1481e396ceabf8ef634e78c4e4f7e7e2 SHA512 efc79abfec0ba27c2805f7e463b3cda8f072d4428f51087a4f03447a570d70847897fdb64976b45ddeae793f0d62b91046103b3107eacd2e3e65c19410bffebd WHIRLPOOL eb32a7d6e84dbf33751957072b29975c29711d76201eb27cea64cd95ec224d05bd4aee83443e074ef0c0471a2ea40afdac0ee2883434f2b2ee973b6e54351e53
diff --git a/app-text/openlp/files/OpenLP-2.4.2-disable-tests.patch b/app-text/openlp/files/OpenLP-2.4.2-disable-tests.patch
new file mode 100644
index 0000000..0b1de65
--- /dev/null
+++ b/app-text/openlp/files/OpenLP-2.4.2-disable-tests.patch
@@ -0,0 +1,22 @@
+diff -urN a/setup.cfg b/setup.cfg
+--- a/setup.cfg 2016-06-25 13:20:56.000000000 -0500
++++ b/setup.cfg 2016-09-08 22:30:54.606413547 -0500
+@@ -2,3 +2,5 @@
+ exclude=resources.py,vlc.py
+ max-line-length = 120
+ ignore = E402
++[install]
++install_scripts=/usr/bin
+\ No newline at end of file
+diff -urN a/setup.py b/setup.py
+--- a/setup.py 2016-06-25 13:20:56.000000000 -0500
++++ b/setup.py 2016-09-08 22:30:50.523413394 -0500
+@@ -157,7 +157,7 @@
+ author_email='raoulsnyman@openlp.org',
+ url='http://openlp.org/',
+ license='GNU General Public License',
+- packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
++ packages=find_packages(exclude=['ez_setup', 'examples', 'tests', 'tests.*']),
+ scripts=['openlp.py'],
+ include_package_data=True,
+ zip_safe=False,
diff --git a/app-text/openlp/openlp-2.4.2.ebuild b/app-text/openlp/openlp-2.4.2.ebuild
new file mode 100644
index 0000000..528b0e0
--- /dev/null
+++ b/app-text/openlp/openlp-2.4.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_4)
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Free church presentation software"
+HOMEPAGE="http://openlp.org/"
+SRC_URI="https://get.openlp.org/${PV}/OpenLP-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pyenchant-1.3[${PYTHON_USEDEP}]
+ dev-python/pyodbc
+ dev-python/PyQt5[multimedia,gui,network,svg,webkit,${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.5[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy-migrate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/OpenLP-${PV}
+
+PATCHES=( "${FILESDIR}"/OpenLP-${PV}-disable-tests.patch )
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu resources/openlp.desktop
+ dosym openlp.py /usr/bin/openlp
+ doicon -s scalable resources/images/openlp.svg
+}