summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2012-06-27 06:34:00 -0500
committerJory A. Pratt <anarchy@gentoo.org>2012-06-27 06:34:00 -0500
commitc8d1486fb1bf0a40108d8b246544bc3a36e01821 (patch)
treef6f5756392055489aa1f8af86e392bf53f4da812
parentupdate for blueman, fix dbus libaudit support for selinux (diff)
downloadanarchy-c8d1486fb1bf0a40108d8b246544bc3a36e01821.tar.gz
anarchy-c8d1486fb1bf0a40108d8b246544bc3a36e01821.tar.bz2
anarchy-c8d1486fb1bf0a40108d8b246544bc3a36e01821.zip
Fix polkit pax-marking so only occurs when appropriate.
-rw-r--r--sys-auth/polkit/Manifest2
-rw-r--r--sys-auth/polkit/polkit-0.106-r5.ebuild107
2 files changed, 109 insertions, 0 deletions
diff --git a/sys-auth/polkit/Manifest b/sys-auth/polkit/Manifest
new file mode 100644
index 0000000..3d07302
--- /dev/null
+++ b/sys-auth/polkit/Manifest
@@ -0,0 +1,2 @@
+DIST polkit-0.106.tar.gz 1381428 RMD160 6fa79aaa4e67e072d16860f1a242b053cc311bc3 SHA1 665624f5d69876ec5833f7952290188ca594aac0 SHA256 4005076a67aaa182872c1e316939fcb0ba74a89298e6330d72cfdac6624c984e
+EBUILD polkit-0.106-r5.ebuild 2973 RMD160 d901d0aa0909bea42621f3dfc43162e40407e6f1 SHA1 81fff347b79f13e0ab8c246302f824431c386003 SHA256 bdcc0b1913e44fc4053b9981ce824ad7032314dabfff7bfb0cf6359e45d101f2
diff --git a/sys-auth/polkit/polkit-0.106-r5.ebuild b/sys-auth/polkit/polkit-0.106-r5.ebuild
new file mode 100644
index 0000000..a6b628b
--- /dev/null
+++ b/sys-auth/polkit/polkit-0.106-r5.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.106-r5.ebuild,v 1.1 2012/06/27 10:24:22 ssuominen Exp $
+
+EAPI=4
+inherit eutils multilib pam pax-utils systemd user
+
+DESCRIPTION="Policy framework for controlling privileges for system-wide services"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/polkit"
+SRC_URI="http://www.freedesktop.org/software/${PN}/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug examples gtk +introspection kde nls pam systemd"
+
+RDEPEND=">=dev-lang/spidermonkey-1.8.5
+ >=dev-libs/glib-2.32
+ >=dev-libs/expat-2
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+ pam? (
+ sys-auth/pambase
+ virtual/pam
+ )
+ systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/intltool
+ virtual/pkgconfig"
+PDEPEND="
+ gtk? ( || (
+ >=gnome-extra/polkit-gnome-0.105
+ lxde-base/lxpolkit
+ ) )
+ kde? ( sys-auth/polkit-kde-agent )
+ pam? (
+ systemd? ( sys-auth/pambase[systemd] )
+ !systemd? ( sys-auth/pambase[consolekit] )
+ )
+ !systemd? ( >=sys-auth/consolekit-0.4.5_p2012[policykit] )"
+
+pkg_setup() {
+ local u=polkitd
+ local g=polkitd
+ local h=/var/lib/polkit-1
+
+ enewgroup ${g}
+ enewuser ${u} -1 -1 ${h} ${g}
+ esethome ${u} ${h}
+}
+
+src_prepare() {
+ sed -i -e 's|unix-group:wheel|unix-user:0|' src/polkitbackend/*-default.rules || die #401513
+ has_version ">=dev-lang/spidermonkey-1.8.7" && { sed -i -e '/mozjs/s:185:187:g' configure || die; }
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --disable-static \
+ $(use_enable debug verbose-mode) \
+ --enable-man-pages \
+ --disable-gtk-doc \
+ $(use_enable systemd libsystemd-login) \
+ $(use_enable introspection) \
+ --disable-examples \
+ $(use_enable nls) \
+ "$(systemd_with_unitdir)" \
+ --with-authfw=$(usex pam pam shadow) \
+ $(use pam && echo --with-pam-module-dir="$(getpam_mod_dir)") \
+ --with-os-type=gentoo
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ libprivdir="${EPREFIX}"/usr/$(get_libdir)/polkit-1 \
+ install
+
+ dodoc docs/TODO HACKING NEWS README
+
+ fowners -R polkitd:root /{etc,usr/share}/polkit-1/rules.d
+
+ diropts -m0700 -o polkitd -g polkitd
+ keepdir /var/lib/polkit-1
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/examples/{*.c,*.policy*}
+ fi
+
+ prune_libtool_files
+ rm -f "${ED}"/usr/lib*/pkgconfig/polkit-backend-1.pc #423431
+
+ # Required for polkitd on hardened/PaX due to spidermonkey's JIT
+ if has_version "<dev-lang/spidermonkey-1.8.7" || has_version ">=dev-lang/spidermonkey-1.8.7" &&
+ built_with_use dev-lang/spidermonkey jit ; then
+ pax-mark mr "${ED}usr/lib/polkit-1/polkitd"
+ fi
+}
+
+pkg_postinst() {
+ chown -R polkitd:root "${EROOT}"/{etc,usr/share}/polkit-1/rules.d
+ chown -R polkitd:polkitd "${EROOT}"/var/lib/polkit-1
+}