summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2017-10-23 09:50:17 -0500
committerJory A. Pratt <anarchy@gentoo.org>2017-10-23 09:50:17 -0500
commit4bc8f6a84948133bff4855b8612f136ffbe5f731 (patch)
tree1aff8a1f2ed501e50d693fc7b58370bbcd438273 /dev-util/cargo/cargo-0.22.0.ebuild
parentdev-util/cargo - 0.22.0 version bump (diff)
downloadanarchy-4bc8f6a84948133bff4855b8612f136ffbe5f731.tar.gz
anarchy-4bc8f6a84948133bff4855b8612f136ffbe5f731.tar.bz2
anarchy-4bc8f6a84948133bff4855b8612f136ffbe5f731.zip
sys-kernel/hardened-sources - 4.9.58 version bump
Diffstat (limited to 'dev-util/cargo/cargo-0.22.0.ebuild')
-rw-r--r--dev-util/cargo/cargo-0.22.0.ebuild51
1 files changed, 33 insertions, 18 deletions
diff --git a/dev-util/cargo/cargo-0.22.0.ebuild b/dev-util/cargo/cargo-0.22.0.ebuild
index 8925e3e..d7ac6cc 100644
--- a/dev-util/cargo/cargo-0.22.0.ebuild
+++ b/dev-util/cargo/cargo-0.22.0.ebuild
@@ -11,53 +11,64 @@ aho-corasick-0.5.3
aho-corasick-0.6.3
atty-0.2.2
backtrace-0.3.2
-backtrace-sys-0.1.11
+backtrace-sys-0.1.12
+bitflags-0.7.0
bitflags-0.9.1
bufstream-0.1.3
cc-1.0.0
cfg-if-0.1.2
cmake-0.1.24
+conv-0.3.3
+core-foundation-0.4.4
+core-foundation-sys-0.4.4
crossbeam-0.2.10
-curl-0.4.7
+curl-0.4.8
curl-sys-0.3.14
+custom_derive-0.1.7
dbghelp-sys-0.2.0
docopt-0.8.1
dtoa-0.4.1
env_logger-0.4.3
-error-chain-0.11.0
+error-chain-0.11.0-rc.2
filetime-0.1.10
flate2-0.2.19
+fnv-1.0.5
foreign-types-0.2.0
fs2-0.4.2
gcc-0.3.51
git2-0.6.6
git2-curl-0.7.0
glob-0.2.11
+globset-0.2.0
hamcrest-0.1.1
hex-0.2.0
-idna-0.1.2
+home-0.3.0
+idna-0.1.4
+ignore-0.2.2
itoa-0.3.1
jobserver-0.1.6
kernel32-sys-0.2.2
lazy_static-0.2.8
-libc-0.2.25
+libc-0.2.28
libgit2-sys-0.6.12
libssh2-sys-0.2.6
libz-sys-1.0.16
log-0.3.8
+magenta-0.1.1
+magenta-sys-0.1.1
matches-0.1.6
memchr-0.1.11
memchr-1.0.1
miniz-sys-0.1.9
miow-0.2.1
-net2-0.2.29
-num-0.1.39
-num-bigint-0.1.39
-num-complex-0.1.38
-num-integer-0.1.34
-num-iter-0.1.33
-num-rational-0.1.38
-num-traits-0.1.39
+net2-0.2.30
+num-0.1.40
+num-bigint-0.1.40
+num-complex-0.1.40
+num-integer-0.1.35
+num-iter-0.1.34
+num-rational-0.1.39
+num-traits-0.1.40
num_cpus-1.6.2
openssl-0.9.20
openssl-probe-0.1.1
@@ -66,18 +77,20 @@ percent-encoding-1.0.0
pkg-config-0.3.9
psapi-sys-0.1.0
quote-0.3.15
-rand-0.3.15
+rand-0.3.16
regex-0.1.80
regex-0.2.2
regex-syntax-0.3.9
regex-syntax-0.4.1
rustc-demangle-0.1.4
rustc-serialize-0.3.24
+same-file-0.1.3
scoped-tls-0.1.0
+scopeguard-0.1.2
semver-0.7.0
semver-parser-0.7.0
-serde-1.0.9
-serde_derive-1.0.9
+serde-1.0.11
+serde_derive-1.0.11
serde_derive_internals-0.15.1
serde_ignored-0.0.3
serde_json-1.0.2
@@ -92,16 +105,18 @@ termcolor-0.3.2
thread-id-2.0.0
thread_local-0.2.7
thread_local-0.3.4
-toml-0.4.2
+toml-0.4.3
unicode-bidi-0.3.4
unicode-normalization-0.1.5
unicode-xid-0.0.4
unreachable-1.0.0
url-1.5.1
+userenv-sys-0.2.0
utf8-ranges-0.1.3
utf8-ranges-1.0.0
vcpkg-0.2.2
void-1.0.2
+walkdir-1.0.7
winapi-0.2.8
winapi-build-0.1.1
wincolor-0.1.4
@@ -151,7 +166,7 @@ src_configure() {
src_compile() {
export CARGO_HOME="${ECARGO_HOME}"
- local cargo="${WORKDIR}/cargo-${BOOTSTRAP_VERSION}-${TRIPLE}/cargo/bin/cargo"
+ local cargo="/usr/bin/cargo"
RUSTFLAGS='-C target-feature=-crt-static' ${cargo} build --release || die "Failed to build cargo"
# Building HTML documentation