summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/files')
-rw-r--r--app-office/libreoffice/files/fix-execinfo.patch54
-rw-r--r--app-office/libreoffice/files/fix-includes.patch40
-rw-r--r--app-office/libreoffice/files/libreoffice-5.2.5.1-glibc-2.24.patch10
-rw-r--r--app-office/libreoffice/files/libreoffice-5.3.4.2-kioclient5.patch11
-rw-r--r--app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch42
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch216
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.3.2-testTdf108947.patch13
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch34
-rw-r--r--app-office/libreoffice/files/linux-musl.patch75
9 files changed, 495 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/fix-execinfo.patch b/app-office/libreoffice/files/fix-execinfo.patch
new file mode 100644
index 0000000..577debb
--- /dev/null
+++ b/app-office/libreoffice/files/fix-execinfo.patch
@@ -0,0 +1,54 @@
+From 22e97095b30583eae81b55cd83e3ab8b944faaad Mon Sep 17 00:00:00 2001
+From: "Jory A. Pratt" <anarchy@gentoo.org>
+Date: Mon, 11 Jun 2018 04:10:23 -0500
+Subject: [PATCH 2/3] execinfo header not needed on musl setup
+
+Signed-off-by: Jory A. Pratt <anarchy@gentoo.org>
+---
+ sal/osl/unx/backtrace.c | 2 +-
+ sal/osl/unx/backtrace.h | 2 +-
+ sal/osl/unx/signal.cxx | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/sal/osl/unx/backtrace.c b/sal/osl/unx/backtrace.c
+index f70031d0b..141ea4e06 100644
+--- a/sal/osl/unx/backtrace.c
++++ b/sal/osl/unx/backtrace.c
+@@ -282,7 +282,7 @@ void backtrace_symbols_fd( void **buffer, int size, int fd )
+ }
+ }
+
+-#elif !defined LINUX
++#elif !defined(__GLIBC__)
+
+ int backtrace( void **buffer, int max_frames )
+ {
+diff --git a/sal/osl/unx/backtrace.h b/sal/osl/unx/backtrace.h
+index 5fafc1c90..408c12c69 100644
+--- a/sal/osl/unx/backtrace.h
++++ b/sal/osl/unx/backtrace.h
+@@ -20,7 +20,7 @@
+ #ifndef INCLUDED_SAL_OSL_UNX_BACKTRACE_H
+ #define INCLUDED_SAL_OSL_UNX_BACKTRACE_H
+
+-#if defined (LINUX)
++#if defined (LINUX) && defined (__GLIBC__)
+
+ #include <execinfo.h>
+
+diff --git a/sal/osl/unx/signal.cxx b/sal/osl/unx/signal.cxx
+index 9a528fec3..bf15f628f 100644
+--- a/sal/osl/unx/signal.cxx
++++ b/sal/osl/unx/signal.cxx
+@@ -35,7 +35,7 @@
+
+ #endif /* MACOSX */
+
+-#ifdef LINUX
++#if defined(LINUX) && defined(__GLIBC__)
+ #include <execinfo.h>
+ #include <link.h>
+ #define INCLUDE_BACKTRACE
+--
+2.17.1
+
diff --git a/app-office/libreoffice/files/fix-includes.patch b/app-office/libreoffice/files/fix-includes.patch
new file mode 100644
index 0000000..917eba3
--- /dev/null
+++ b/app-office/libreoffice/files/fix-includes.patch
@@ -0,0 +1,40 @@
+From af25d1cb9c009d66a536e6bbd5f997c71e6592a7 Mon Sep 17 00:00:00 2001
+From: "Jory A. Pratt" <anarchy@gentoo.org>
+Date: Mon, 11 Jun 2018 04:11:20 -0500
+Subject: [PATCH 3/3] fix includes for musl system
+
+Signed-off-by: Jory A. Pratt <anarchy@gentoo.org>
+---
+ sd/source/ui/remotecontrol/BluetoothServer.cxx | 2 +-
+ vcl/inc/headless/svpinst.hxx | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/sd/source/ui/remotecontrol/BluetoothServer.cxx b/sd/source/ui/remotecontrol/BluetoothServer.cxx
+index 780224719..c938afe48 100644
+--- a/sd/source/ui/remotecontrol/BluetoothServer.cxx
++++ b/sd/source/ui/remotecontrol/BluetoothServer.cxx
+@@ -21,7 +21,7 @@
+ #include <dbus/dbus.h>
+ #include <errno.h>
+ #include <fcntl.h>
+- #include <sys/unistd.h>
++ #include <unistd.h>
+ #include <sys/socket.h>
+ #include <bluetooth/bluetooth.h>
+ #include <bluetooth/rfcomm.h>
+diff --git a/vcl/inc/headless/svpinst.hxx b/vcl/inc/headless/svpinst.hxx
+index ba8096032..bcb644b84 100644
+--- a/vcl/inc/headless/svpinst.hxx
++++ b/vcl/inc/headless/svpinst.hxx
+@@ -31,7 +31,7 @@
+
+ #include <list>
+
+-#include <time.h>
++#include <sys/time.h>
+
+ #define VIRTUAL_DESKTOP_WIDTH 1024
+ #define VIRTUAL_DESKTOP_HEIGHT 768
+--
+2.17.1
+
diff --git a/app-office/libreoffice/files/libreoffice-5.2.5.1-glibc-2.24.patch b/app-office/libreoffice/files/libreoffice-5.2.5.1-glibc-2.24.patch
new file mode 100644
index 0000000..d714ff2
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.2.5.1-glibc-2.24.patch
@@ -0,0 +1,10 @@
+--- libreoffice-5.2.5.1.orig/desktop/unx/source/pagein.c 2017-01-11 16:54:33.000000000 -0800
++++ libreoffice-5.2.5.1/desktop/unx/source/pagein.c 2017-02-03 10:22:51.697673613 -0800
+@@ -26,6 +26,7 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+
+ /* do_pagein */
+ static void do_pagein (const char * filename)
diff --git a/app-office/libreoffice/files/libreoffice-5.3.4.2-kioclient5.patch b/app-office/libreoffice/files/libreoffice-5.3.4.2-kioclient5.patch
new file mode 100644
index 0000000..a6e732f
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.3.4.2-kioclient5.patch
@@ -0,0 +1,11 @@
+--- a/shell/source/unix/misc/senddoc.sh 2017-06-15 15:44:22.000000000 +0200
++++ b/shell/source/unix/misc/senddoc.sh 2017-06-25 01:00:08.525435930 +0200
+@@ -389,6 +389,8 @@
+ elif [ -n "$DESKTOP_LAUNCH" ]; then
+ # http://lists.freedesktop.org/pipermail/xdg/2004-August/002873.html
+ MAILER=${DESKTOP_LAUNCH}
++ elif [ -n "$KDE_FULL_SESSION" -a -x /usr/bin/kde-open5 ] ; then
++ MAILER=/usr/bin/kde-open5
+ elif [ -n "$KDE_FULL_SESSION" -a -x /usr/bin/kde-open ] ; then
+ MAILER=/usr/bin/kde-open
+ elif [ -x /usr/bin/xdg-open ] ; then
diff --git a/app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch b/app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch
new file mode 100644
index 0000000..83b56d1
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch
@@ -0,0 +1,42 @@
+--- a/desktop/scripts/soffice.sh
++++ a/desktop/scripts/soffice.sh
+@@ -147,6 +147,9 @@ if echo "$checks" | grep -q "cc" ; then
+ exit 1;
+ fi
+
++PYTHONPATH=$sd_prog${PYTHONPATH+:$PYTHONPATH}
++export PYTHONPATH
++
+ case "$(uname -s)" in
+ NetBSD|OpenBSD|DragonFly)
+ # this is a temporary hack until we can live with the default search paths
+--- a/pyuno/source/module/uno.py
++++ a/pyuno/source/module/uno.py
+@@ -16,11 +16,16 @@
+ # except in compliance with the License. You may obtain a copy of
+ # the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ #
++import os
+ import pyuno
+ import sys
+ import traceback
+ import warnings
+
++sys.path.append('%eprefix%/usr/%libdir%/libreoffice/program')
++if getattr(os.environ, 'URE_BOOTSTRAP', None) is None:
++ os.environ['URE_BOOTSTRAP'] = "vnd.sun.star.pathname:%eprefix%/usr/%libdir%/libreoffice/program/fundamentalrc"
++
+ # since on Windows sal3.dll no longer calls WSAStartup
+ import socket
+
+--- a/pyuno/source/officehelper.py
++++ a/pyuno/source/officehelper.py
+@@ -45,7 +45,7 @@ def bootstrap():
+ if "UNO_PATH" in os.environ:
+ sOffice = os.environ["UNO_PATH"]
+ else:
+- sOffice = "" # lets hope for the best
++ sOffice = "%eprefix%/usr/%libdir%/libreoffice/program"
+ sOffice = os.path.join(sOffice, "soffice")
+ if platform.startswith("win"):
+ sOffice += ".exe"
diff --git a/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch
new file mode 100644
index 0000000..03421c5
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch
@@ -0,0 +1,216 @@
+Kindly borrowed from Debian.
+
+14:13 < mst__> _rene_, the toolkit unoapi tests are known to be flaky (in some
+ system dependent way) e.g. on the Win@6 tinderbox it always
+ crashes
+14:14 < mst__> _rene_, sc.ScAccessible* tests also fail on some systems some of
+ the time
+
+diff --git a/toolkit/Module_toolkit.mk b/toolkit/Module_toolkit.mk
+index 25db0b6..14e507c 100644
+--- a/toolkit/Module_toolkit.mk
++++ b/toolkit/Module_toolkit.mk
+@@ -26,11 +26,11 @@ $(eval $(call gb_Module_add_targets,toolkit,\
+ ifneq ($(OOO_JUNIT_JAR),)
+ $(eval $(call gb_Module_add_subsequentcheck_targets,toolkit,\
+ JunitTest_toolkit_complex \
+- JunitTest_toolkit_unoapi_1 \
+- JunitTest_toolkit_unoapi_2 \
+- JunitTest_toolkit_unoapi_3 \
+- JunitTest_toolkit_unoapi_4 \
+ ))
+ endif
++# JunitTest_toolkit_unoapi_1 \
++# JunitTest_toolkit_unoapi_2 \
++# JunitTest_toolkit_unoapi_3 \
++# JunitTest_toolkit_unoapi_4 \
+
+ # vim: set noet sw=4 ts=4:
+diff --git a/sc/qa/unoapi/sc_1.sce b/sc/qa/unoapi/sc_1.sce
+index fa1684c..cc8e1a5 100644
+--- a/sc/qa/unoapi/sc_1.sce
++++ b/sc/qa/unoapi/sc_1.sce
+@@ -24,10 +24,3 @@
+ # i84554 -o sc.AccessibleEditableTextPara_PreviewNote
+ # i88241 -o sc.AccessibleEditableTextPara_HeaderFooter
+ -o sc.AccessibleEditableTextPara_PreviewCell
+--o sc.ScAccessibleCell
+-# i91044 -o sc.ScAccessibleCsvCell
+-# i91044 -o sc.ScAccessibleCsvGrid
+-# i84641 -o sc.ScAccessibleCsvRuler
+-# i88330 -o sc.ScAccessibleDocument
+-# i91045 -o sc.ScAccessibleDocumentPagePreview
+--o sc.ScAccessiblePageHeader
+diff --git a/sc/qa/unoapi/sc_2.sce b/sc/qa/unoapi/sc_2.sce
+index dbfc3e1..d235c5d 100644
+--- a/sc/qa/unoapi/sc_2.sce
++++ b/sc/qa/unoapi/sc_2.sce
+@@ -15,11 +15,6 @@
+ # except in compliance with the License. You may obtain a copy of
+ # the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ #
+-# fdo#FOO -o sc.ScAccessiblePageHeaderArea
+--o sc.ScAccessiblePreviewCell
+--o sc.ScAccessiblePreviewHeaderCell
+--o sc.ScAccessiblePreviewTable
+-# fdo#45337 -o sc.ScAccessibleSpreadsheet
+ # FIXME_REMOVE_WHEN_RE_BASE_COMPLETE
+ # -o sc.ScAnnotationObj
+ # -o sc.ScAnnotationShapeObj
+
+12:18 < _rene_> chris_wot: ping?
+12:18 < chris_wot> heya
+12:18 < chris_wot> you pinged?
+12:19 < _rene_> chris_wot: any news on
+ https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815292?
+12:20 < _rene_> (of course the this-night-uploaded rc3 also failed)
+12:21 < chris_wot> ah, sorry - I've looked at an EMF regression, but I've not
+ gotten any further on that one
+12:22 < chris_wot> I honestly think that for this one just disable the test for
+ now
+12:22 < chris_wot> I'll ping the ML
+
+This seems fixed when opening the original doc.
+
+diff --git a/sw/qa/extras/ooxmlexport/ooxmlexport7.cxx b/sw/qa/extras/ooxmlexport/ooxmlexport7.cxx
+index 54eed4d..78019bd 100644
+--- a/sw/qa/extras/ooxmlexport/ooxmlexport7.cxx
++++ b/sw/qa/extras/ooxmlexport/ooxmlexport7.cxx
+@@ -1128,30 +1128,30 @@ DECLARE_OOXMLEXPORT_TEST(testTDF93675, "no-numlevel-but-indented.odt")
+
+
+
+-DECLARE_OOXMLEXPORT_TEST(testFlipAndRotateCustomShape, "flip_and_rotate.odt")
+-{
+- xmlDocPtr pXmlDoc = parseExport("word/document.xml");
+- if (!pXmlDoc)
+- return;
+- // there should be no flipH and flipV attributes in this case
+- assertXPathNoAttribute(pXmlDoc, "//a:xfrm", "flipH");
+- assertXPathNoAttribute(pXmlDoc, "//a:xfrm", "flipV");
+- // check rotation angle
+- assertXPath(pXmlDoc, "//a:xfrm", "rot", "13500000");
+- // check the first few coordinates of the polygon
+-#ifndef MACOSX /* Retina-related rounding roundtrip error
+- * hard to smooth out due to the use of string compare
+- * instead of number */
+-#if !defined(_WIN32)
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[1]/a:pt", "x", "2351");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[1]/a:pt", "y", "3171");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[2]/a:pt", "x", "1695");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[2]/a:pt", "y", "3171");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[3]/a:pt", "x", "1695");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[3]/a:pt", "y", "1701");
+-#endif
+-#endif
+-}
++//DECLARE_OOXMLEXPORT_TEST(testFlipAndRotateCustomShape, "flip_and_rotate.odt")
++//{
++// xmlDocPtr pXmlDoc = parseExport("word/document.xml");
++// if (!pXmlDoc)
++// return;
++// // there should be no flipH and flipV attributes in this case
++// assertXPathNoAttribute(pXmlDoc, "//a:xfrm", "flipH");
++// assertXPathNoAttribute(pXmlDoc, "//a:xfrm", "flipV");
++// // check rotation angle
++// assertXPath(pXmlDoc, "//a:xfrm", "rot", "13500000");
++// // check the first few coordinates of the polygon
++//#ifndef MACOSX /* Retina-related rounding roundtrip error
++// * hard to smooth out due to the use of string compare
++// * instead of number */
++//#if !defined(_WIN32)
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[1]/a:pt", "x", "2351");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[1]/a:pt", "y", "3171");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[2]/a:pt", "x", "1695");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[2]/a:pt", "y", "3171");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[3]/a:pt", "x", "1695");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[3]/a:pt", "y", "1701");
++//#endif
++//#endif
++//}
+
+
+ CPPUNIT_PLUGIN_IMPLEMENT();
+diff --git a/svx/qa/unoapi/svx.sce b/svx/qa/unoapi/svx.sce
+index 1c3925f..a16f001 100644
+--- a/svx/qa/unoapi/svx.sce
++++ b/svx/qa/unoapi/svx.sce
+@@ -25,7 +25,7 @@
+ #i111216 -o svx.AccessiblePresentationGraphicShape
+ #i111216 -o svx.AccessiblePresentationOLEShape
+ #i85539 -o svx.AccessiblePresentationShape
+--o svx.AccessibleShape
++#-o svx.AccessibleShape
+ #i90294 -o svx.GraphicExporter
+ -o svx.SvxDrawPage
+ #i85501 -o svx.SvxGraphCtrlAccessibleContext
+
+19:26 <@x1sc0> _rene_, since that test is using exact dimensions, it seems it
+ fails on your side probably because the paragraph style is
+ different. 1. I will change the test to avoid the exact
+ dimensions. 2. meantime you can skip that test:
+https://cgit.freedesktop.org/libreoffice/core/commit/?id=e05f16e6bf36efbaab16dd2ed1427a750ce7cafd
+19:26 < IZBot> core - disable UI test that does exact comparison
+19:27 < _rene_> mmh, ok, saw that but that was for a different test, so.. :)
+19:27 -!- jacobo [~jaragunde@fanzine.igalia.com] has quit [Quit: Leaving.]
+19:27 < _rene_> thanks, will do
+
+diff --git a/uitest/writer_tests/tdf79236.py b/uitest/writer_tests/tdf79236.py
+index 8585e48d8c64..704f42c009a1 100644
+--- a/uitest/writer_tests/tdf79236.py
++++ b/uitest/writer_tests/tdf79236.py
+@@ -8,8 +8,11 @@ from uitest.framework import UITestCase
+ import time
+ from uitest.uihelper.common import get_state_as_dict, type_text
+
++import unittest
++
+ class tdf79236(UITestCase):
+
++ @unittest.skip("Currently broken")
+ def test_paragraph(self):
+
+ self.ui_test.create_doc_in_start_center("writer")
+
+14:39 < ztamas> _rene_: chart2dump is used to fail because of font size differences, just use a bigger delta or disable it if it
+ fails for you.
+14:40 <@sberg_> noelgrandin, no
+14:40 < noelgrandin> sberg_, sure seems that way both in the debugger and in the resulting SAL_WARN output
+14:42 < ztamas> _rene_: there were some work on making font rendering consistent on different platforms, but it's not finished
+ yet, I guess
+diff --git a/chart2/Module_chart2.mk b/chart2/Module_chart2.mk
+index 3273055d5373..cb452139170c 100644
+--- a/chart2/Module_chart2.mk
++++ b/chart2/Module_chart2.mk
+@@ -33,9 +33,9 @@ $(eval $(call gb_Module_add_slowcheck_targets,chart2,\
+ CppunitTest_chart2_export \
+ CppunitTest_chart2_import \
+ CppunitTest_chart2_trendcalculators \
+- CppunitTest_chart2_dump \
+ CppunitTest_chart2_pivot_chart_test \
+ ))
++# CppunitTest_chart2_dump \
+
+ ifeq ($(ENABLE_CHART_TESTS),TRUE)
+ ifeq ($(WITH_FONTS), TRUE)
+diff --git a/sw/qa/extras/ooxmlimport/ooxmlimport.cxx b/sw/qa/extras/ooxmlimport/ooxmlimport.cxx
+index 4d65beeb90c4..f3d71501c41a 100644
+--- a/sw/qa/extras/ooxmlimport/ooxmlimport.cxx
++++ b/sw/qa/extras/ooxmlimport/ooxmlimport.cxx
+@@ -1559,14 +1559,14 @@ DECLARE_OOXMLIMPORT_TEST(testTdf43017, "tdf43017.docx")
+ }
+
+
+-DECLARE_OOXMLIMPORT_TEST(testTdf112443, "tdf112443.docx")
++/*DECLARE_OOXMLIMPORT_TEST(testTdf112443, "tdf112443.docx")
+ {
+ // the position of the flying text frame should be off page
+ // 30624 below its anchor
+ OUString aTop = parseDump("//fly[1]/infos/bounds", "top");
+ CPPUNIT_ASSERT_EQUAL( OUString("30624"), aTop );
+
+-}
++}*/
+
+ DECLARE_OOXMLIMPORT_TEST(testTdf113946, "tdf113946.docx")
+ {
diff --git a/app-office/libreoffice/files/libreoffice-6.0.3.2-testTdf108947.patch b/app-office/libreoffice/files/libreoffice-6.0.3.2-testTdf108947.patch
new file mode 100644
index 0000000..bd84b31
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.3.2-testTdf108947.patch
@@ -0,0 +1,13 @@
+diff --git a/sw/qa/extras/rtfimport/rtfimport.cxx b/sw/qa/extras/rtfimport/rtfimport.cxx
+index 457aedce0acb..4f02cf2b4040 100644
+--- a/sw/qa/extras/rtfimport/rtfimport.cxx
++++ b/sw/qa/extras/rtfimport/rtfimport.cxx
+@@ -1352,7 +1352,7 @@ DECLARE_RTFIMPORT_TEST(testImportHeaderFooter, "tdf108055.rtf")
+ DECLARE_RTFIMPORT_TEST(testTdf108947, "tdf108947.rtf")
+ {
+ //Check page count
+- CPPUNIT_ASSERT_EQUAL(2, getPages());
++ CPPUNIT_ASSERT_EQUAL(1, getPages());
+
+ //Check if Headers/Footers contain what they should in this document
+ uno::Reference<text::XText> xHeaderTextRight = getProperty<uno::Reference<text::XText>>(
diff --git a/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch b/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch
new file mode 100644
index 0000000..1430fdf
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch
@@ -0,0 +1,34 @@
+From 5f1bf6598b5725ad1e50ae9f7ec7524cc8a834fa Mon Sep 17 00:00:00 2001
+From: Louis Sautier <sautier.louis@gmail.com>
+Date: Sun, 10 Jun 2018 12:25:18 +0200
+Subject: Fix build with GLM 0.9.9.0, tdf#118070
+
+One of the test files was forgotten in 953c4add8fd76d88f49a81ae4c21a1fdcc007e57
+
+Change-Id: I0315433c688ff7edb2ba599bbef203cac9de3022
+Reviewed-on: https://gerrit.libreoffice.org/55554
+Reviewed-by: Rene Engelhard <rene@debian.org>
+Tested-by: Rene Engelhard <rene@debian.org>
+---
+ vcl/Executable_icontest.mk | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/vcl/Executable_icontest.mk b/vcl/Executable_icontest.mk
+index ce16330..8c917b7 100644
+--- a/vcl/Executable_icontest.mk
++++ b/vcl/Executable_icontest.mk
+@@ -19,6 +19,12 @@ $(eval $(call gb_Executable_use_externals,icontest,\
+ ))
+ endif
+
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Executable_add_defs,icontest,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
++
+ $(eval $(call gb_Executable_use_api,icontest,\
+ offapi \
+ udkapi \
+--
+cgit v1.1
diff --git a/app-office/libreoffice/files/linux-musl.patch b/app-office/libreoffice/files/linux-musl.patch
new file mode 100644
index 0000000..baadb49
--- /dev/null
+++ b/app-office/libreoffice/files/linux-musl.patch
@@ -0,0 +1,75 @@
+From 6b74147fc8de0ada711175aa46876fc7d41b562f Mon Sep 17 00:00:00 2001
+From:
+Date: Mon, 11 Jun 2018 04:08:38 -0500
+Subject: [PATCH] add support for linux-musl to configure and remove glibc
+ check
+
+---
+ configure.ac | 23 ++++-------------------
+ 1 file changed, 4 insertions(+), 19 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 848dc4ff3..666a9ee04 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -573,7 +573,7 @@ solaris*)
+ fi
+ ;;
+
+-linux-gnu*|k*bsd*-gnu*)
++linux-gnu*|linux-musl*|k*bsd*-gnu*)
+ test_gtk=yes
+ build_gstreamer_1_0=yes
+ build_gstreamer_0_10=yes
+@@ -4012,7 +4012,7 @@ kfreebsd*)
+ esac
+ ;;
+
+-linux-gnu*)
++linux-gnu*|linux-musl*)
+ COM=GCC
+ USING_X11=TRUE
+ OS=LINUX
+@@ -6957,7 +6957,7 @@ if test -n "$ENABLE_JAVA" -a -z "$JAVAINC"; then
+ test -d "$JAVA_HOME/include/native_thread" && JAVAINC="$JAVAINC -I$JAVA_HOME/include/native_thread"
+ ;;
+
+- linux-gnu*)
++ linux-gnu*|linux-musl*)
+ JAVAINC="-I$JAVA_HOME/include"
+ JAVAINC="$JAVAINC -I$JAVA_HOME/include/linux"
+ test -d "$JAVA_HOME/include/native_thread" && JAVAINC="$JAVAINC -I$JAVA_HOME/include/native_thread"
+@@ -9460,21 +9460,6 @@ if test "$with_system_libexttextcat" = "yes"; then
+ fi
+ AC_SUBST(SYSTEM_LIBEXTTEXTCAT_DATA)
+
+-dnl ***************************************
+-dnl testing libc version for Linux...
+-dnl ***************************************
+-if test "$_os" = "Linux"; then
+- AC_MSG_CHECKING([whether libc is >= 2.1.1])
+- exec 6>/dev/null # no output
+- AC_CHECK_LIB(c, gnu_get_libc_version, HAVE_LIBC=yes; export HAVE_LIBC)
+- exec 6>&1 # output on again
+- if test "$HAVE_LIBC"; then
+- AC_MSG_RESULT([yes])
+- else
+- AC_MSG_ERROR([no, upgrade libc])
+- fi
+-fi
+-
+ dnl =========================================
+ dnl Check for uuidgen
+ dnl =========================================
+@@ -12470,7 +12455,7 @@ else
+
+ case "$host_os" in
+
+- aix*|dragonfly*|freebsd*|linux-gnu*|*netbsd*|openbsd*)
++ aix*|dragonfly*|freebsd*|linux-gnu*|linux-musl*|*netbsd*|openbsd*)
+ if test "$ENABLE_JAVA" != ""; then
+ pathmunge "$JAVA_HOME/bin" "after"
+ fi
+--
+2.17.1
+