summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/openlp/openlp-2.0.3.ebuild')
-rw-r--r--app-text/openlp/openlp-2.0.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/openlp/openlp-2.0.3.ebuild b/app-text/openlp/openlp-2.0.3.ebuild
new file mode 100644
index 0000000..7285862
--- /dev/null
+++ b/app-text/openlp/openlp-2.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Free church presentation software"
+HOMEPAGE="http://openlp.org/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/OpenLP-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pyodbc
+ dev-python/PyQt4[X,multimedia,phonon,webkit,${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy-migrate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/OpenLP-${PV}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu resources/openlp.desktop
+ dosym openlp.pyw /usr/bin/openlp
+ doicon resources/images/openlp.svg
+}
+