summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/u-boot-tools/Manifest1
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2016.01.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
new file mode 100644
index 0000000..faae49d
--- /dev/null
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -0,0 +1 @@
+DIST u-boot-2016.01.tar.bz2 10602974 SHA256 e5792fba9399d9804aa2ef667f14ff771e2cdece72367d340250265bf095a5d5 SHA512 4d0c78bcca8def32b991ca930e9145f2eac16036f006698577d71c68a7d199574c8c9dd4d95f081742972f49f5c1ee1724a0ab2ee472025511f9ea488c33c595 WHIRLPOOL 0211404b8c5280ccb2fb784fece7283293cd5f45aa968ad5bd6a9dff7fe10831a764dfffa9862e2e2bc5110e09029ab333af6f52c999342f20e5f413114f6448
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2016.01.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2016.01.ebuild
new file mode 100644
index 0000000..c9dfa6c
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2016.01.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # Unset a few KBUILD variables. Bug #540476
+ unset KBUILD_OUTPUT KBUILD_SRC
+ emake defconfig
+ emake \
+ HOSTSTRIP=: \
+ STRIP=: \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_install() {
+ cd tools
+ dobin bmp_logo gen_eth_addr img2srec mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+ doman "${S}/doc/mkimage.1"
+}