summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ross <aross@gentoo.org>2006-10-07 00:11:24 +0000
committerAndrew Ross <aross@gentoo.org>2006-10-07 00:11:24 +0000
commit30502b003da563413ef6fa753706a8fe9f06f608 (patch)
treee6f5aedb46903d767ff99aee7aa15fe99fc5d3f5
parentTrim leftover code from supporting unstable. Update HOMEPAGE. (diff)
downloadaross-30502b003da563413ef6fa753706a8fe9f06f608.tar.gz
aross-30502b003da563413ef6fa753706a8fe9f06f608.tar.bz2
aross-30502b003da563413ef6fa753706a8fe9f06f608.zip
Revert the fix for bug #147876 since it turned out to be INVALID.
svn path=/; revision=18
-rw-r--r--app-emulation/xen-tools/Manifest12
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild19
2 files changed, 19 insertions, 12 deletions
diff --git a/app-emulation/xen-tools/Manifest b/app-emulation/xen-tools/Manifest
index 305fc5c..feec04d 100644
--- a/app-emulation/xen-tools/Manifest
+++ b/app-emulation/xen-tools/Manifest
@@ -43,10 +43,14 @@ EBUILD xen-tools-3.0.2-r3.ebuild 5530 RMD160 fe932ebe8722970f5a433a0619552c6ec2f
MD5 11588a83ffd3177430efeca5cc668ba3 xen-tools-3.0.2-r3.ebuild 5530
RMD160 fe932ebe8722970f5a433a0619552c6ec2f93eaf xen-tools-3.0.2-r3.ebuild 5530
SHA256 cff3399ef7a791cafcf2053c00124ab56772b730ac8aa32a088ced857b011c1e xen-tools-3.0.2-r3.ebuild 5530
-EBUILD xen-tools-3.0.2-r4.ebuild 5201 RMD160 3849ba5b7e56333736aa905527accd3dd8f1f5e7 SHA1 d9c0190e1582ef1d95ef8cf42b0852ddc94ce0ee SHA256 31dc4e1697a75fbe5dd68b9f6ad951add22b2f5c3f7c3abf23d573c73a18274f
-MD5 21ef10386c8ddc2170b4cd067805aaa3 xen-tools-3.0.2-r4.ebuild 5201
-RMD160 3849ba5b7e56333736aa905527accd3dd8f1f5e7 xen-tools-3.0.2-r4.ebuild 5201
-SHA256 31dc4e1697a75fbe5dd68b9f6ad951add22b2f5c3f7c3abf23d573c73a18274f xen-tools-3.0.2-r4.ebuild 5201
+EBUILD xen-tools-3.0.2-r4.ebuild 5292 RMD160 e9336962c7ac321da04412f624072b2506a3a74f SHA1 78de6eea547944b7c470fb2375b8df2f8db09e3b SHA256 c4d204b8a667107d880c4cac2eb1e72da1d20cb3e11df7f51bc79e03d8a77aa4
+MD5 69f78dd22a8fdf2c65827f260ef99272 xen-tools-3.0.2-r4.ebuild 5292
+RMD160 e9336962c7ac321da04412f624072b2506a3a74f xen-tools-3.0.2-r4.ebuild 5292
+SHA256 c4d204b8a667107d880c4cac2eb1e72da1d20cb3e11df7f51bc79e03d8a77aa4 xen-tools-3.0.2-r4.ebuild 5292
+MISC xen-tools-3.0.2-r4.ebuild.orig 4917 RMD160 8cb659aa71e621eae6a301b8af7c9be9ab5c0546 SHA1 707c128f5352162d8a47a8ce7276e54226e59389 SHA256 2eac0376528c9bb83839c76d7bdade41780201e1c7b6114e4d3598edf49edd86
+MD5 7688d84246e23bb5111806fea413e405 xen-tools-3.0.2-r4.ebuild.orig 4917
+RMD160 8cb659aa71e621eae6a301b8af7c9be9ab5c0546 xen-tools-3.0.2-r4.ebuild.orig 4917
+SHA256 2eac0376528c9bb83839c76d7bdade41780201e1c7b6114e4d3598edf49edd86 xen-tools-3.0.2-r4.ebuild.orig 4917
MD5 6618adc624bc8ab64af0f4555c33529a files/digest-xen-tools-3.0.2-r3 235
RMD160 ad3a1d2a82c40b0bca653431c2d7964809580e5e files/digest-xen-tools-3.0.2-r3 235
SHA256 274536fc8a3cb10fda114e533062b0dbddcda4ae15f52033a39b85785b221794 files/digest-xen-tools-3.0.2-r3 235
diff --git a/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
index 66180e9..349e066 100644
--- a/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
@@ -81,7 +81,17 @@ src_unpack() {
-i {} \;
fi
- # Disable the 32bit-only vmxassist, if we are not on x86 and we don't support the x86 ABI
+ # xen tries to be smart and filter out CFLAGs not supported by gcc.
+ # It's not smart enough to catch no* flags, though, so we force them.
+ if use hardened; then
+ HARDFLAGS="-nopie -fno-stack-protector -fno-stack-protector-all"
+ sed -e "s/CFLAGS :=/CFLAGS := ${HARDFLAGS}/" \
+ -i "${S}"/tools/firmware/hvmloader/Makefile \
+ "${S}"/tools/firmware/vmxassist/Makefile
+ fi
+
+ # Disable the 32bit-only vmxassist if we are not on x86
+ # and we don't support the x86 ABI
if ! use x86 && ! has x86 $(get_all_abis); then
sed -i -e "/SUBDIRS += vmxassist/d" "${S}"tools/firmware/Makefile
fi
@@ -93,13 +103,6 @@ src_unpack() {
# Allow --as-needed LDFLAGS
epatch "${FILESDIR}/${P}"--as-needed.patch
- # Allow building with gcc-4.1 (bug #147876)
- for FLAG in -fnopie -nopie -fno-stack-protector -fno-stack-protector-all ;
- do
- test-flag-CC ${FLAG} && HARDFLAGS="${HARDFLAGS} ${FLAG}"
- done
- sed -i "s/^CFLAGS :=$/& ${HARDFLAGS}/" "${S}"/tools/firmware/{hvmloader,vmxassist}/Makefile
-
# Allow building with python-2.5 (bug #149138)
# Backported from upstream - should be in 3.0.3
sed -i 's/\.2|^2\.3|^2\.4/.[2345]/' "${S}"/tools/check/check_python