summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-07-21 12:02:06 +0000
committerThilo Bangert <bangert@gentoo.org>2009-07-21 12:02:06 +0000
commite8cbd391c186ca0d892f21b7785ab345c7471707 (patch)
tree81ecca575aa794967d29d6ef11c7eda9f3ae9947
parentregenerate manifest (diff)
downloadbangert-e8cbd391c186ca0d892f21b7785ab345c7471707.tar.gz
bangert-e8cbd391c186ca0d892f21b7785ab345c7471707.tar.bz2
bangert-e8cbd391c186ca0d892f21b7785ab345c7471707.zip
dracut ebuild
svn path=/ebuilds/; revision=88
-rw-r--r--sys-boot/dracut/ChangeLog10
-rw-r--r--sys-boot/dracut/Manifest4
-rw-r--r--sys-boot/dracut/dracut-0.4.ebuild36
-rw-r--r--sys-boot/dracut/metadata.xml24
4 files changed, 74 insertions, 0 deletions
diff --git a/sys-boot/dracut/ChangeLog b/sys-boot/dracut/ChangeLog
new file mode 100644
index 0000000..afc1774
--- /dev/null
+++ b/sys-boot/dracut/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-boot/dracut
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*dracut-0.4 (21 Jul 2009)
+
+ 21 Jul 2009; Thilo Bangert <bangert@gentoo.org> +dracut-0.4.ebuild,
+ +metadata.xml:
+ initial import - dracut, a initramfs builder
+
diff --git a/sys-boot/dracut/Manifest b/sys-boot/dracut/Manifest
new file mode 100644
index 0000000..ec4552a
--- /dev/null
+++ b/sys-boot/dracut/Manifest
@@ -0,0 +1,4 @@
+DIST dracut-0.4.tar.bz2 45458 RMD160 2e1cf2dd0b10e6bc2eb8893710792e5ba6032188 SHA1 f8d1c287fc3fdbb7b6e4e657696268f05d400791 SHA256 b1e67ad3d781d68fc7ef84f6c20c298cc69cb6de14041ad640e2867dd8e7d1ce
+EBUILD dracut-0.4.ebuild 742 RMD160 cec0ac0d8f90ed8e08e184c98581394443b5dad2 SHA1 41f490fe522bcfcbb39f25b3bcbab9e894c25b57 SHA256 15f037734a47036082c9cd7eceddc520878b7dd551078ab740d941a6cb508b8c
+MISC ChangeLog 278 RMD160 c38752320bc1f86330185c32a345c46079a0014e SHA1 f22fd0000105de5407d7bbe3353af47aead91264 SHA256 eb05fd64961c047551d2051ab33ad75bf3330c4c6b5e6280dc68da5671b3f7f6
+MISC metadata.xml 1147 RMD160 2668e7280becbff38059fbda6d54ef6d2c404f3b SHA1 9c3ee210408995a4f47fcbe034ffb46c9175863d SHA256 9fe5341adb781f21d20a23018651cd5d099c017ec233859eab393cb199ec0e80
diff --git a/sys-boot/dracut/dracut-0.4.ebuild b/sys-boot/dracut/dracut-0.4.ebuild
new file mode 100644
index 0000000..55c3d9e
--- /dev/null
+++ b/sys-boot/dracut/dracut-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+DESCRIPTION="Dracut is a new initramfs infrastructure."
+HOMEPAGE="http://apps.sourceforge.net/trac/dracut/wiki"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/cpio
+ sys-fs/udev
+ sys-apps/util-linux
+ sys-devel/binutils
+ sys-apps/coreutils
+ sys-apps/module-init-tools
+ sys-apps/findutils
+ sys-apps/grep
+ sys-apps/openrc
+ "
+
+#src_prepare() {
+ #run sed which adds CFLAGS to make file
+#}
+
+src_install() {
+ #pkglibdir=/usr/libexec/dracut
+ emake install DESTDIR="${D}" sbindir=/sbin sysconfdir=/etc \
+ || die "emake install failed"
+}
diff --git a/sys-boot/dracut/metadata.xml b/sys-boot/dracut/metadata.xml
new file mode 100644
index 0000000..5e2a64e
--- /dev/null
+++ b/sys-boot/dracut/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bangert@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+Unlike existing initramfs's, this is an attempt at having as little as
+possible hard-coded into the initramfs as possible. The initramfs has
+(basically) one purpose in life -- getting the rootfs mounted so that
+we can transition to the real rootfs. This is all driven off of
+device availability. Therefore, instead of scripts hard-coded to do
+various things, we depend on udev to create device nodes for us and
+then when we have the rootfs's device node, we mount and carry on.
+This helps to keep the time required in the initramfs as little as
+possible so that things like a 5 second boot aren't made impossible as
+a result of the very existence of an initramfs. It's likely that
+we'll grow some hooks for running arbitrary commands in the flow of
+the script, but it's worth trying to resist the urge as much as we can
+as hooks are guaranteed to be the path to slow-down.
+</longdescription>
+</pkgmetadata>
+