summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/pjsua/ChangeLog10
-rw-r--r--net-voip/pjsua/Manifest2
-rw-r--r--net-voip/pjsua/metadata.xml61
-rw-r--r--net-voip/pjsua/pjsua-1.6.ebuild52
-rw-r--r--net-voip/sofsip-cli/ChangeLog10
-rw-r--r--net-voip/sofsip-cli/Manifest4
-rw-r--r--net-voip/sofsip-cli/metadata.xml13
-rw-r--r--net-voip/sofsip-cli/sofsip-cli-0.16.ebuild25
8 files changed, 177 insertions, 0 deletions
diff --git a/net-voip/pjsua/ChangeLog b/net-voip/pjsua/ChangeLog
new file mode 100644
index 0000000..fc21883
--- /dev/null
+++ b/net-voip/pjsua/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-voip/pjsua
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pjsua-1.6 (06 May 2010)
+
+ 06 May 2010; Thilo Bangert <bangert@gentoo.org> +pjsua-1.6.ebuild,
+ +metadata.xml:
+ initial import - very crud ebuild
+
diff --git a/net-voip/pjsua/Manifest b/net-voip/pjsua/Manifest
new file mode 100644
index 0000000..5b0e97b
--- /dev/null
+++ b/net-voip/pjsua/Manifest
@@ -0,0 +1,2 @@
+DIST pjproject-1.6.tar.bz2 3716047 RMD160 4a8c1342ad2860983e785bbfbd170410edc2b7d7 SHA1 63e7cd6963290cf396024a837d1fb5194107db57 SHA256 8f13d7197eddd1442d24cf164b395582c00e7f19283f3c0e9d1315d85551ec7b
+EBUILD pjsua-1.6.ebuild 1083 RMD160 3b51f765fc3d13e0b6c0d4d55ba7b35544044985 SHA1 9cbdd9438204c1330bd54b61d8547bef270210e8 SHA256 89fd76da1c49b7cceb7214784101b549faf833258ef08450ee5486376662250f
diff --git a/net-voip/pjsua/metadata.xml b/net-voip/pjsua/metadata.xml
new file mode 100644
index 0000000..fde6e9f
--- /dev/null
+++ b/net-voip/pjsua/metadata.xml
@@ -0,0 +1,61 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bangert@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+pjsua is an open source command line SIP user agent (softphone) that is used as the reference implementation for PJSIP, PJNATH, and PJMEDIA. Despite its simple command line appearance, it does pack many features!
+
+SIP features:
+Mutiple lines/identities (account registrations).
+Multiple calls.
+IPv6 (added in version 1.2)
+PRACK (100rel, RFC 3262).
+UPDATE (RFC 3311).
+OPTIONS.
+Call hold.
+Call transfer (attended or unattended, with or without refersub, RFC 3515, 3891, 3892, 4488).
+SIMPLE with PIDF and XPIDF support (SUBSCRIBE/NOTIFY, RFC 3265, 3856, 3863).
+Custom presence status text (RPID, RFC 4480).
+PUBLISH support (RFC 3903).
+Instant messaging (MESSAGE) and message composing indication (RFC 3428, 3994)
+UDP, TCP, and TLS transports.
+DNS SRV resolution for SIP servers (RFC 3263).
+DTMF with INFO (RFC 2976).
+STUN (RFC 3489bis).
+Digest AKA authentication (in development, RFC 3310, 4169).
+Media features:
+Multiple Concurrent calls
+Conferencing
+Speex, iLBC, GSM, G711, G722, and L16 codecs.
+Wideband and ultra-wideband codec (Speex)
+More codecs via Intel IPP library: AMR-NB, AMR-WB, G.722.1 (Siren7), G.723.1, G.726, G.728, G.729A
+Stereo codecs (L16)
+WAV file playing, streaming, and recording.
+RTCP
+Call quality monitoring.
+RFC 2833
+Auto-answer, auto-play file, auto-loop RTP
+Tone generation.
+AEC (Accoustic echo cancellation).
+Adaptive jitter buffer.
+Adaptive silence detection.
+PLC (Packet Lost Concealment).
+Packet loss simulation.
+Multiple frames per RTP packet.
+SRTP (Secure RTP)
+NAT traversal features:
+ICE (Interactive Connectivity Establishment, latest ICE draft).
+STUN (latest rfc3489-bis).
+TURN (latest draft-ietf-behave-turn)
+rport.
+SIP TCP and TLS keep-alive.
+Auto-detect and recover SIP UDP address change.
+Auto-detect ICE media transport change.
+pjsua can be downloaded from http://www.pjsip.org/download.htm.
+
+</longdescription>
+</pkgmetadata>
+
diff --git a/net-voip/pjsua/pjsua-1.6.ebuild b/net-voip/pjsua/pjsua-1.6.ebuild
new file mode 100644
index 0000000..c105b8c
--- /dev/null
+++ b/net-voip/pjsua/pjsua-1.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+DESCRIPTION="pjsua is an open source command line SIP user agent"
+HOMEPAGE="http://www.pjsip.org/pjsua.htm"
+SRC_URI="http://www.pjsip.org/release/${PV}/pjproject-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ipv6 portaudio ssl"
+
+DEPEND="media-libs/speex
+ portaudio? ( media-libs/portaudio )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/pjproject-${PV}"
+
+src_configure() {
+ local localconf
+
+ localconf='--with-external-speex '
+ use portaudio && \
+ localconf="${localconf} --with-external-pa"
+ use portaudio || \
+ localconf="${localconf} --without-pa"
+
+ econf ${localconf} || die
+
+ use ssl && \
+ echo '#define PJSIP_HAS_TLS_TRANSPORT 1' >> \
+ pjlib/include/pj/config_site.h
+
+ use ipv6 && \
+ echo '#define PJ_HAS_IPV6 1' >> \
+ pjlib/include/pj/config_site.h
+
+}
+
+src_compile() {
+ #fails on parallel build
+ emake -j1 || die "Make failed!"
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe pjsip-apps/bin/pjsua* pjsua
+}
diff --git a/net-voip/sofsip-cli/ChangeLog b/net-voip/sofsip-cli/ChangeLog
new file mode 100644
index 0000000..4b0d108
--- /dev/null
+++ b/net-voip/sofsip-cli/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-voip/sofsip-cli
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*sofsip-cli-0.16 (06 May 2010)
+
+ 06 May 2010; Thilo Bangert <bangert@gentoo.org> +sofsip-cli-0.16.ebuild,
+ +metadata.xml:
+ initial import
+
diff --git a/net-voip/sofsip-cli/Manifest b/net-voip/sofsip-cli/Manifest
new file mode 100644
index 0000000..7833931
--- /dev/null
+++ b/net-voip/sofsip-cli/Manifest
@@ -0,0 +1,4 @@
+DIST sofsip-cli-0.16.tar.gz 391817 RMD160 659e653b55e148ad9345ca5de462b3372ecf04b3 SHA1 d5afeb2b808c1cab3de06e6d9e4ff7e730aa5f79 SHA256 9a8c86697b28b8d5ec3a8af24b50cc2f8ea5e7e2dbbcae9d9a4313fe05a8d32c
+EBUILD sofsip-cli-0.16.ebuild 634 RMD160 66ec0e0cf6a13171ac327da8d6ebf98b0e3cc067 SHA1 5f2af739070f77fe5dd7b45428c68d4912c7d870 SHA256 83fb33555786d52e39a0964430932075734c6b419f298c149b5236199fef3989
+MISC ChangeLog 262 RMD160 42e205f8f0daf7d8a1159f7ca721e3dffcf110b2 SHA1 b6a209a9c3672a91ec54f2693750bfd6226d52db SHA256 d6f50793bd5ece7f5d551729d8f193200733c30fdeaca74c226cf247e78fbe2a
+MISC metadata.xml 420 RMD160 e319b065e47b12a7e7fe45cde60f2202d43a1aef SHA1 78d84f49afc8d8e733f7d1fed9eaea1e0c64d3e5 SHA256 5734c1398904c1343459bf4d5cdec4f00e4a2f3e57241e492b1e3c6dd1134aa6
diff --git a/net-voip/sofsip-cli/metadata.xml b/net-voip/sofsip-cli/metadata.xml
new file mode 100644
index 0000000..35a0eec
--- /dev/null
+++ b/net-voip/sofsip-cli/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bangert@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+Sofsip-cli is a simple example client (sofsip_cli) demonstrating how to use
+the Sofia-SIP libsofia-sip-ua library to implement a SIP VoIP/IM client.
+</longdescription>
+</pkgmetadata>
+
diff --git a/net-voip/sofsip-cli/sofsip-cli-0.16.ebuild b/net-voip/sofsip-cli/sofsip-cli-0.16.ebuild
new file mode 100644
index 0000000..01a3a29
--- /dev/null
+++ b/net-voip/sofsip-cli/sofsip-cli-0.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+DESCRIPTION="A console VoIP/IM SIP client based on sofia-sip"
+HOMEPAGE="http://wiki.opensource.nokia.com/projects/SofSipCli
+http://sofia-sip.sourceforge.net/development.html"
+SRC_URI="mirror://sourceforge/sofia-sip/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=net-libs/sofia-sip-1.12.3
+ >=media-libs/gstreamer-0.10.2
+ sys-libs/readline"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README NEWS TODO AUTHORS || die
+}