summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/openvz-sources/openvz-sources-2.6.26.2.1.ebuild')
-rw-r--r--sys-kernel/openvz-sources/openvz-sources-2.6.26.2.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-kernel/openvz-sources/openvz-sources-2.6.26.2.1.ebuild b/sys-kernel/openvz-sources/openvz-sources-2.6.26.2.1.ebuild
new file mode 100644
index 0000000..e816cd2
--- /dev/null
+++ b/sys-kernel/openvz-sources/openvz-sources-2.6.26.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openvz-sources/openvz-sources-2.6.24.008.1.ebuild,v 1.1 2009/03/17 07:49:00 bangert Exp $
+
+inherit versionator
+
+ETYPE="sources"
+
+CKV=$(get_version_component_range 1-3)
+OKV=${OKV:-${CKV}}
+OVZ_REV="$(get_version_component_range 5)"
+OVZ_KERNEL="chekhov"
+if [[ ${PR} == "r0" ]]; then
+ KV_FULL=${CKV}-${PN/-*}-${OVZ_KERNEL}.${OVZ_REV}
+ EXTRAVERSION=-${OVZ_KERNEL}.${OVZ_REV}
+else
+ KV_FULL=${CKV}-${PN/-*}-${OVZ_KERNEL}.${OVZ_REV}-${PR}
+ EXTRAVERSION=-${OVZ_KERNEL}.${OVZ_REV}-${PR}
+fi
+KERNEL_URI="mirror://kernel/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/linux-${OKV}.tar.bz2"
+
+inherit kernel-2
+detect_version
+
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DESCRIPTION="Full sources including OpenVZ patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+HOMEPAGE="http://www.openvz.org"
+SRC_URI="${KERNEL_URI} ${ARCH_URI}
+ http://download.openvz.org/kernel/branches/${CKV}/${CKV}-${OVZ_KERNEL}.${OVZ_REV}/patches/patch-${OVZ_KERNEL}.${OVZ_REV}-combined.gz"
+
+UNIPATCH_STRICTORDER=1
+UNIPATCH_LIST="${DISTDIR}/patch-${OVZ_KERNEL}.${OVZ_REV}-combined.gz"
+
+K_EXTRAEINFO="This is development branch of openvz-sources. For more information
+about this kernel tak a look at:
+http://wiki.openvz.org/Download/kernel/${CKV}/${CKV}-${OVZ_KERNEL}.${OVZ_REV}"