summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-02-09 17:46:23 -0500
committerAnthony G. Basile <blueness@gentoo.org>2013-02-09 17:46:23 -0500
commit89d8f67b32c0e6e2ee354f9386faadd026a3f0e8 (patch)
tree8c0357db895d0207573faba88a55b2b016d9a679 /sys-fs
parentsys-kernel/hardened-sources: testing patchset 20130207 (diff)
downloadblueness-89d8f67b32c0e6e2ee354f9386faadd026a3f0e8.tar.gz
blueness-89d8f67b32c0e6e2ee354f9386faadd026a3f0e8.tar.bz2
blueness-89d8f67b32c0e6e2ee354f9386faadd026a3f0e8.zip
sys-fs/helloworld: test of pax-utils.eclass
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/helloworld/Manifest3
-rw-r--r--sys-fs/helloworld/helloworld-0.1.ebuild24
-rw-r--r--sys-fs/helloworld/metadata.xml8
3 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/helloworld/Manifest b/sys-fs/helloworld/Manifest
new file mode 100644
index 0000000..28ea1ed
--- /dev/null
+++ b/sys-fs/helloworld/Manifest
@@ -0,0 +1,3 @@
+DIST helloworld-0.1.tgz 160666 SHA256 8bc4c1a57c46a5794baeac5b4b20fac6538e69ecac70a81a57c0313da7b85922 SHA512 e10d54c3056da5dca3a2cca1dea70f69828f6918ec06314aa5533b58d0529bb766a4a2728bc488089f4b7f72d1022b9c941926a12df4dfb598e05ad3789a01f2 WHIRLPOOL 11529191db4bcf690831e92e798fd40727ab03f46e01a300a652844b8d02aceff93ef391b5542d63c76640b1daf2546540e6ea5293b3b097c11df0e44f6aabb2
+EBUILD helloworld-0.1.ebuild 407 SHA256 47a27bf5f1035359ba3b84e11c41decaff9498eed6068bd628929eaf3fea02e7 SHA512 fe5f36117b72f0e317175d4213792474dea297707b6c8e3f3813c31fa2d88432b296d1c8e4d679b7cf7213cd39783fb1b2cb48b413720b0e43686708e20d28dd WHIRLPOOL 8cf615a7321b66e6beb83e144c7f9e67af3a0430bcc1fb2225866ddd09dc9539526aafc808670b9935bc8c23061418d6deaeeaf1f246c9c57e61e6789dcb2ec5
+MISC metadata.xml 238 SHA256 f13e6e7b65d20beb9ae945d520160ef0dba80c1965754958945904d7e3c0a75f SHA512 3c3d75f1cb90ffcfb98df47481fbde6d451254a29fa87577acd25bc27cbcc3e5dbc0c1efce5974be905428f0b7caf912c8b051417aff92763847fa377493a153 WHIRLPOOL 6ec3d597b87aff99014404b8b732e6f600aafc3c3eeebfab135c9c19cde2e43161cfa23f841bd72826cc3393b724e1dac115c15dcce2b74ace6f1d6ec209dbf3
diff --git a/sys-fs/helloworld/helloworld-0.1.ebuild b/sys-fs/helloworld/helloworld-0.1.ebuild
new file mode 100644
index 0000000..09a7c41
--- /dev/null
+++ b/sys-fs/helloworld/helloworld-0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit pax-utils
+
+DESCRIPTION="Hello world"
+HOMEPAGE="http://opensource.dyc.edu"
+SRC_URI="http://opensource.dyc.edu/pub/misc/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ pax-mark m "${ED}"/usr/bin/hw
+}
diff --git a/sys-fs/helloworld/metadata.xml b/sys-fs/helloworld/metadata.xml
new file mode 100644
index 0000000..1e75873
--- /dev/null
+++ b/sys-fs/helloworld/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>