summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/eresi/files')
-rw-r--r--dev-util/eresi/files/0.82_beta2-as-needed.patch28
-rw-r--r--dev-util/eresi/files/0.82_beta2-direct-ld.patch32
-rw-r--r--dev-util/eresi/files/0.82_beta2-drop-dprintf.patch25
-rw-r--r--dev-util/eresi/files/0.82_beta2-gentoo-autodetect.patch17
-rw-r--r--dev-util/eresi/files/0.82_beta2-parallel-make.patch66
-rw-r--r--dev-util/eresi/files/0.82_beta2-sed-in-Makefile.patch22
6 files changed, 190 insertions, 0 deletions
diff --git a/dev-util/eresi/files/0.82_beta2-as-needed.patch b/dev-util/eresi/files/0.82_beta2-as-needed.patch
new file mode 100644
index 0000000..978bf95
--- /dev/null
+++ b/dev-util/eresi/files/0.82_beta2-as-needed.patch
@@ -0,0 +1,28 @@
+Index: eresi-0.82_beta2/e2dbg/Makefile
+===================================================================
+--- eresi-0.82_beta2.orig/e2dbg/Makefile
++++ eresi-0.82_beta2/e2dbg/Makefile
+@@ -38,9 +38,10 @@ CFLAGS64 += -fPIC -g3 -Wall -Iinclude $
+ -DERESI64
+
+ LDFLAGS32 += -L../liballocproxy -lallocproxy -L../libelfsh/ -lelfsh32 \
+- -L../libetrace/ -letrace32 -L../libstderesi -lstderesi32 \
++ -L../libetrace/ -letrace32 \
+ -L../libdump/ -L/usr/pkg/lib/ -L../libasm/ -lasm32 \
+ -L../libaspect/ -laspect32 -L../librevm/ -lrevm32 \
++ -L../libstderesi -lstderesi32 \
+ -L../libmjollnir -lmjollnir32 -g3 \
+ -L../libui/ -lui32 -L../libedfmt -ledfmt32 \
+ $(LDREADLNOPT) $(DLOPT) -L/usr/freeware/lib32/ $(DYNOPT) \
+@@ -48,9 +49,10 @@ LDFLAGS32 += -L../liballocproxy -lalloc
+ $(LDMJOLLNIR) $(KERNSHLIB32) $(NCURSESLNOPT) $(READLNOPT)
+
+ LDFLAGS64 += -L../liballocproxy -lallocproxy -L../libelfsh/ -lelfsh64 \
+- -L../libetrace/ -letrace64 -L../libstderesi -lstderesi64 \
++ -L../libetrace/ -letrace64 \
+ -L../libdump/ -L/usr/pkg/lib/ -L../libasm/ -lasm64 \
+ -L../libaspect/ -laspect64 -L../librevm/ -lrevm64 \
++ -L../libstderesi -lstderesi64 \
+ -L../libmjollnir -lmjollnir64 -g3 \
+ -L../libui/ -lui64 -L../libedfmt -ledfmt64 \
+ $(LDREADLNOPT) $(DLOPT) -L/usr/freeware/lib32/ $(DYNOPT) \
diff --git a/dev-util/eresi/files/0.82_beta2-direct-ld.patch b/dev-util/eresi/files/0.82_beta2-direct-ld.patch
new file mode 100644
index 0000000..f3bb19c
--- /dev/null
+++ b/dev-util/eresi/files/0.82_beta2-direct-ld.patch
@@ -0,0 +1,32 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Don't call LD when linking, use CC instead.
+
+--- a/libdump/Makefile
++++ b/libdump/Makefile
+@@ -26,12 +26,12 @@
+ all32: $(OBJ32)
+ $(AR) $(NAME32).a $(OBJ32)
+ $(RANLIB) $(NAME32).a
+- $(LD) -r $(OBJ32) -o $(NAME32).o $(LDFLAGS32)
++ $(CC) -Wl,-r -nostdlib $(OBJ32) -o $(NAME32).o $(LDFLAGS32)
+
+ all64: $(OBJ64)
+ $(AR) $(NAME64).a $(OBJ64)
+ $(RANLIB) $(NAME64).a
+- $(LD) -r $(OBJ64) -o $(NAME64).o $(LDFLAGS64)
++ $(CC) -Wl,-r -nostdlib $(OBJ64) -o $(NAME64).o $(LDFLAGS64)
+
+ clean :
+ @rm -f $(OBJ32) $(OBJ64) *~ *\# \#* .\#* dump_main.o
+
+--- a/elfsh/Makefile
++++ b/elfsh/Makefile
+@@ -36,7 +36,7 @@
+ -I../libedfmt/include/ $(STATOPT2) \
+ $(ASMOPT) -DERESI64 $(NCURSESLNOPT) $(READLNOPT)
+
+-LDFLAGS32 += -L../libedfmt/ -ledfmt32 -L../libelfsh/ -lelfsh32 \
++LDFLAGS32 += -L../libedfmt/ -ledfmt32 -L../libdump/ -L../libelfsh/ -lelfsh32 \
+ -L../libetrace/ -letrace32 -L../libstderesi/ -lstderesi32 \
+ -L/usr/pkg/lib/ -L../libmjollnir/ -lmjollnir32 \
+ -L../libetrace -letrace32 $(LPTHREAD) -L../libasm/ -lasm32 \
diff --git a/dev-util/eresi/files/0.82_beta2-drop-dprintf.patch b/dev-util/eresi/files/0.82_beta2-drop-dprintf.patch
new file mode 100644
index 0000000..bde1a95
--- /dev/null
+++ b/dev-util/eresi/files/0.82_beta2-drop-dprintf.patch
@@ -0,0 +1,25 @@
+Drop conflicting dprintf declaration.
+
+ERESI does declare a prototype for dprintf, which conflicts with the
+declaration in stdio.h, leading to the following compiler error:
+
+../librevm/include/revm.h:604: error: conflicting types for ‘dprintf’
+/usr/include/stdio.h:397: note: previous declaration of ‘dprintf’ was here
+
+As the whole ERESI source code doesn't even mention dprintf in any
+other place, dropping the declaration shouldn't cause any harm at all.
+
+2010-04-07 Martin von Gagern
+
+Index: eresi-0.82_beta2/librevm/include/revm.h
+===================================================================
+--- eresi-0.82_beta2.orig/librevm/include/revm.h
++++ eresi-0.82_beta2/librevm/include/revm.h
+@@ -601,7 +601,6 @@ int revm_isnbr(char *string);
+ void revm_workfiles_load();
+ int revm_implicit(revmcmd_t *actual);
+ int revm_workfiles_unload();
+-int dprintf(int fd, char *format, ...);
+ void revm_pht_print(elfsh_Phdr *phdr, uint16_t num, eresi_Addr base);
+ char *revm_fetch_sht_typedesc(elfsh_Word typenum);
+ int revm_sht_print(elfsh_Shdr *shdr, u_int num, char rtflag);
diff --git a/dev-util/eresi/files/0.82_beta2-gentoo-autodetect.patch b/dev-util/eresi/files/0.82_beta2-gentoo-autodetect.patch
new file mode 100644
index 0000000..d90fccd
--- /dev/null
+++ b/dev-util/eresi/files/0.82_beta2-gentoo-autodetect.patch
@@ -0,0 +1,17 @@
+Avoid autodetecting Gentoo using any kind of black magic.
+
+2011-05-23 Martin von Gagern
+
+Index: eresi-0.82_beta2/configure
+===================================================================
+--- eresi-0.82_beta2.orig/configure
++++ eresi-0.82_beta2/configure
+@@ -20,7 +20,7 @@ VARSFILE="librevm/include/revm-vars.h"
+ LIBVARSFILE="libelfsh/include/libvars.h"
+ LPTHREAD="-lpthread"
+ SHELL=`which bash`
+-GENTOO=` uname -a | grep gentoo`
++GENTOO=yes
+
+ printHelp()
+ {
diff --git a/dev-util/eresi/files/0.82_beta2-parallel-make.patch b/dev-util/eresi/files/0.82_beta2-parallel-make.patch
new file mode 100644
index 0000000..c14d21a
--- /dev/null
+++ b/dev-util/eresi/files/0.82_beta2-parallel-make.patch
@@ -0,0 +1,66 @@
+Index: librevm/Makefile
+===================================================================
+--- librevm/Makefile (revision 1284)
++++ librevm/Makefile (working copy)
+@@ -42,7 +42,7 @@
+ $(MAKE) -C io all32
+ $(MAKE) -C api all32
+
+-$(NAME32).so :
++$(NAME32).so : mod32
+ $(CC) -shared $(OBJ32) -o $(NAME32).so $(LDFLAGS32) \
+ $(STATOPT) $(NCURSESLNOPT) $(READLNOPT)
+ ar rc ${NAME32}.a ${OBJ32}
+@@ -57,7 +57,7 @@
+ $(MAKE) -C io all64
+ $(MAKE) -C api all64
+
+-lib64 :
++lib64 : mod64
+ $(CC) -shared $(OBJ64) -o $(NAME64).so $(LDFLAGS64) \
+ $(STATOPT) $(NCURSESLNOPT) $(READLNOPT)
+ ar rc ${NAME64}.a ${OBJ64}
+Index: libstderesi/Makefile
+===================================================================
+--- libstderesi/Makefile (revision 1284)
++++ libstderesi/Makefile (working copy)
+@@ -47,7 +47,7 @@
+ $(MAKE) -C analysis all32
+ $(MAKE) -C files all32
+
+-$(NAME32).so :
++$(NAME32).so : mod32
+ $(CC) -shared $(OBJ32) -o $(NAME32).so $(LDFLAGS32) \
+ $(NCURSESLNOPT) $(READLNOPT)
+ ar rc ${NAME32}.a ${OBJ32}
+@@ -66,7 +66,7 @@
+ $(MAKE) -C analysis all64
+ $(MAKE) -C files all64
+
+-$(NAME64).so :
++$(NAME64).so : mod64
+ $(CC) -shared $(OBJ64) -o $(NAME64).so $(LDFLAGS64) \
+ $(STATOPT) $(NCURSESLNOPT) $(READLNOPT)
+ ar rc ${NAME64}.a ${OBJ64}
+Index: libe2dbg/Makefile
+===================================================================
+--- libe2dbg/Makefile (revision 1284)
++++ libe2dbg/Makefile (working copy)
+@@ -52,7 +52,7 @@
+ $(MAKE) -C kernel
+ endif
+
+-$(DBGNAME32O):
++$(DBGNAME32O): mod32
+ @$(CC) -shared $(COBJ32) $(EXTRAOBJ32) $(UOBJ32) $(LDFLAGS32) \
+ -o $(DBGNAME32).so
+ @$(AR) $(DBGNAME32).a $(COBJ32) $(UOBJ32) $(EXTRAOBJ32)
+@@ -70,7 +70,7 @@
+ $(MAKE) -C common all64
+ $(MAKE) -C user all64
+
+-$(DBGNAME64O) :
++$(DBGNAME64O) : mod64
+ @$(CC) -shared $(COBJ64) $(EXTRAOBJ64) $(UOBJ64) $(LDFLAGS64) \
+ -o $(DBGNAME64).so
+ @$(AR) $(DBGNAME64).a $(OBJ64)
diff --git a/dev-util/eresi/files/0.82_beta2-sed-in-Makefile.patch b/dev-util/eresi/files/0.82_beta2-sed-in-Makefile.patch
new file mode 100644
index 0000000..321e710
--- /dev/null
+++ b/dev-util/eresi/files/0.82_beta2-sed-in-Makefile.patch
@@ -0,0 +1,22 @@
+Having a sed command at the top of the Makefile will break with
+current (3.82) GNU make.
+
+2011-05-23 Martin von Gagern
+
+Index: eresi-0.82_beta2/configure
+===================================================================
+--- eresi-0.82_beta2.orig/configure
++++ eresi-0.82_beta2/configure
+@@ -618,10 +618,10 @@ echo "RM = rm -f "
+ echo "" >> Makefile
+ echo "all : world modules testsuite tags" >> Makefile
+
++sed -ie "s%TESTING_ROOT=.*%TESTING_ROOT=`pwd`/%" eresi-config
++
+ cat >> Makefile <<EOF
+
+-sed -ie "s%TESTING_ROOT=.*%TESTING_ROOT=`pwd`/%" eresi-config
+-
+ ifdef NAME
+ include build/defs/dep-rules.def
+ component: dep-\$(NAME)