summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'coda/net-fs/coda/coda-6.9.3.ebuild')
-rw-r--r--coda/net-fs/coda/coda-6.9.3.ebuild98
1 files changed, 0 insertions, 98 deletions
diff --git a/coda/net-fs/coda/coda-6.9.3.ebuild b/coda/net-fs/coda/coda-6.9.3.ebuild
deleted file mode 100644
index 7f5965d..0000000
--- a/coda/net-fs/coda/coda-6.9.3.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-inherit autotools eutils
-
-KEYWORDS="~amd64 ~ppc ~x86"
-
-DESCRIPTION="Coda is an advanced networked filesystem developed at Carnegie Mellon Uni."
-HOMEPAGE="http://www.coda.cs.cmu.edu/"
-SRC_URI="http://www.coda.cs.cmu.edu/pub/${PN}/src/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="kerberos server"
-
-RDEPEND=">=sys-libs/lwp-2.4
- >=net-libs/rpc2-2.7
- >=sys-libs/rvm-1.15
- >=sys-libs/db-4.2
- >=sys-libs/ncurses-5.4
- >=sys-libs/readline-5.0
- dev-lang/perl
- kerberos? ( virtual/krb5 )"
-
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${P}-gentoo-dirs.patch"
-}
-
-src_compile() {
- local myconf="--enable-client"
-
- use server && myconf="${myconf} --enable-server"
- use kerberos && myconf="${myconf} --with-crypto --with-krb5"
-
- econf ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc INSTALL* README*
-
- rm -Rf "${D}"/etc/init.d
- doinitd "${FILESDIR}"/venus
- if use server ; then
- doinitd "${FILESDIR}"/auth2
- doinitd "${FILESDIR}"/coda-update
- doinitd "${FILESDIR}"/codasrv
- fi
-
- # Fix conflict with backup.sh from tar.
- mv -f "${D}"/usr/sbin/backup{,-coda}.sh
-
- # Add Gentoo specific dirs.
- if use server ; then
- dodir /var/lib/vice
- dodir /mnt/vicepa
- fi
- dodir /var/lib/coda/spool
- dodir /mnt/coda
-
- diropts -m0700
- dodir /var/lib/coda/etc
- dodir /var/lib/coda/venus.cache
-
- # Symlink traditional Coda dirs to Gentoo dirs.
- if use server ; then
- dosym /var/lib/vice /vice
- dosym /mnt/vicepa /vicepa
- fi
- dosym /var/lib/coda /usr/coda
- dosym /mnt/coda /coda
-}
-
-pkg_postinst() {
- if use server ; then
- elog "To configure the coda server, run vice-setup."
- elog "To enable the coda server at boot up, please do:"
- elog " rc-update add auth2 default"
- elog " rc-update add coda-update default"
- elog " rc-update add codasrv default"
- elog
- fi
- elog "To configure the coda client, run venus-setup."
- elog "To enable the coda client at boot up, please do:"
- elog " rc-update add venus default"
-}