summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-08-29 22:53:30 -0700
committerPatrick McLean <chutzpah@gentoo.org>2013-08-29 22:54:13 -0700
commite3aca59141a09db2295864fc5ceeb712736aff65 (patch)
tree64bc10a5f4db6aaefde6ae4b10eb631e8267136d
parentapp-vim/hexman: new package, the hexman vim plugin (diff)
downloadchutzpah-e3aca59141a09db2295864fc5ceeb712736aff65.tar.gz
chutzpah-e3aca59141a09db2295864fc5ceeb712736aff65.tar.bz2
chutzpah-e3aca59141a09db2295864fc5ceeb712736aff65.zip
add jedi vim plugin
-rw-r--r--app-vim/jedi/Manifest1
-rw-r--r--app-vim/jedi/jedi-9999.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/jedi/Manifest b/app-vim/jedi/Manifest
new file mode 100644
index 0000000..446474b
--- /dev/null
+++ b/app-vim/jedi/Manifest
@@ -0,0 +1 @@
+EBUILD jedi-9999.ebuild 638 SHA256 5328b29bb016666e93e81821e47640a6ef5c0c2cf641bc1aa3d050f33f2fb3ed SHA512 0afcdabc73af86ec9ab4c757cbdde0131e138cd1eb185d162ce1d5759b1d941ac9abbf2c1ff8909040d5b3dabfe00c48b0939826bce37b009990bf3eeb768ff4 WHIRLPOOL 8c429e4765620bf3eda3cd3108af29a4e72286ddccee39110d5d1e94c28b5e0423df0cdecc235a36bd13f7e3b285232eab6d1d9542b2c3b8a3bbf493d2bc5ee4
diff --git a/app-vim/jedi/jedi-9999.ebuild b/app-vim/jedi/jedi-9999.ebuild
new file mode 100644
index 0000000..a4c1351
--- /dev/null
+++ b/app-vim/jedi/jedi-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3})
+inherit vim-plugin git-2 python-r1 python-utils-r1
+
+DESCRIPTION="Jedi Python autocompletion with VIM"
+HOMEPAGE="https://github.com/davidhalter/jedi-vim"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/davidhalter/${PN}-vim.git"
+
+LICENSE="LGPL-3+"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-python/jedi[${PYTHON_USEDEP}]"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ python_copy_sources
+}
+
+src_install() {
+ python_foreach_impl python_domodule jedi_vim.py
+ vim-plugin_src_install
+}