summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-04-19 15:20:20 -0500
committerJeremy Olexa <darkside@gentoo.org>2012-04-19 15:20:20 -0500
commit30ccdac03721f8a8b6398ba844a93282ce4c3919 (patch)
treeb5ba4a8d68d0bd00329dfdcb8caad0b4f21022c4 /net-analyzer/munin/munin-2.0_rc5.ebuild
parent[www-servers/nginx] in tree, rm (diff)
downloaddarkside-30ccdac03721f8a8b6398ba844a93282ce4c3919.tar.gz
darkside-30ccdac03721f8a8b6398ba844a93282ce4c3919.tar.bz2
darkside-30ccdac03721f8a8b6398ba844a93282ce4c3919.zip
[net-analyzer/munin] experimental version bump, YMMV
Diffstat (limited to 'net-analyzer/munin/munin-2.0_rc5.ebuild')
-rw-r--r--net-analyzer/munin/munin-2.0_rc5.ebuild147
1 files changed, 147 insertions, 0 deletions
diff --git a/net-analyzer/munin/munin-2.0_rc5.ebuild b/net-analyzer/munin/munin-2.0_rc5.ebuild
new file mode 100644
index 0000000..5efbe57
--- /dev/null
+++ b/net-analyzer/munin/munin-2.0_rc5.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-1.4.6-r5.ebuild,v 1.1 2012/04/09 23:15:27 flameeyes Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Munin Server Monitoring Tool"
+HOMEPAGE="http://munin-monitoring.org/"
+SRC_URI="mirror://sourceforge/munin/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="asterisk doc irc java memcached minimal mysql postgres ssl"
+
+# Upstream's listing of required modules is NOT correct!
+# Some of the postgres plugins use DBD::Pg, while others call psql directly.
+# Some of the mysql plugins use DBD::mysql, while others call mysqladmin directly.
+DEPEND_COM="dev-lang/perl
+ sys-process/procps
+ asterisk? ( dev-perl/Net-Telnet )
+ irc? ( dev-perl/Net-IRC )
+ java? ( >=virtual/jdk-1.5 )
+ mysql? ( virtual/mysql
+ dev-perl/Cache-Cache
+ dev-perl/DBD-mysql )
+ ssl? ( dev-perl/Net-SSLeay )
+ postgres? ( dev-perl/DBD-Pg dev-db/postgresql-base )
+ memcached? ( dev-perl/Cache-Memcached )
+ dev-perl/DateManip
+ dev-perl/File-Copy-Recursive
+ dev-perl/Net-CIDR
+ dev-perl/Net-Netmask
+ dev-perl/Net-SNMP
+ dev-perl/libwww-perl
+ dev-perl/net-server
+ dev-perl/DBI
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-MIME-Base64
+ virtual/perl-Storable
+ virtual/perl-Text-Balanced
+ virtual/perl-Time-HiRes
+ !minimal? ( dev-perl/HTML-Template
+ net-analyzer/rrdtool[perl]
+ dev-perl/Log-Log4perl )"
+
+# Keep this seperate, as previous versions have had other deps here
+DEPEND="${DEPEND_COM}
+ virtual/perl-Module-Build"
+RDEPEND="${DEPEND_COM}
+ !minimal? ( virtual/cron )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup munin
+ enewuser munin 177 -1 /var/lib/munin munin
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0_rc-Makefile.patch
+
+ epatch "${FILESDIR}"/${PN}-1.4.7-munin-version-identifier.patch
+
+ # Don't build java plugins if not requested via USE.
+ if ! use java; then
+ sed -i -e 's: build-plugins-java : :' \
+ -e 's: install-plugins-java : :' Makefile || die
+ fi
+
+ # Bug 304447, fix for gentoo PS location
+ sed -i -e 's,/usr/bin/ps,/bin/ps,g' \
+ "${S}"/plugins/node.d/ifx_concurrent_sessions_.in || die
+
+ # bug 367785, cleanup make output by disabling HP-UX cruft
+ sed -i "/plugins\/\*\.adv/d" Makefile || die
+}
+
+src_compile() {
+ emake -j1
+ if use doc; then
+ emake build-doc
+ fi
+
+}
+
+src_install() {
+ local dirs
+ dirs="/var/log/munin/ /var/lib/munin/"
+ dirs="${dirs} /var/lib/munin/plugin-state/"
+ dirs="${dirs} /var/run/munin/plugin-state/"
+ dirs="${dirs} /var/run/munin/spool/"
+ dirs="${dirs} /etc/munin/plugin-conf.d/"
+ dirs="${dirs} /etc/munin/munin-conf.d/"
+ dirs="${dirs} /etc/munin/plugins/"
+ keepdir ${dirs}
+
+ if use minimal; then
+ emake DESTDIR="${D}" install-common-prime install-node-prime \
+ install-plugins-prime
+ else
+ emake DESTDIR="${D}" install
+ fi
+ fowners munin:munin ${dirs}
+
+ insinto /etc/munin/plugin-conf.d/
+ newins "${FILESDIR}"/${PN}-2.0_rc-plugins.conf munin-node
+
+ # make sure we've got everything in the correct directory
+ insinto /var/lib/munin
+ newins "${FILESDIR}"/${PN}-2.0_rc-crontab crontab
+ newinitd "${FILESDIR}"/munin-node_init.d_2.0_rc munin-node
+ newconfd "${FILESDIR}"/munin-node_conf.d_2.0_rc munin-node
+ dodoc README ChangeLog INSTALL logo.eps logo.svg build/resources/apache*
+
+ # bug 254968
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/logrotate.d-munin munin || die
+}
+
+pkg_config() {
+ einfo "Press enter to install the default crontab for the munin master"
+ einfo "installation from /var/lib/munin/crontab"
+ einfo "If you have a large site, you may wish to customize it."
+ read
+ # dcron is very fussy about syntax
+ # the following is the only form that works in BOTH dcron and vixie-cron
+ crontab - -u munin </var/lib/munin/crontab
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} < 2 ]]; then
+ elog "Be aware that as of munin-2.0_rc4 you must use CGI, please read"
+ elog "the documentation at http://munin-monitoring.org/wiki/CgiHowto2"
+ fi
+ echo
+ if ! use minimal; then
+ elog "To have munin's cronjob automatically configured for you if this is"
+ elog "your munin master installation, please:"
+ elog "emerge --config net-analyzer/munin"
+ fi
+}