summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-ip4r/postgresql-ip4r-1.05.ebuild')
-rw-r--r--dev-db/postgresql-ip4r/postgresql-ip4r-1.05.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-db/postgresql-ip4r/postgresql-ip4r-1.05.ebuild b/dev-db/postgresql-ip4r/postgresql-ip4r-1.05.ebuild
new file mode 100644
index 0000000..986eff0
--- /dev/null
+++ b/dev-db/postgresql-ip4r/postgresql-ip4r-1.05.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_PN="${PN/postgresql-}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="IPv4 and IPv4 range index type for PostgreSQL"
+HOMEPAGE="http://pgfoundry.org/projects/ip4r"
+SRC_URI="http://pgfoundry.org/frs/download.php/2607/${MY_P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="|| (
+ >=dev-db/postgresql-base-8.2
+ >=dev-db/postgresql-server-8.2
+ )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake USE_PGXS=1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install || die
+ dodoc README.ip4r
+}