summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_geoip2/mod_geoip2-1.2.7.ebuild')
-rw-r--r--www-apache/mod_geoip2/mod_geoip2-1.2.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-apache/mod_geoip2/mod_geoip2-1.2.7.ebuild b/www-apache/mod_geoip2/mod_geoip2-1.2.7.ebuild
new file mode 100644
index 0000000..c328b05
--- /dev/null
+++ b/www-apache/mod_geoip2/mod_geoip2-1.2.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit apache-module
+
+MY_P="${PN}_${PV}"
+MY_PN="${PN/2}"
+
+DESCRIPTION="Apache 2.x module for finding the country and city
+that a web request originated from"
+HOMEPAGE="http://www.maxmind.com/app/mod_geoip"
+SRC_URI="http://geolite.maxmind.com/download/geoip/api/mod_geoip2/${MY_P}.tar.gz"
+LICENSE="Apache-1.1"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+SLOT="0"
+
+DEPEND="dev-libs/geoip"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# See apache-module.eclass for more information.
+APACHE2_MOD_CONF="30_${PN}"
+APACHE2_MOD_FILE="${S}/.libs/${MY_PN}.so"
+APXS2_ARGS="-l GeoIP -c ${MY_PN}.c"
+DOCFILES="INSTALL README README.php Changes"
+
+need_apache2