aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2011-05-26 09:02:25 -0500
committerDonnie Berkholz <dberkholz@gentoo.org>2011-05-26 09:03:04 -0500
commit338e9df0c0c9b94a81e8878f236ccd1b7a06ed4f (patch)
tree1bc9df54bec075fb7c952923d020b1fcb96f8bdd
parentrefmac: merged to main tree. (diff)
downloaddberkholz-338e9df0c0c9b94a81e8878f236ccd1b7a06ed4f.tar.gz
dberkholz-338e9df0c0c9b94a81e8878f236ccd1b7a06ed4f.tar.bz2
dberkholz-338e9df0c0c9b94a81e8878f236ccd1b7a06ed4f.zip
rdkit: new ebuild, mostly broken work-in-progress.
-rw-r--r--sci-chemistry/rdkit/Manifest2
-rw-r--r--sci-chemistry/rdkit/rdkit-2010.2.1.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/rdkit/Manifest b/sci-chemistry/rdkit/Manifest
new file mode 100644
index 0000000..1984118
--- /dev/null
+++ b/sci-chemistry/rdkit/Manifest
@@ -0,0 +1,2 @@
+DIST RDKit_Q22010_1.tgz 9816639 RMD160 baa227dd08438a11dce7e720006db5c865c3914e SHA1 1d2931041e1f205ef43a661102a062353f3afd6f SHA256 58cc0757ecd2ddd1f33fc860f296da69ac281d512d00a6cd9340a9e596a4e0ee
+EBUILD rdkit-2010.2.1.ebuild 1055 RMD160 1ef777fc55276e4afd34b02c3c8de084814ccef5 SHA1 f70bb5fe8951a20115d9fbaade5c7fb25cb9331a SHA256 cd4aac33eb5fdec6e05d95ba270b76f971779fca16a08f9378a7b386ef410064
diff --git a/sci-chemistry/rdkit/rdkit-2010.2.1.ebuild b/sci-chemistry/rdkit/rdkit-2010.2.1.ebuild
new file mode 100644
index 0000000..e3a4984
--- /dev/null
+++ b/sci-chemistry/rdkit/rdkit-2010.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+CMAKE_MIN_VERSION=2.8
+
+inherit cmake-utils versionator
+
+MAJOR_V=$(get_version_component_range 1)
+Q_V=$(get_version_component_range 2)
+MICRO_V=$(get_version_component_range 3)
+MY_P="RDKit_Q${Q_V}${MAJOR_V}_${MICRO_V}"
+
+DESCRIPTION="www.rdkit.org/"
+HOMEPAGE="A software suite for cheminformatics, computational chemistry, and predictive modeling"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+LICENSE="BSD-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND=">=dev-lang/python-2.5
+ dev-db/sqlite:3
+ dev-python/numpy
+ dev-python/imaging
+ dev-python/matplotlib
+ dev-python/aggdraw
+ >=dev-libs/boost-1.40"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ pushd ${CMAKE_BUILD_DIR} >/dev/null
+ sqlite3 ../Data/RDTests.sqlt < ../rdkit/Dbase/test_data/RDTests.sqlite || die
+ sqlite3 ../Data/RDData.sqlt < ../rdkit/Dbase/test_data/RDData.sqlite || die
+ ctest || die "Tests failed"
+ popd >/dev/null
+}