aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-02-22 10:58:56 -0800
committerDonnie Berkholz <dberkholz@gentoo.org>2008-02-22 10:58:56 -0800
commitfa8e0c7e2803c484d524a07b89166e1ca6732476 (patch)
treededeed025c18a9e7f90de7a2753e9b282c14770c /sci-chemistry/mopac2007-bin
parentDrop some old pymol files (diff)
downloaddberkholz-fa8e0c7e2803c484d524a07b89166e1ca6732476.tar.gz
dberkholz-fa8e0c7e2803c484d524a07b89166e1ca6732476.tar.bz2
dberkholz-fa8e0c7e2803c484d524a07b89166e1ca6732476.zip
Add initial ebuild for mopac2007.
Diffstat (limited to 'sci-chemistry/mopac2007-bin')
-rw-r--r--sci-chemistry/mopac2007-bin/Manifest3
-rw-r--r--sci-chemistry/mopac2007-bin/metadata.xml5
-rw-r--r--sci-chemistry/mopac2007-bin/mopac2007-bin-8.032.ebuild30
3 files changed, 38 insertions, 0 deletions
diff --git a/sci-chemistry/mopac2007-bin/Manifest b/sci-chemistry/mopac2007-bin/Manifest
new file mode 100644
index 0000000..ffaafd8
--- /dev/null
+++ b/sci-chemistry/mopac2007-bin/Manifest
@@ -0,0 +1,3 @@
+DIST MOPAC_for_Linux_8_032.zip 1088948 RMD160 4161dd1a45ab743eeef5aa657f944cd9a23f3381 SHA1 b47389e2fdbed48b13bd05fd6ff8a0ef8af468e9 SHA256 cb468653870ee2c0d36c70c7feba45e1bb561cd579b9b4f2ae33831e6c1b326c
+EBUILD mopac2007-bin-8.032.ebuild 1551 RMD160 1f3d86ab853883affb685470ac4693cdd8b4bb81 SHA1 26ea8ea9cb6053c7706a9367d087af5092f66d12 SHA256 b999e3bafe3c423dec61c8e5226cc1d4f76591fd48930d6d59b9428d0f0b95a6
+MISC metadata.xml 166 RMD160 4452298fd03e7c9395d1182bfe69d60a14144af6 SHA1 cb0b513473c0348f4f6f6cd9a132e4884155fddb SHA256 84c92b49702daf95eace8d2765215cbd8650da4ef776f9f700b5ce3785dec852
diff --git a/sci-chemistry/mopac2007-bin/metadata.xml b/sci-chemistry/mopac2007-bin/metadata.xml
new file mode 100644
index 0000000..9ac9ffd
--- /dev/null
+++ b/sci-chemistry/mopac2007-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/mopac2007-bin/mopac2007-bin-8.032.ebuild b/sci-chemistry/mopac2007-bin/mopac2007-bin-8.032.ebuild
new file mode 100644
index 0000000..fec738f
--- /dev/null
+++ b/sci-chemistry/mopac2007-bin/mopac2007-bin-8.032.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.10-r1.ebuild,v 1.4 2006/12/14 00:27:25 je_fro Exp $
+
+DESCRIPTION="Powerful, fast semi-empirical package"
+HOMEPAGE="http://openmopac.net/"
+SRC_URI="http://openmopac.net/MOPAC_for_Linux_8_032.zip"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S=${WORKDIR}
+
+pkg_setup() {
+ # We need a license number to proceed
+ if [[ -z ${MOPAC_LICENSE} ]]; then
+ msg="You must set MOPAC_LICENSE to your license number in make.conf."
+ ewarn "$msg"
+ die "$msg"
+ fi
+}
+
+src_install() {
+ into /opt/${PN}
+ newexe MOPAC2007.out ${PN} || die
+ touch "${T}"/${MOPAC_LICENSE} || die
+ doins "${T}"/${MOPAC_LICENSE} || die
+}