aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-03-24 15:23:07 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2008-03-24 15:23:07 -0700
commit152b4a1a67c1b9873b2b6bd6e8e496ab69a2bf03 (patch)
tree1e98d14c7d42554bcee9fed39674c4844b4230e5 /sci-libs
parentpbs-python: merged to main tree. (diff)
downloaddberkholz-152b4a1a67c1b9873b2b6bd6e8e496ab69a2bf03.tar.gz
dberkholz-152b4a1a67c1b9873b2b6bd6e8e496ab69a2bf03.tar.bz2
dberkholz-152b4a1a67c1b9873b2b6bd6e8e496ab69a2bf03.zip
vcg: add dep of qutemol.
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vcg/Manifest1
-rw-r--r--sci-libs/vcg/qutemol.cfg99
-rw-r--r--sci-libs/vcg/vcg-9999.ebuild29
3 files changed, 129 insertions, 0 deletions
diff --git a/sci-libs/vcg/Manifest b/sci-libs/vcg/Manifest
new file mode 100644
index 0000000..260e4f8
--- /dev/null
+++ b/sci-libs/vcg/Manifest
@@ -0,0 +1 @@
+EBUILD vcg-9999.ebuild 643 RMD160 6e0488f347cb3994f45bfe81b58a05ba8fc8122f SHA1 62ed42dd7ba8364f0fbc452f38c3191016e083ce SHA256 6829bc2718708aae11e1f541fe4284add6438b9f3f95767972100b9090ec3ee1
diff --git a/sci-libs/vcg/qutemol.cfg b/sci-libs/vcg/qutemol.cfg
new file mode 100644
index 0000000..10abe74
--- /dev/null
+++ b/sci-libs/vcg/qutemol.cfg
@@ -0,0 +1,99 @@
+TSIZE = 1024
+ \\ favoured texture size for molecule
+ \\ (default: 1024 )
+
+MAX_TSIZE = 2048
+ \\ maximal texture size (used when molecule too large for TSIZE)
+ \\ (default: 2048 )
+
+N_VIEW_DIR = 128
+ \\ number of view directions ussed in AO computation
+ \\ (default: 128 )
+
+SHADOWMAP_SIZE = 1024
+ \\ texture size for shadowmap
+ \\ (default: 1024 )
+
+AOSM_SIZE = 256
+ \\ texture size for shadowmmaps for AO computation
+ \\ (default: 256 )
+
+MOVING_QUALITY = 100
+ \\ Quality of image on screen when molecole moves (between 50..200)
+ \\ (default: 100 )
+
+STILL_QUALITY = 200
+ \\ Quality of image on screen when molecole is still (between 50..200)
+ \\ (default: 200 )
+
+doubleSM = 1
+ \\ if 1, use double ShadomMap optimization (two way lights)
+ \\ (default: 1 )
+
+NVIDIA_PATCH = 0
+ \\ use 1 - *AND* disable doubleSM - to patch a bug reported on some Nvidia cards (warning: lowers visual quality!)
+ \\ (default: 0 )
+
+SNAP_SIZE = 1024
+ \\ snapshots resolution (per side)
+ \\ (default: 1024 )
+
+SNAP_ANTIALIAS = 1
+ \\ if 1, antialias exported snapshots
+ \\ (default: 1 )
+
+PNG_TRANSPARENT = 0
+ \\ if 1, save PNG images with tranparent background
+ \\ (default: 0 )
+
+GIF_SNAP_SIZE = 256
+ \\ resolution of exported GIF animations
+ \\ (default: 256 )
+
+ \\ PARAMETERS FOR GIF ANIMATION
+ \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
+
+GIF_INITIAL_PAUSE = 0
+ \\ initial pause in msec before each animation loop
+ \\ (default: 0 )
+
+GIF_ANIMATION_MODE = 0
+ \\ if 0: full rotation. If 1: inspection mode (rotation around current viewpoint). If 2: six-views show.
+ \\ (default: 0 )
+
+GIF_ROT_N_FRAMES = 60
+ \\ number of frames of exported GIF animations (for full rotation)
+ \\ (default: 60 )
+
+GIF_GIF_ROT_MSEC = 3000
+ \\ total duration in msec of GIF animations loop (for full rotation)
+ \\ (default: 3000 )
+
+GIF_GIF_ROT_SIDEVIEW_ANGLE = 10
+ \\ angle (in -45 +45). If 0, perfect side rotation; if >0, look from above; if <0, look from below (for full rotation)
+ \\ (default: 10 )
+
+GIF_INSP_N_FRAMES = 60
+ \\ number of frames of exported GIF animations (for inspections)
+ \\ (default: 60 )
+
+GIF_INSP_MSEC = 3000
+ \\ total duration in msec of GIF animations loop (for inspections)
+ \\ (default: 3000 )
+
+GIF_INSP_ANGLE = 10
+ \\ in (10..45). Animation is an inspection around current view point (for inspections)
+ \\ (default: 10 )
+
+GIF_6SIDES_N_FRAMES = 10
+ \\ number of frames of exported GIF animations (for six-views show)
+ \\ (default: 10 )
+
+GIF_6SIDES_MSEC = 400
+ \\ duration in msec of each face shift (for six-views show)
+ \\ (default: 400 )
+
+GIF_6SIDES_PAUSE = 1000
+ \\ pause in msec after each face shift (for six-views show)
+ \\ (default: 1000 )
+
diff --git a/sci-libs/vcg/vcg-9999.ebuild b/sci-libs/vcg/vcg-9999.ebuild
new file mode 100644
index 0000000..da1646e
--- /dev/null
+++ b/sci-libs/vcg/vcg-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ECVS_SERVER="vcg.cvs.sourceforge.net:/cvsroot/vcg"
+ECVS_MODULE="vcg"
+
+inherit cvs
+
+DESCRIPTION="A portable C++ templated library for manipulation, processing and displaying triangle and tetrahedral meshes with OpenGL"
+HOMEPAGE="http://vcg.sourceforge.net/"
+SRC_URI=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ true
+}
+
+src_install() {
+ find . -type d -name CVS | xargs rm -rf || die
+
+ dodir /usr/include || die
+ treecopy vcg/{vcg,wrap} "${D}"/usr/include/ || die
+}