aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <donnie@supernova.(none)>2006-04-17 22:30:24 -0700
committerDonnie Berkholz <donnie@supernova.(none)>2006-04-17 22:30:24 -0700
commitb084e8250f714a5d67587f1d43f40d5774d25643 (patch)
treebc819fff34c32bd0c8c4c68df3a846f0b47316ca /sys-cluster
downloaddberkholz-b084e8250f714a5d67587f1d43f40d5774d25643.tar.gz
dberkholz-b084e8250f714a5d67587f1d43f40d5774d25643.tar.bz2
dberkholz-b084e8250f714a5d67587f1d43f40d5774d25643.zip
Initial commit of portage overlay.
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild.old84
1 files changed, 84 insertions, 0 deletions
diff --git a/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild.old b/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild.old
new file mode 100644
index 0000000..2bf6cca
--- /dev/null
+++ b/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild.old
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic fortran
+
+MY_P=${P/_}
+DESCRIPTION="MPICH 2 - A portable MPI implementation, version 2"
+HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich2"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${MY_P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="fortran f90 threads"
+
+DEPEND="virtual/libc
+ >=dev-lang/python-2.2.3
+ dev-python/pyxml
+ dev-libs/expat"
+
+RDEPEND="${DEPEND}
+ !sys-cluster/lam-mpi"
+
+S=${WORKDIR}/${MY_P}
+
+# Allowed Fortran compilers
+FORTRAN="g77 ifc"
+
+pkg_setup() {
+ if [ -n "${MPICH2_CONFIGURE_OPTS}" ]; then
+ einfo "Custom configure options are ${MPICH2_CONFIGURE_OPTS}."
+ fi
+
+ if use fortran; then
+ fortran_pkg_setup
+ fi
+}
+
+src_compile() {
+ if use fortran; then
+ export F77=${FORTRANC}
+ fi
+
+ local myconf="${MPICH2_CONFIGURE_OPTS}"
+
+ append-ldflags -Wl,-z,now
+
+ # Can't assume f90 is available if f77 is
+ if use fortran; then
+ myconf="${myconf} --enable-f77"
+
+ if use f90; then
+ myconf="${myconf}--enable-f90"
+ ewarn "Only >=gcc-4 supports Fortran 90."
+ fi
+ else
+ myconf="${myconf} --disable-f77 --disable-f90"
+ fi
+
+ if use threads; then
+ myconf="${myconf} --enable-threads"
+ fi
+
+ econf \
+ ${myconf} \
+ --with-common-prefix=/usr/share/mpich2 \
+ --with-arch=LINUX \
+ --sysconfdir=/etc/mpich2 \
+ || die "configure failed"
+# --with-wwwdir=${D}/usr/share/doc/${PF}/html \
+# --disable-mpe \
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ # Fix mpe2 includes
+ export PREFIX="${D}/usr"
+
+ einstall \
+ includedir="${D}/usr/include" || die "make install failed"
+# make DESTDIR=${D} install || die "make install failed"
+ dodoc README COPYRIGHT
+}