summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-02-03 20:44:19 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-02-03 20:44:19 +0000
commitf946734b204f3db46a5db2a407bd8af413a4f8fe (patch)
tree58c2b6b98e9c03ad1dee5599ee35e979f09e5d72 /net-analyzer
parentnagios-3.0_rc2 (diff)
downloaddertobi123-f946734b204f3db46a5db2a407bd8af413a4f8fe.tar.gz
dertobi123-f946734b204f3db46a5db2a407bd8af413a4f8fe.tar.bz2
dertobi123-f946734b204f3db46a5db2a407bd8af413a4f8fe.zip
nagios-3.0_rc2
svn path=/; revision=22
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-core/nagios-core-3.0_rc2.ebuild267
-rw-r--r--net-analyzer/nagios/nagios-3.0_rc2.ebuild27
2 files changed, 294 insertions, 0 deletions
diff --git a/net-analyzer/nagios-core/nagios-core-3.0_rc2.ebuild b/net-analyzer/nagios-core/nagios-core-3.0_rc2.ebuild
new file mode 100644
index 0000000..c7aba86
--- /dev/null
+++ b/net-analyzer/nagios-core/nagios-core-3.0_rc2.ebuild
@@ -0,0 +1,267 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-2.9-r1.ebuild,v 1.4 2007/08/01 21:00:26 marineam Exp $
+
+inherit eutils apache-module toolchain-funcs
+
+MY_P=${PN/-core}-${PV/_rc/rc}
+DESCRIPTION="Nagios Core - Check daemon, CGIs, docs"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz
+ mirror://gentoo/nagios-2.0b.cfg-sample.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="apache2 lighttpd perl debug"
+# mysql postgres
+DEPEND="virtual/mailx
+ apache2? (
+ ${NEED_APACHE_DEPEND}
+ >=media-libs/jpeg-6b-r3
+ >=media-libs/libpng-1.2.5-r4
+ >=media-libs/gd-1.8.3-r5
+ perl? ( net-analyzer/traceroute )
+ )
+ lighttpd? (
+ www-servers/lighttpd )
+ >=media-libs/jpeg-6b-r3
+ >=media-libs/libpng-1.2.5-r4
+ >=media-libs/gd-1.8.3-r5
+ perl? ( net-analyzer/traceroute )
+ perl? ( >=dev-lang/perl-5.6.1-r7 )
+ >=dev-libs/glib-2"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ # Check if gd has been compiled with jpeg and png support
+ if use apache2 || lighttpd; then
+ if ! built_with_use media-libs/gd jpeg png; then
+ eerror "Your gd has been compiled without jpeg and/or png support."
+ eerror "Please re-emerge gd:"
+ eerror "# USE="jpeg png" emerge gd"
+ die "pkg_setup failed"
+ fi
+ fi
+
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/2.x-series-nsca.patch
+
+ local strip="$(echo '$(MAKE) strip-post-install')"
+ sed -i -e "s:${strip}::" {cgi,base}/Makefile.in || die "sed failed in Makefile.in"
+}
+
+src_compile() {
+ local myconf
+
+ if use perl
+ then
+ myconf="${myconf} --enable-embedded-perl --with-perlcache"
+ fi
+
+ if use debug; then
+ myconf="${myconf} --enable-DEBUG0"
+ myconf="${myconf} --enable-DEBUG1"
+ myconf="${myconf} --enable-DEBUG2"
+ myconf="${myconf} --enable-DEBUG3"
+ myconf="${myconf} --enable-DEBUG4"
+ myconf="${myconf} --enable-DEBUG5"
+ fi
+
+ if use !apache2 && use !lighttpd ; then
+ myconf="${myconf} --with-command-grp=nagios"
+ else
+ if use apache2 ; then
+ myconf="${myconf} --with-command-grp=apache"
+ myconf="${myconf} --with-httpd-conf=/etc/apache2/conf.d"
+ fi
+ if use lighttpd ; then
+ myconf="${myconf} --with-command-grp=lighttpd"
+ fi
+ fi
+
+ econf ${myconf} \
+ --prefix=/usr \
+ --bindir=/usr/sbin \
+ --sbindir=/usr/lib/nagios/cgi-bin \
+ --datadir=/usr/share/nagios/htdocs \
+ --localstatedir=/var/nagios \
+ --sysconfdir=/etc/nagios \
+ --libexecdir=/usr/lib/nagios/plugins \
+ || die "./configure failed"
+
+ #--with-lockfile=/var/run/nagios2/nagios2.pid
+
+
+ emake CC=$(tc-getCC) nagios || die "make failed"
+
+ if use apache2 || use lighttpd ; then
+ # Only compile the CGI's if any of the web backends is set.
+ make CC=$(tc-getCC) DESTDIR="${D}" cgis || die
+ fi
+
+ emake -C contrib all || "contrib make filed"
+
+}
+
+src_install() {
+ dodoc Changelog INSTALLING LEGAL LICENSE README UPGRADING
+ docinto contrib
+ dodoc contrib/README
+
+ if use !apache2 && use !lighttpd; then
+ sed -i -e 's/cd $(SRC_CGI) && $(MAKE) $@/# line removed due to use flag/' \
+ -e 's/cd $(SRC_HTM) && $(MAKE) $@/# line removed due to use flag/' \
+ Makefile
+ fi
+
+ sed -i -e 's/^contactgroups$//g' Makefile
+
+ make DESTDIR="${D}" install
+ make DESTDIR="${D}" install-config
+ make DESTDIR="${D}" install-commandmode
+
+
+# docinto sample-configs
+# dodoc "${D}"/etc/nagios/*
+# rm "${D}"/etc/nagios/*
+
+# newdoc ${WORKDIR}/nagios-2.0b.cfg-sample nagios.cfg-sample
+
+ #contribs are not configured by the configure script, we'll configure them overselves...
+ find "${S}"/contrib/ -type f | xargs sed -e 's:/usr/local/nagios/var/rw:/var/nagios/rw:;
+ s:/usr/local/nagios/libexec:/usr/nagios/libexec:;
+ s:/usr/local/nagios/etc:/etc/nagios:;
+ s:/usr/local/nagios/sbin:/usr/nagios/sbin:;' -i
+
+ insinto /usr/share/doc/${PF}/contrib
+ doins -r contrib/eventhandlers
+
+ doinitd "${FILESDIR}"/nagios || die "Error adding nagios init script"
+ newconfd "${FILESDIR}"/conf.d nagios \
+ || die "Error adding nagios init script configuration"
+
+ chmod 644 "${S}"/contrib/*.cgi
+ into /usr/nagios
+ for bin in `find contrib/ -type f -perm 0755 -maxdepth 1` ; do
+ dobin "$bin"
+ done
+
+ # Apache Module
+ if use apache2; then
+ insinto "${APACHE2_MODULES_CONFDIR}"
+ doins "${FILESDIR}"/99_nagios.conf \
+ || die "Error adding configuration files for apache"
+
+ if use perl; then
+ into /usr/nagios ; dosbin contrib/traceroute.cgi
+ fi
+ fi
+
+ # Lighttpd Module
+ if use lighttpd; then
+ insinto /etc/lighttpd
+ newins "${FILESDIR}/lighttpd_nagios.conf" nagios.conf
+ fi
+
+ for dir in etc/nagios var/nagios ; do
+ chown -R nagios:nagios "${D}/${dir}" || die "Failed chown of ${D}/${dir}"
+ done
+
+ chown -R root:root "${D}"/usr/lib/nagios
+ find "${D}"/usr/lib/nagios -type d -print0 | xargs -0 chmod 755
+ find "${D}"/usr/lib/nagios/cgi-bin -type f -print0 | xargs -0 chmod 755
+# find "${D}"/usr/nagios/share -type f -print0 | xargs -0 chmod 644
+
+ chown root:root "${D}"/usr/lib/nagios
+ chown root:root "${D}"/usr/lib/nagios/cgi-bin
+
+ chown nagios:nagios "${D}"/var/nagios/spool/checkresults
+ chmod 640 "${D}"/var/nagios/spool/checkresults
+
+ keepdir /etc/nagios
+ keepdir /var/nagios
+ keepdir /var/nagios/archives
+ keepdir /usr/nagios/share/ssi
+ keepdir /var/nagios/rw
+ keepdir /var/nagios/spool/checkresults
+
+ if use !apache2 && use !lighttpd; then
+ chown -R nagios:nagios "${D}"/var/nagios/rw || die "Failed chown of ${D}/var/nagios/rw"
+ else
+ if use apache2 ; then
+ chown -R nagios:apache "${D}"/var/nagios/rw || die "Failed chown of ${D}/var/nagios/rw"
+ fi
+ if use lighttpd ; then
+ chown -R nagios:lighttpd "${D}"/var/nagios/rw || die "Failed chown of ${D}/var/nagios/rw"
+ fi
+ fi
+
+ chmod ug+s "${D}"/var/nagios/rw || die "Failed chmod of ${D}/var/nagios/rw"
+ chmod 0750 "${D}"/etc/nagios || die "Failed chmod of ${D}/etc/nagios"
+
+ cat << EOF > "${T}"/55-nagios-core-revdep
+SEARCH_DIRS="/usr/nagios/bin /usr/nagios/libexec"
+EOF
+
+ insinto /etc/revdep-rebuild
+ doins "${T}"/55-nagios-core-revdep
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The example config files are located at /usr/share/doc/${PF}/sample-configs/."
+ einfo
+ einfo "Also, if you want nagios to start at boot time"
+ einfo "remember to execute:"
+ einfo " rc-update add nagios default"
+ einfo
+
+ if use !apache2 || use !lighttpd; then
+ einfo "This does not include cgis that are perl-dependent"
+ einfo "Currently traceroute.cgi is perl-dependent"
+ einfo "To have ministatus.cgi requires copying of ministatus.c"
+ einfo "to cgi directory for compiling."
+
+ einfo " Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
+
+ einfo
+ einfo "That will make nagios's web front end visable via"
+ einfo "http://localhost/nagios/"
+ einfo
+ einfo "Note that the user your webserver is running at needs"
+ einfo "read-access to /etc/nagios. There are several possible"
+ einfo "solutions to accomplish this, choose the one you are"
+ einfo "most comfortable with:"
+ einfo " usermod -G nagios apache"
+ einfo "or"
+ einfo " chown nagios:apache /etc/nagios"
+
+ else
+ einfo "Please note that you have installed Nagios without web interface."
+ einfo "Please don't file any bugs about having no web interface when you do this."
+ einfo "Thank you!"
+ fi
+
+ einfo
+ einfo "If your kernel has /proc protection, nagios"
+ einfo "will not be happy as it relies on accessing the proc"
+ einfo "filesystem. You can fix this by adding nagios into"
+ einfo "the group wheel, but this is not recomended."
+ einfo
+
+ einfo
+ ewarn "Use /usr/nagios/bin/convertcfg for configuration file conversion"
+}
+
+pkg_prerm() {
+ /etc/init.d/nagios stop
+}
diff --git a/net-analyzer/nagios/nagios-3.0_rc2.ebuild b/net-analyzer/nagios/nagios-3.0_rc2.ebuild
new file mode 100644
index 0000000..055d5cc
--- /dev/null
+++ b/net-analyzer/nagios/nagios-3.0_rc2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-2.9.ebuild,v 1.2 2007/07/11 23:49:24 mr_bones_ Exp $
+
+DESCRIPTION="The Nagios metapackage - merge this to pull install all of the
+nagios packages"
+HOMEPAGE="http://www.nagios.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="~net-analyzer/nagios-core-${PV}
+ >=net-analyzer/nagios-plugins-1.4.11-r100
+ >=net-analyzer/nagios-imagepack-1.0"
+
+pkg_postrm() {
+ elog "Note: this is a META ebuild for ${P}."
+ elog "to remove it completely or before re-emerging"
+ elog "either use 'depclean', or remove/re-emerge these packages:"
+ elog
+ for dep in ${RDEPEND}; do
+ elog " ${dep}"
+ done
+ echo
+}